LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-27-2006, 09:04 AM   #1
aureus620
LQ Newbie
 
Registered: Nov 2006
Posts: 3

Rep: Reputation: 0
Multiple monitors on kubuntu edgy issues / x server not found


Hello folks, I'm having a few issues getting xorg working properly on my laptop (Sager NP9860). Video card is a Nvidia Geforce go6800; attached LCD is 17" 1680x1050, and external monitor is a dell 2001FP, 1600x1200 resolution.

The problem i'm having is, after a couple hours of playing with the nvidia drivers and compiling the kernel modules, the X windows session will only display on the laptop LCD. What I need is for the laptop display to not be used, and the display to show up on the 2001FP. Also, the resolution seems stuck at 1024x768, nomatter what I do.

And to top it all off, I'm getting a nice error of "Cannot connect to X server 0:0" whenever i try to run an application such as xemacs (although firefox and every program from the KDE panel function fine)

Any help would be greatly appreciated. Below is the contents of my xorg.conf file



Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "extmod"
Load "freetype"
# Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Monitor"
Identifier "Dell 2001FP"
HorizSync 30.0 - 75.0
VertRefresh 50.0 - 85.0
Option "DPMS"
EndSection

Section "Device"
Identifier "NVIDIA GeForce go6800"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA GeForce go6800"
Monitor "Dell 2001FP"
DefaultDepth 24
Option "UseFBDev" "true"
SubSection "Display"
Depth 1
Modes "1600x1200" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1600x1200" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1600x1200" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1600x1200" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1600x1200" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1600x1200" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

 
Old 11-27-2006, 04:28 PM   #2
aureus620
LQ Newbie
 
Registered: Nov 2006
Posts: 3

Original Poster
Rep: Reputation: 0
bump.

Anyone have an idea?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Once more, Adept refuses to work properly on a Kubuntu Edgy Eft Laptop. supertunaman Ubuntu 3 12-02-2006 12:25 PM
Kubuntu Edgy AMD64 wont install Mark_667 Ubuntu 4 11-28-2006 09:53 AM
k-mail from Kubuntu 606 to Kubuntu "edgy" impeteperry Ubuntu 2 11-08-2006 04:27 AM
XGL in Kubuntu edgy with an opensource driver, anyone??? JaseP Ubuntu 2 10-14-2006 12:54 PM
LXer: First Look: Kubuntu Edgy Eft Beta LXer Syndicated Linux News 0 10-02-2006 12:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration