-   Linux - Hardware (
-   -   MS Wireless Intellimouse Explorer and Slackware 9.0 (

sambartle 03-27-2003 06:09 AM

MS Wireless Intellimouse Explorer and Slackware 9.0
I have a Microsoft Wireless Intellimouse Explorer (USB Only), and i had everything set-up perfectly in slackware 9.0 (RC1), all buttons were working, and the wheel functioned correctly.

The XF86Config:
device /dev/input/mice
protocol ExplorerPS/2
buttons 7
ZAxisMapping 6 7

and xmodmap -e "pointer 1 2 3 6 7 4 5" to get all the buttons in order.

Now i have upgraded to Slackware 9.0 (Final Release) and the mouse has gone crazy. Left and Right movement cause the pointer to go up and down the screen, and change desktops on fluxbox.

Up and Down movement work but very slowly.

Clicking any button (all 7) and moving the wheel makes the pointer jump in small increments to the right.

Does any one have any ideas why? (i know there is a similar post on this board, but i think this is a different problem, as i know how to set up the mouse (it was perfect in Slack9.0 (RC1) )

Im more interested in what has changed in Slack 9.0 (Release) to kill my mouse.


jetblackz 03-27-2003 10:59 AM

I'm not sure, but strange things happened to me. init mode changed. X seems to become picky.

sambartle 03-30-2003 08:40 AM

Aussie, could you have a quick look at this.

Since you have slack 9.0, i was wondering if you knew what has changed with the mouse handling code?


nokiaxv2 04-05-2003 08:24 PM

having the same issue...
I was wondering if you've found a solution to this yet? I'm currently experiencing the exact same issues. Not exactly sure what I can do to fix it or "substitute" the problem....

Thanks in Advance....

sambartle 04-06-2003 07:01 AM

I believe i am close to fixing the problem, i have had it working perfectly once in slackware 9, and it still works 100% reliably in slackware 8.1 every time.

Which distribution are you using?


nokiaxv2 04-06-2003 08:51 PM

I'm using the final release of Slackware 9...

sambartle 04-07-2003 02:22 AM

I think that the problem has definitly only appeared in slackware 9.0 (Final Release) then, as in 9.0 (Release Candidate 1) there are no problems for me (did you try the RC1 before 9.0(final) was released? and did it work for you.)

Im just going to have a look at the changelog and see what has changed so i have a better idea of where to start looking.

I think it may be a Hotplug issue, but disabling it causes all kind of problems for me that id rather avoid ( aside from disabling the mouse completely as its USB and would need setting up seperate from hotplug - which i think would bring the same results as letting hotplug do the configuration )

Also im sure Hotplug isnt changed from the RC1 so it should work the same.
Ill edit this post (or repost) if i find anything interesting in the changelog.

nokiaxv2 04-07-2003 02:29 AM

Linux 9 RC1

I've never used RC1...I've read a few forums where this problem does happen in Mandrake 9 as well. I think and this forum as well.

It is rather frustrating because I've grown to like the Slackware distro of Linux...however I'd like to soon get into making my own linux from scratch deal...might be checking into this a lot sooner than i had anticipated...Anyway,

I appreciate your help...hopefully someone will figure this out...

I disabled the hot swapple thing btw and for some reason, my mouse receiver didn't even have power coming to it...Was weird...Everything else had power though...Atleast my hub did. But my reciever for my mouse is plugged directly into my computer...instead of the hub...Any thoughts on this?

Aussie 04-07-2003 02:43 AM

You can stop hotplug from loading problem modules by added them to /etc/hotplug/blacklist

sambartle 04-07-2003 02:47 AM

There is either
1. no module loaded to support the mouse (hid.o, input.o and mousedev.o i think)
Im now guessing (because ive never used hotplug before) that the modules are loaded by hotplug (this is its purpose i believe, feel free to correct me anyone if im wrong) and so you will need to modprobe them yourself to load support for the mouse.

(although i *think* that power should be supplied even without HID drivers loaded, i might be wrong.)
Anyway give it a try

and look in /proc/bus/usb/devices for changes before and after you activate it if possible.

2. the USB driver for the PC isnt loaded (but of course if this hub is powered from another USB socket on the same bus as the one your mouse is in then this is already taken care of and so option 1 is the only solution)

sambartle 04-07-2003 02:49 AM

Aussie: Its not really a problem module i dont think, the problem is that the module is loaded but there is something wrong with its configuration since slackware 9.0 final.

The changelogs dont show any changes to hotplug that should affect this mouse, but in slackware 9.0 it has changed in some way.

Is there an easy way to compare 9(rc1)'s hotplug config to 9.0(release) dso you know?

Thanks for the help everyone.

Aussie 04-07-2003 03:03 AM

Any changes between rc1 and final will be in Changelog.txt.
Are you running gpm?
If you are then kill it and see if that helps.

sambartle 04-07-2003 03:36 AM

no gpm is not runnning.

i have checked the Changelog and there are a few mentions of Hotplug but from my very limited experience i dont think any of those should effect the Mouse handling.

My setup is exactly the same as i have always had with Slackware (9.0 RC1) where my mouse works fine, so i am nearly sertain it is a change in slackware rather than me configuring things incorrectly

Aussie 04-07-2003 03:57 AM

Well, I'm using the same mouse config I've had since I wrote the side button guide, using a five button no-name optical ps/2 mouse.
Check for dirt or a hair over the lens, a small hair once sent my mouse crazy.

yper 04-07-2003 05:57 AM

Good to se that i'm not alone with this problem.
Just installed Slackware 9 (final relese) to my PC and configured the
XF86Config (just like on top of this page) file just to notice that my mouse behavied the same as Sambartle.

I very big need of good help because i'm a complete newbie in linux. I guess that i'm running fluxbox got nothing to do with the issue.

All times are GMT -5. The time now is 11:13 AM.