LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 05-31-2011, 06:36 PM   #1
goodlight
LQ Newbie
 
Registered: Jul 2009
Posts: 2

Rep: Reputation: 0
Moved install to new System now, mkrootdev: lable /1 not found


I'm a major newbie, but our phone system is running asterisk. About a year ago, the motherboard/CPU failed, and i was able to just swap the hard drive into an old computer we had and it worked. (I know i got lucky).

Well, it's happened again, and I took the Hard drive from the old system and put it into a new one.

Now when it boots, i have the errors

Red hat nash version 4.2.15 starting
mkrootdev: label /1 not found
mount: error 2 mounting ext3
ERROR opening /dev/console!!!!: 2
Kernel panic - not syncing: Attempted to kill init!

I can get the system booted up on the old system, but hardware issue prevent me from using that system.
Any help you could offer would be tremendous.
 
Old 05-31-2011, 07:26 PM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
Is the new system substantially newer hardware? What linux kernel are you running on the old system (hint: uname -a)? What is the hardware of the old system and what is the new system (i.e. make/model of motherboard)?

My best guess is that there is no driver in the old linux kernel for the hard disk controller (i.e. the motherboard chipset) on the new system. If there's no driver present, the old linux install doesn't know what to do with a hard disk.

Last edited by pljvaldez; 05-31-2011 at 07:27 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Moved system files and system crashed soofi Linux - Newbie 4 02-03-2011 12:42 AM
kernel panic - mkrootdev: label /1 not found - when booting from newly compiled kerne the_shani Red Hat 7 05-21-2009 07:27 AM
mkrootdev: label /1 not found ... kernel panic bcg121 Fedora - Installation 2 09-26-2008 11:26 AM
mkrootdev: label \1 not found ahmed2008 Linux - Kernel 3 03-05-2008 06:43 AM
RH 7.1 install issue (no operating system found) mnapier Linux - Software 8 01-07-2002 10:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration