LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Mouse thumb button problem (https://www.linuxquestions.org/questions/linux-hardware-18/mouse-thumb-button-problem-433455/)

Black_Knight 04-09-2006 05:07 PM

Mouse thumb button problem
 
Hi,
I have recently acquired a strange problem with my USB Intellimouse in Linux. It used to be OK, not sure what happened.

The problem is that the thumb buttons no longer seem to function as back and forward when browsing the web. Instead both seem to function as a left click.
The mouse has 2 thumb buttons and a wheel.

I'm running Mandriva 2006, KDE 3.5, Kernel 2.6.
The InputDevice section of my xorg.conf contains:
Option "Protocol" "Auto"
Option "Buttons" "5"
Option "ZAxisMapping" "6 7"
although I have tried changing things in here but to no avail.

Any ideas appreciated.

Gethyn 04-09-2006 05:14 PM

I've not tried it personally, but perhaps this will help you.

Black_Knight 04-10-2006 03:56 PM

Thanks for the link which was helpful.
I managed to solve it in the end by adding the line

PHP Code:

xmodmap -"pointer = 1 2 3 8 9 4 5 6 7" 

to a startup script.
I'm not really sure what's going on here though - my mouse only has 7 buttons, including scroll up & scroll down, so not sure what the 8 & 9 are.
xev was previously reporting my thumb buttons as 8 and 9, wheel up/down as 4 and 5, and nothing for 6 & 7 before I added this line. Now it reports thumb as 6 & 7, with no 8 & 9.
(I also changed the buttons option to 7 in the xorg.conf file - not sure if this had any effect though)

If anyone really understands this, please post!


All times are GMT -5. The time now is 08:30 PM.