-   Linux - Hardware (
-   -   mouse partially stops working randomly... (

kahn 10-14-2008 02:51 PM

mouse partially stops working randomly...
Quick: My mouse will still move, but clicks don't do anything. I can still use all apps with the keyboard.

Current solution: Restart X.

Setup: Fedora 9, KDE(also happens in Fluxbox)

Variances: Logitech mouse at home, dell wired mouse at work, did run through a kvm, now directly plugged in, has no effect what-so-ever. Though the hardware is different both are running nvidia cards.

Logs: I've looked through the xorg.0.log, messages log and found nothing of any interest.

What didn't work: Switched to evdev mouse driver at work, no difference. Bypassed KVM, no difference, got new dell mouse, no difference.

So, if anybody can point me in the right direction to trouble shooting steps? I installed opera at home, and using opera VS. firefox seems to delay. Can't seem to pinpoint exact repro steps. Just general usage.

Firefox/pidgin/thunderbird/ktorrent , rdesktop at work

Let me know if you guys need any more info like my xorg.conf ...

kahn 10-16-2008 01:58 AM

Do I need to include more info to get a response or rephrase this?

kahn 10-28-2008 12:31 PM

I'm going to copy/paste because I wrote this a lot better on another forum.

What happens: I'm using the computer, surfing with firefox, thunderbird for email and some other apps. Then my mouse will stop working, it moves, but will not click. I can still use the keyboard and type in the various apps and switch using alt+tab. Switching VT's doesn't work. I can simply restart X and it starts working again.

What I've tried to no avail:

modprobe -r everything under modprode -l | grep mouse and modprobe it back
restarting everything I could 'usb' and 'mouse' (gpm included)
Switched mouse drivers in /etc/X11/XF86Config to 'evdev' and 'usb' both produced the same results.

I've checked dmesg , Xorg.0.log and messages and nothing of any use was in there.

Hardware wise, this is what throws me off...This happens at work on a intel dell box with a wired usb dell mouse. I swapped it for a new mouse, different USB ports, through the KVM, directly in the box, no change.

This also happens at home, where I have an amd custom build computer with a usb wireless logitech mouse.

The only common hardware between them are nvidia video cards. So, that and I'm sure lots of packages are common between them as well. But, my box isn't so weird that nobody else wouldn't have noticed this problem either. I'm pretty sure this happened when I wasn't using the kmod nvidia driver too, but it's been awhile, so I'd have to check again.

So, this has been going on for awhile, and is definitely one of the most annoying things.

If you guys can even point me in any kind of direction to getting this solved, that would be awesome.
Edit/Delete Message

Also, when I cat /dev/input/mice or anything related to the mouse in /by-id/ /by-device/ I get no output, but it works with the keyboard output.

Oxagast 10-29-2008 12:07 PM

Are you using the wired or wireless mouse right now? If your using the wireless it could be that your battery is dieing or its too far away from the receiver. Mine does that sometimes because of that.

kahn 10-29-2008 02:08 PM


Originally Posted by Oxagast (Post 3325174)
Are you using the wired or wireless mouse right now? If your using the wireless it could be that your battery is dieing or its too far away from the receiver. Mine does that sometimes because of that.

i understand what you're saying and have read that. But that is not the cause. At work this happens with a wired mouse, and at home it does it with 2 wireless mouses(different brands). When the mouse stops clicking, I've even tried to switch mice then, and the new mouse moves, but still doesn't click.

lelmo82 11-01-2008 02:15 PM

mouse partially stops working---
I have a "Thermaltake" optical USB wired mouse that got goofy on XP would stall for a while-then come back to life. It seems to be working full time on Fedora 9 now but when I had trouble I dug out an old Dell PS-2 mouse and installed it to the PS-2 port on the computer.They both work-I can switch from one to the other with seamless results.

Homemade desktop Asus AN8-SLI board AMD Athlon 64FX CPU one 74G SATA one (9.1G IBM SCSI one 30.8G IDE one CD-R one DVD-RW/R-RW two LeadTek (Nvidia) PX6800TDH video cards Linksys USB wireless adapter . Running Fedora 9, Ubuntu 8.10, various flavors of DOS.

kahn 11-26-2008 03:44 PM

So I'm going to update this: Yesterday I think I found the culprit. By disabling xinerama in the nvidia-settings and running one monitor, my mouse has had no issues what so ever.

kahn 12-04-2008 10:57 AM

sorry, last update. I've been using twinview at home and at work. so far no mouse issues whatsoever.

All times are GMT -5. The time now is 09:34 AM.