-   Linux - Hardware (
-   -   mouse not detected if not moved during startup (FC5) (

xsten 07-09-2006 09:47 AM

mouse not detected if not moved during startup (FC5)
Hello All,

I have troubles with my M$ intellimouse (part of m$ wireless optical desktop 1.0A).

This is a wireless mouse, connected to a receiver - the receiver has both PS/2 and USB connectors both ends are plugged to the PC : PS2 for keyboard and USB for mouse.

This config worked find under Fedora Core 1 (FC1), but since I upgraded to FC5, there is an annoying problem

- if I boot my PC normally (without touching anything), the mouse does not work (mouse stuck in the middle of the screen)

- if I boot my PC, and move my mouse during the startup (when the text bootmessages are shown on the screen) ... the mouse works

If I diff the two "dmesg" outputs, I see the lines
< input: Microsoft Microsoft Wireless Optical Desktop� 1.00 as /class/input/input2
< input: USB HID v1.11 Mouse [Microsoft Microsoft Wireless Optical Desktop� 1.00] on usb-0000:00:10.1-1

appearing only when mouse is detected.

Are-there any parameter I can pass to the kernel, or any initfile to modify in order to force the detection of the mouse ?


kg4ysy 07-10-2006 03:55 PM

did you try unpluggin the mouse and plugging it back in to see if it detects it after boot? This will help to rule out a couple of solutions.

xsten 07-12-2006 02:47 AM

Thanks kg4ysy - apparently the problem dissepeared today. I tried today 2-3 reboots, and the mouse was correctly detected... strange (I did not upgrade my system). I'll post a message if the problem arises again.

kg4ysy 07-12-2006 09:08 AM

That's Linux for you...the ever classic "I swear I did nothing"

Haha...I actually had a few cases of that yesterday.


xsten 07-20-2006 08:50 AM

Well... I know... Again I did nothing, and the bug came back -

I noticed during boot time (the very first lines of boot screens) that "udev" could not start :

starting udev.... [FAIL]

If I unplug and replug the USB connector of the mouse, it is not detected (still stuck in the middle of the screen).

All times are GMT -5. The time now is 08:13 PM.