-   Linux - Hardware (
-   -   mouse & keyboard stop working! (

shycalais 03-08-2004 10:57 PM

mouse & keyboard stop working!
well i'm in a slight dilema, neither my mouse or keyboard work when i'm trying to log into red hat 9. i have a usb mouse and ps2 keyboard, they all worked fine until i took my computer to a mates house and he used his keyboard and mouse... now NOTHING!

i have important stuff on there that i need to get off, i'm on my windows partition at the moment but can't access my linux partition...

any help would be appreciated??

Aussie 03-09-2004 05:29 AM

Have you asked your mate if he changed anything?

shycalais 03-10-2004 01:20 AM

i was there when he was playing around..
he didn't touch any settings..

could linux have remembered his mouse and keyboard and forgotten mine?
if this is the case, why doesn't red hat simply remember mine again when i restart??

i have lots of stuff on there i need! any suggestions how i can get this working again?

Aussie 03-10-2004 01:37 AM

Have a look in the bios, he may be playing a joke on you.

shycalais 03-10-2004 02:22 AM

nah he didn't go into the bios!
for example, at the gui signin, i have to reset the computer, then when i boot back up into redhat, it does something with the drive (because it wasn't shut down properly) my keyboard works to choose and navigate. its just in the gui or CLI signup

1kyle 03-10-2004 03:47 AM

Start up your rescue system / install system -- you should get eventually a menu "Repair existing system" or something like that -- I'm on SUSE but I'm sure REDHAT / Mandrake etc will have similar facilities.

You should be able to re-configure your mouse / keyboard.

fhol 03-19-2004 07:52 AM

Re: mouse & keyboard stop working!

Originally posted by shycalais
well i'm in a slight dilema, neither my mouse or keyboard work when i'm trying to log into red hat 9.
I'm having the same problem, but I'm using Fedora Core 1 with the latest updates. Everything was working fine and I was going to check some log files (after three-four hours of uptime) and I noticed that the keyboard (standard PS/2) had stopped working, just like that, while the system was still online. I couldn't figure it out so rebooted and hoped that it would resolve the problem but no. Keyboard is working fine in BIOS setup (and in Windows XP) but it refuses to work when I am prompted to login to Linux. The thing is that I have rebooted at least twice since I did my last "yum update" and I have had no problems at all earlier, and all of a sudden this happens. STRANGE!

Any help would be appreciated!


EDIT: Issue solved! I stepped thorough the interactive startup and found that the GPM, (console mouse driver) was causing the trouble.

All times are GMT -5. The time now is 09:51 PM.