LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   mounting troubles (https://www.linuxquestions.org/questions/linux-hardware-18/mounting-troubles-197837/)

ahimsel08 06-26-2004 12:05 AM

mounting troubles
 
heres the whole story. i installed WINE on my redhat 9 box. and i need to mount my windows filesystem. heres some directories

/home/andrew/.wine/fake_windows/

it says i need to mount it on a dos filesystem.. my problems are i can't run any programs because it can't access my DLL files... so i need to mount that directory on a DOS filesystem. but how do i do this???

here are my current mounts: (df @ the CLI)
Filesystem 1K-blockes Used Available Use& Mounted on
/dev/hda2 12523480 6399036 5488272 54% /
/dev/hda1 101089 23665 72205 25% /boot
none 127168 0 127168 0& /dev/shm

what do i need to do?

Bruce Hill 06-26-2004 07:12 AM

As a normal user issue
$ df -h
and then issue
$ cat /etc/fstab
and then as root issue
# fdisk -l
and post the output. In order for it to be readable in the forum, put [_code_] without the underscores before the output and [_/code_] without the underscores after the output. That will make it look like this
Code:

bash-2.05b# fdisk -l


Disk /dev/sda: 40.0 GB, 40007761920 bytes
64 heads, 32 sectors/track, 38154 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1              1      38154    39069680    c  W95 FAT32 (LBA)

Disk /dev/sdb: 131 MB, 131072000 bytes
9 heads, 32 sectors/track, 888 cylinders
Units = cylinders of 288 * 512 = 147456 bytes

  Device Boot      Start        End      Blocks  Id  System
/dev/sdb1  *          1        889      127983+  b  W95 FAT32
Partition 1 has different physical/logical endings:
    phys=(1000, 8, 32) logical=(888, 7, 31)

Disk /dev/hdc: 61.4 GB, 61492838400 bytes
255 heads, 63 sectors/track, 7476 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start        End      Blocks  Id  System
/dev/hdc1              1          10      80293+  83  Linux
/dev/hdc2              11        6332    50781465  83  Linux
/dev/hdc3            6333        6940    4883760  83  Linux
/dev/hdc4            6941        7476    4305420    5  Extended
/dev/hdc5            6941        7183    1951866  83  Linux
/dev/hdc6            7184        7305      979933+  83  Linux
/dev/hdc7            7306        7476    1373526  83  Linux

Disk /dev/hda: 61.4 GB, 61492838400 bytes
255 heads, 63 sectors/track, 7476 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start        End      Blocks  Id  System
/dev/hda1  *          1        1216    9767488+  7  HPFS/NTFS
/dev/hda2            1217        7476    50283450    f  W95 Ext'd (LBA)
/dev/hda5            1217        2432    9767488+  7  HPFS/NTFS
/dev/hda6            2433        4864    19535008+  7  HPFS/NTFS
/dev/hda7            4865        6688    14651248+  b  W95 FAT32
/dev/hda8            6689        7174    3903763+  b  W95 FAT32
/dev/hda9            7175        7296      979933+  82  Linux swap
/dev/hda10          7297        7476    1445818+  b  W95 FAT32
bash-2.05b#

except you probably won't have 4 drives.

I'm assuming you're running a dual-boot system.
If so, what is the Windoze system that you're running?
How was it partitioned?
How was it formatted?

motub 06-26-2004 08:48 AM

Hello, you guys are striking off in the wrong direction (sorry to say).

The thing is, if ahimsel08's wine directory is /home/andrew/.wine/fake_windows/, Wine is going to be using its own internal "dlls" (if created) whether the true Windows partition is mounted or not.

The only way it would be using the real Windows installation is if he had set up his Wine "fake c:" drive to point to the real Windows directory. This would, admittedly, require the Windows partition to be mounted, but my point is that with the current configuration, it's not going to matter, without some additional steps (either copying the Windows dlls, as I have done, or by changing the Wine configuration).

However, I'm by no means certain that this is completely necessary, as that error message is not being relayed clearly, and I'm not sure that it's really saying what you guys think it is.

I would like to see the contents of /home/andrew/.wine/config.

I would also like to know what you were doing, Andrew, when you got this error message, and exactly what it says.

I would also also like (wik, for you Monty Python and the Holy Grail fans) to see the contents of /etc/fstab.

Mounting the Windows partition may be as simple as mount /windows (depending what's in /etc/fstab) or a bit more complex, such as mount -t vfat /dev/hd* /mnt/windows (just an example), but it's not going to make much difference if that's not what Wine is talking about in the first place.

Bruce Hill 06-26-2004 08:52 AM

So Holly what are you running under Wine that runs correctly?

motub 06-26-2004 11:09 AM

Quote:

Originally posted by Chinaman
So Holly what are you running under Wine that runs correctly?
Not that much atm, as my CD-RW just came back from the shop, and I haven't put it back in the box yet. Plus, I don't play all "the latest and greatest" (though I'm planning to install some of it to see if it runs, which will be a big help in encouraging my boyfriend to switch).

But before the CD went down I had:

Installed and running (either currently, in the past, or both):

Double Deck Solitaire (which I really should add to the Wine Application Database)
Icewind Dale
Icewind Dale 2
Deus Ex
Fallout
SiN
(yes, I know that there's a Linux native version, but I own this and so does my boyfriend, so I really do not want to buy a third copy of this game)
Half-Life (plain; no Steam or expansions)
Thief Gold
Vampire: The Masquerade
(which was 3 kinds of a b*tch to get installed and patched, but it does work, or at least it starts and gives me a menu as if it's going to work; I actually didn't play it since I didn't have time to move my old saves over to the new install)

Installed but no chance to run or tweak if it wouldn't run (because I had to pull the CD-Drive):

Crystal Key 2
Painkiller


Would not install, but might well run if I transfer the Windows install (but haven't checked as I can't put in the CD) or upgraded my Wine version:

Dungeon Siege LOA

Runnable, but apparently only via WineX (but again, haven't checked to see if current versions of Wine might get running):

Morrowind, the only reason I still have a Windows drive really... ooh, wait, I see there's a loki installer for morrowind at loki installers for linux gamers. That's new.... and if it needed WineX, there would be no need for a Loki installer (since you could install with Point2Play, or just via WineX/Cedega itself). This is very hopeful!!!

Won't run, won't ever run-- so I need to give it up, or keep Windows for it:

The Sims + expansions (Transgaming sells a custom version of The Sims only which does run native, but the expansions don't, and won't ever. Doubt that the Sims2 will, either, dammit)

Are supposed to run, but I haven't tried yet (need more HDD space to install this stuff):

Max Payne 2
GTA 3
(bf)
GTA Vice City (bf)
Far Cry (4GB install!!!) (bf)
Anachronox
Arcanum:Of Steamworks and bla blah blah
(I think; hated this game immediately and hesitate to reinstall, but I believe it uses the Fallout 2 engine, and afaik, Fallout 2 works)
MoH (bf)
NFS : Underground (bf)
Mafia (bf)
Star Trek Elite Forces 2 (bf)
Command and Conquer Red Alert 2 (bf, hope he'll be satisfied with that as Renegade and Generals don't seem to be working, at least under WineX/Cedega)
CoD (bf)
Oddworld: Abe's Oddysey (never finished, so I'd like to)

Are supposed to run but are very troublesome to actually get working (under current versions of Windows as well):

Septerra Core
System Shock 2


Waiting for Wine(X) DX 9 support to be implemented before I expect these to run (but not tested):

Uru: Ages Beyond Myst (and probably Crystal Key 2 and Painkiller as well, though, if Far Cry works..... anything is possible)

Stuff I might need a DOS emulator for, not sure yet as untested:

Betrayal at Krondor

but if I can't get that to work (which would really make me sad), I can always see if Betrayal at Antarra will work under Wine. Probably will, but it's just not the same).

Stuff I really don't know the (current) status of:

Final Fantasy 7 (which I never finished)
Operation Flashpoint Cold War Crisis (bf)
Battlefield: Vietnam (though BF 1942 is supposed to run) (bf)
Ghost Recon 2 (bf)
Broken Sword 3
Little Big Adventure
(although LBA2 is supposed to run)
Lose Your Marbles (which I would really like to have running)
Prince of Persia Sands of Time
The Omega Stone
Jack The Ripper
CSI 2
Knights of the Temple
ToEE
(which apparently sucked, but hey, maybe I want to see for myself)
Sacred
The Egyptian Prophecy
The Longest Journey
(just because it was a lovely experience to play)
Syberia I (again, just because)

Don't seem like they're ever going to run (but haven't tried older versions, hackarounds or waited for DX 9 support, or other improvements to current support):

Pretty Good Solitaire (which is a shame as it's the only collection that contains Josephine, afaik, but I should write to the GNOME-games devels and ask them to add it to AisleRiot, which is otherwise fine-- though I have to play PySol to play Simple Simon)
Dink Smallwood (again, there is a native port, but that works even worse than the emulated version)

And of course, we always have the native stuff:

Duke3D (works great, but I have a sound problem most likely due to the lack of DOS sound on my onboard sound chip, seriously thinking about buying an SB Live! original or 5.1 Gamer)
The Quakes (old school action gaming; that's why I want to play Painkiller as well)
Unreal Tournament 2003 & 2004 (bf, naturally; I think UT is just idiotic even for an shooter, though fun at a LAN party)
Neverwinter Nights (which is what I've been playing)
NES and SNES emulated games (meaning that the emulators are native)
MoH
Return to Castle Wolfenstein
Enemy Territory
America's Army
Wolf3D
Savage
(whatever that is; never heard of it, to be honest)
Gweled (aka Diamond Mine)
Pathological
Frozen Bubble
(which is a great game, and beautiful, too)
ScummVM for those old LucasArts games (haven't tried to finish Loom or Sam N Max using it, though... yet)

And that's not even an exhaustive list, just the list of things that I and my boyfriend personally have/have installed (except for 3 of those native games).

So, with one thing and another, I have a wide range of things I can play now, a large number of things to test, and quite a few things to research. The chance is still about 60-40 that I will have to pony up for a WineX subscription, but I'm not sure how I feel about that, so I'm testing in the hopes that Wine will "catch up" insofar as catching up is possible (since Cedega uses a lot of licensed stuff that may not be replicable by OSS). My gaming habits have already changed a bit. I'm perfectly happy playing NWN at the moment, and the other installs are becoming more a matter of "I just wanna have it," rather than "I can't live without it". I own stuff that I (presume I) can't play (most notably URU, and the free expansion they ponied up for after they screwed us all by cancelling Uru Live, and of course The Sims, for which I have a huge number of objects and items) without booting into Windows to do so, and I can't be bothered (although I did spend 2 days in Windows to play Syberia 2. That went without saying).

On the whole, I'm not dissatisfied with my current gaming status, which is pretty amazing to me since I don't do all that much with my PC but play games (surfing the web, reading email, watching the occasional movie, listening to music, and backing up to CD are not really "doing" anything).

Answer your question, Chinaman :D ;) ?

ahimsel08 06-26-2004 11:12 AM

FSTAB;

Code:

LABEL=/                /                      ext3    defaults        1 1
LABEL=/boot            /boot                  ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                  proc    defaults        0 0
none                    /dev/shm                tmpfs  defaults        0 0
#/dev/hdb3              swap                    swap    defaults        0 0
/dev/cdrom              /mnt/cdrom              udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1            /mnt/cdrom1            udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0                /mnt/floppy            auto    noauto,owner,kudzu 0 0
/dev/sda                /mnt/windows                msdos        uid=0,gid=100,umask=007        0 0

*NOTE* i added the last line manually like winehq told me to.. but i believe i did it wrong... shouldn't it be mounted at /home/andrew/.wine/fake_windows. but anyways... in
/home/andrew/.wine/fake_windows/dosdevices i do have a c: which goes to
/home/andrew/.wine/fake_windows .
i get the error because /dev/sda is not a mount device or something in that area. i'm saying that the WINE HQ website says i need to mount it on a dos filesystem. and the only DLL errrors i get is when i'm trying to run a program an it can't get the DLLs.

.config


Code:

WINE REGISTRY Version 2
;; All keys relative to \\Machine\\Software\\Wine\\Wine\\Config

;; If you think it is necessary to show others your complete config for a
;; bug report, filter out empty lines and comments with
;; grep -v "^;" ~/.wine/config | grep '.'
;;
;; MS-DOS drives configuration
;;
;; Each section has the following format:
;; [Drive X]
;; "Path"="xxx"      (Unix path for drive root)
;; "Type"="xxx"      (supported types are 'floppy', 'hd', 'cdrom' and 'network')
;; "Label"="xxx"      (drive label, at most 11 characters)
;; "Serial"="xxx"    (serial number, 8 characters hexadecimal number)
;; "Filesystem"="xxx" (supported types are 'msdos'/'dos'/'fat', 'win95'/'vfat', 'unix')
;;  This is the FS Wine is supposed to emulate on a certain
;;  directory structure.
;;  Recommended:
;;  - "win95" for ext2fs, VFAT and FAT32
;;  - "msdos" for FAT16 (ugly, upgrading to VFAT driver strongly recommended)
;;  DON'T use "unix" unless you intend to port programs using Winelib !
;; "Device"="/dev/xx" (only if you want to allow raw device access)
;;

[Drive A]
"Path" = "/mnt/floppy"
"Type" = "floppy"
"Label" = "Floppy"
"Device" = "/dev/fd0"

[Drive C]
"Path" = "/home/andrew/.wine/fake_windows"
"Type" = "hd"
"Label" = "/home/andrew/.wine/fake_windows"
"Filesystem" = "win95"

[Drive D]
"Path" = "/mnt/cdrom"
"Type" = "cdrom"
"Label" = "/mnt/cdrom"
"Filesystem" = "win95"
"Device" = "/dev/hdc"

[Drive E]
"Path" = "/mnt/cdrom1"
"Type" = "cdrom"
"Label" = "/mnt/cdrom1"
"Filesystem" = "win95"
"Device" = "/dev/scd0"

[Drive X]
"Path" = "/tmp"
"Type" = "hd"
"Label" = "Tmp Drive"
"Filesystem" = "win95"

[Drive Y]
"Path" = "%HOME%"
"Type" = "network"
"Label" = "Home"
"Filesystem" = "win95"

[Drive Z]
"Path" = "/"
"Type" = "hd"
"Label" = "Root"
"Filesystem" = "win95"

[wine]
"Windows" = "C:\\Windows"
"System" = "C:\\Windows\\System"
"Temp" = "X:\\"
"Path" = "C:\\Windows;C:\\Windows\\System;X:\\;X:\\test;Y:\\"
"GraphicsDriver" = "x11drv"
; Wine doesn't pass directory symlinks to Windows programs by default.
; Enabling this may crash some programs that do recursive lookups of a whole
; subdir tree in case of a symlink pointing back to itself.
;"ShowDirSymlinks" = "1"
;"ShowDotFiles" = "1"
"ShellLinker" = "wineshelllink"

# [wineconf]

[Version]
; Windows version to imitate (win95,win98,winme,nt351,nt40,win2k,winxp,win2k3,win20,win30,win31)
"Windows" = "win98"
; DOS version to imitate
;"DOS" = "6.22"

; Be careful here, wrong DllOverrides settings have the potential
; to pretty much kill your setup.

[DllOverrides]
; some dlls you may want to change
"oleaut32" = "builtin, native"
"ole32" = "builtin, native"
"commdlg" = "builtin, native"
"comdlg32" = "builtin, native"
"shell" = "builtin, native"
"shell32" = "builtin, native"
"shfolder" = "builtin, native"
"shlwapi" = "builtin, native"
"shdocvw" = "builtin, native"
"advapi32" = "builtin, native"
"msvcrt" = "native, builtin"
"mciavi.drv" = "native, builtin"
"mcianim.drv" = "native, builtin"
"msi" = "native, builtin"
; you can specify applications too
; this one will apply for all notepad.exe
;"*notepad.exe" = "native, builtin"
; this one will apply only for a particular file
;"C:\\windows\\regedit.exe" = "native, builtin"
; default for all other dlls
"*" = "builtin, native"

[x11drv]
; Number of colors to allocate from the system palette
"AllocSystemColors" = "100"
; Use a private color map
"PrivateColorMap" = "N"
; Favor correctness over speed in some graphics operations
"PerfectGraphics" = "N"
; Color depth to use on multi-depth screens
;;"ScreenDepth" = "16"
; Name of X11 display to use
;;"Display" = ":0.0"
; Allow the window manager to manage created windows
"Managed" = "Y"
; Use a desktop window of 640x480 for Wine
;"Desktop" = "640x480"
; Use XFree86 DGA extension if present
; (make sure /dev/mem is accessible by you !)
"UseDGA" = "Y"
; Use XVidMode extension if present
"UseXVidMode" = "Y"
; Use XRandR extension if present
"UseXRandR" = "Y"
; Use the take focus protocol
"UseTakeFocus" = "Y"
; Enable DirectX mouse grab
"DXGrab" = "N"
; Create the desktop window with a double-buffered visual
; (useful to play OpenGL games)
"DesktopDoubleBuffered" = "Y"
; Run in synchronous mode (useful for debugging X11 problems)
;;"Synchronous" = "Y"
;
; Use the Render extension to render client side fonts (default "Y")
;;"ClientSideWithRender" = "Y"
; Fallback on X core requests to render client side fonts (default "Y")
;;"ClientSideWithCore" = "Y"
; Set both of the previous two to "N" in order to force X11 server side fonts
;
; Anti-alias fonts if using the Render extension (default "Y")
;;"ClientSideAntiAliasWithRender" = "Y"
; Anti-alias fonts if using core requests fallback (default "Y")
;;"ClientSideAntiAliasWithCore" = "Y"
;

"Desktop" = "N"

[fonts]
;Read the Fonts topic in the Wine User Guide before adding aliases
;See a couple of examples for russian users below
"Resolution" = "96"
"Default" = "-adobe-helvetica-"
"DefaultFixed" = "fixed"
"DefaultSerif" = "-adobe-times-"
"DefaultSansSerif" = "-adobe-helvetica-"

;; default TrueType fonts with russian koi8-r encoding
;"Default" = "-monotype-arial-*-*-*--*-*-*-*-*-*-koi8-r"
;"DefaultFixed" = "-monotype-courier new-*-*-*--*-*-*-*-*-*-koi8-r"
;"DefaultSerif" = "-monotype-times new roman-*-*-*--*-*-*-*-*-*-koi8-r"
;"DefaultSansSerif" = "-monotype-arial-*-*-*--*-*-*-*-*-*-koi8-r"
;; default cyrillic bitmap X fonts
;"Default" = "-cronyx-helvetica-"
;"DefaultFixed" = "fixed"
;"DefaultSerif" = "-cronyx-times-"
;"DefaultSansSerif" = "-cronyx-helvetica-"

; the TrueType font dirs you want to make accessible to wine

[FontDirs]
;"dir1" = "/usr/X11R6/lib/X11/fonts/TrueType"
;"dir2" = "/usr/share/fonts/truetype"
;"dir3" = "/usr/X11R6/lib/X11/fonts/TT"
;"dir4" = "/usr/share/fonts/TT"

[serialports]
"Com1" = "/dev/ttyS0"
"Com2" = "/dev/ttyS1"
"Com3" = "/dev/ttyS2"
"Com4" = "/dev/modem"

[parallelports]
"Lpt1" = "/dev/lp0"

[ppdev]
;; key:  io-base of the emulated port
;; value : parport-device{,timeout}
;; timeout for auto closing an open device ( not yet implemented)
;"378" = "/dev/parport0"
;"278" = "/dev/parport1"
;"3bc" = "/dev/parport2"

[spooler]
"FILE:" = "tmp.ps"
"LPT1:" = "|lpr"
"LPT2:" = "|gs -sDEVICE=bj200 -sOutputFile=/tmp/fred -q -"
"LPT3:" = "/dev/lp3"

[ports]
;"read" = "0x779,0x379,0x280-0x2a0"
;"write" = "0x779,0x379,0x280-0x2a0"

[Debug]
;"RelayExclude" = "RtlEnterCriticalSection;RtlLeaveCriticalSection"
;"RelayInclude" = "user32.CreateWindowA"
;"RelayFromExclude" = "user32;x11drv"
;"RelayFromInclude" = "sol.exe"
;"SnoopExclude" = "RtlEnterCriticalSection;RtlLeaveCriticalSection"
;"SpyExclude" = "WM_SIZE;WM_TIMER;"

[registry]
;These are all booleans.  Y/y/T/t/1 are true, N/n/F/f/0 are false.
;Defaults are read all, write to Home
; Where to find the global registries
;"GlobalRegistryDir" = "/etc";
; Global registries (stored in /etc)
"LoadGlobalRegistryFiles" = "Y"
; Home registries (stored in ~user/.wine/)
"LoadHomeRegistryFiles" = "Y"
; Load Windows registries from the Windows directory
"LoadWindowsRegistryFiles" = "Y"
; TRY to write all changes to home registries
"WritetoHomeRegistryFiles" = "Y"
; Registry periodic save timeout in seconds
; "PeriodicSave" = "600"
; Save only modified keys
"SaveOnlyUpdatedKeys" = "Y"

[Tweak.Layout]
;; supported styles are 'Win31'(default), 'Win95', 'Win98'
;; this has *nothing* to do with the windows version Wine returns:
;; set the "Windows" value in the [Version] section if you want that.
"WineLook" = "Win98"

[Clipboard]
"ClearAllSelections" = "0"
"PersistentSelection" = "1"

; List of all directories directly contain .AFM files

[afmdirs]
"1" = "/usr/share/ghostscript/fonts"
"2" = "/usr/share/a2ps/afm"
"3" = "/usr/share/enscript"
"4" = "/usr/X11R6/lib/X11/fonts/Type1"

[WinMM]
; Uncomment the "Drivers" line matching your sound setting.

"Drivers" = "wineoss.drv"      ; default for most common configurations
;"Drivers" = "winearts.drv"    ; for KDE
;"Drivers" = "winealsa.drv"    ; for ALSA users
;"Drivers" = "winejack.drv"    ; for Jack sound server
;"Drivers" = "winenas.drv"    ; for NAS sound system
;"Drivers" = "wineaudioio.drv" ; for Solaris machines
;"Drivers" = ""                ; to disable sound
"WaveMapper" = "msacm.drv"
"MidiMapper" = "midimap.drv"

[dsound]
;; HEL only: Number of waveOut fragments ahead to mix in new buffers.
;"HELmargin" = "5"
;; HEL only: Number of waveOut fragments ahead to queue to driver.
;"HELqueue" = "5"
;; Max number of fragments to prebuffer
;"SndQueueMax" = "28"
;; Min number of fragments to prebuffer
;"SndQueueMin" = "12"
;; Forces emulation mode (using wave api)
;"HardwareAcceleration" = "Emulation"
;; Sets default playback device (0 - number of devices - 1)
;"DefaultPlayback" = "0"        ; use first device (/dev/dsp)
;"DefaultPlayback" = "1"        ; use second device (/dev/dsp1)
;"DefaultPlayback" = "2"        ; use third device (/dev/dsp2)
;; Sets default capture device (0 - number of devices - 1)
;"DefaultCapture" = "0"                ; use first device (/dev/dsp)
;"DefaultCapture" = "1"                ; use second device (/dev/dsp1)
;"DefaultCapture" = "2"                ; use third device (/dev/dsp2)

[Network]
;; Use the DNS (Unix) host name always as NetBIOS "ComputerName" (boolean, default "Y").
;; Set to N if you need a persistent NetBIOS ComputerName that possibly differs
;; from the Unix host name. You'll need to set ComputerName in
;; HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\ComputerName\ComputerName, too.
;"UseDnsComputerName" = "N"

#########################################
# Application dependent sections follow #
#########################################

[AppDefaults\\_INS5576._MP\\x11drv]
; Lotus Notes R5 installer
; I'm quite not sure this will run on some other machine than mine, but it
; can't hurt
"Managed" = "N"
"Desktop" = "N"

[AppDefaults\\nlnotes.exe\\x11drv]
"Desktop" = "800x600"

[AppDefaults\\explorer.exe\\x11drv]
"Desktop" = "800x600"

[AppDefaults\\notes.exe\\DllOverrides]
"msvcrt" = "native"
"msvcrt40" = "native"
"crtdll" = "native"
"imagehlp" = "native"
"rnaph" = "native"

[AppDefaults\\nlnotes.exe\\DllOverrides]
"msvcrt" = "native"
"msvcrt40" = "native"
"crtdll" = "native"
"imagehlp" = "native"
"rnaph" = "native"

[AppDefaults\\nhldaemn.exe\\DllOverrides]
"msvcrt" = "native"
"msvcrt40" = "native"
"crtdll" = "native"
"imagehlp" = "native"
"rnaph" = "native"

# [/wineconf]

there you go guys.

motub 06-26-2004 12:46 PM

Sincerely and truly meaning no disrespect, I must nonetheless inform you that it's pretty clear atm that you have no idea what you're doing. That's OK, but you need to take a deep breath, clear your mind of whatever information you think it has, and let's just start with a clean slate. That's the only way to proceed.

Now, I've gone to the WineHQ site, and I've located the instructions in question (I think). It seems to me you can only be referring to this:
Quote:

6.2. I have installed and configured Wine, but Wine cannot find MS Windows on my drive. Where did I go wrong?

If you have a DOS partition, first make sure that you have mounted it, either by putting the entry into /etc/fstab, or by manually mounting it.

Remember too that unless your version of UNIX can see through it, or you are running a utility that can see through it, your DOS partition must not be located on a Drivespaced, Doublespaced or Stackered partition, as neither Linux, FreeBSD, NetBSD or Wine can natively 'see' files located in these compressed DOS partitions.

What you have misunderstood is:

1. Wine does not NEED MS Windows, and in fact often runs better without it; and

2. as I said in my first post, unless you have specifically configured Wine to use the (mounted) Windows partition as its "C:\" drive, Wine won't be looking for any version of MS Windows under any circumstances, so it doesn't matter if you've got it mounted or not. You have not so configured WINE, so you can either change your configuration so that WINE uses your installed Windows as a base (which would require mounting the Windows system partition), or you can leave the configuration as it is, because-- as per #1 above-- WINE does not need to have Windows available or installed to work. However, some things do work better (sometimes) with native Windows system files available (which is not the same as using a mounted Windows system partition as the Wine C:\ folder).

Let me explain further, as it seems to me you don't quite get how WINE works, which is fairly important for configuring and using it.

Basically, WINE fools Windows programs into thinking Windows is running when it is not. So it's perfectly possible to run Wine (and to run apps/games under WINE) without having Windows installed at all, and many people do.

However, the success of WINE's ability to fool programs into thinking that Windows is running when it is not is dependent on a number of factors, the most notable of which are:

1) The complexity of the program being run (notepad, for example doesn't require much to be "fooled", but it's much harder to pull the wool over the eyes of a large application like Photoshop, as it has much more that it requires from the OS "backend" than notepad does);

2) The ability of Wine "dlls" (libraries) to replicate the function of the Windows dlls reliably. Since Windows is closed-source and proprietary, it's like trying to replicate a McDonald's hamburger perfectly without having the recipe. You know the basic components (beef, some lettuce, a sesame-seed bun), but you don't know if there are additonal ingredients ("special sauce") or special cooking procedures that make it taste the way it does, so you just keep working at it till you get as close as you can. The result might fool your mother (notepad), because all you have to do is acquire a McDonald's bag, put your burger in, and she'll believe it. However, the chief chef of the McDonald's kitchen labs (Photoshop) will probably not be taken in by such a ruse.

So, an end user trying to run Wine has two choices: they can run Wine "standalone" (using no Windows system files, because the user does not have a Windows installation or a Windows licence to use the system files) or they can run Wine with the assistance of Windows system files (which still does not require Windows to be installed, but we're coming to that).

The very most basic necessities for fooling any program into thinking that Windows is running is the existence of a folder/partition designated as C:\, which contains the following folders: \windows (or WINNT), \windows\system, \windows\system32, and \Program Files. It does not matter if these folders are empty (though naturally it helps a lot if they aren't), but they must exist, or else no program is going to be fooled at all.

So the very first thing in your config file is meant to answer the question, "Where is the C:\ drive?"

Quote:

Originally posted by ahimsel08
[CODE]WINE REGISTRY Version 2
;; All keys relative to \\Machine\\Software\\Wine\\Wine\\Config

;; If you think it is necessary to show others your complete config for a
;; bug report, filter out empty lines and comments with
;; grep -v "^;" ~/.wine/config | grep '.'
;;
;; MS-DOS drives configuration
;;
;; Each section has the following format:
;; [Drive X]
;; "Path"="xxx" (Unix path for drive root)
;; "Type"="xxx" (supported types are 'floppy', 'hd', 'cdrom' and 'network')
;; "Label"="xxx" (drive label, at most 11 characters)
;; "Serial"="xxx" (serial number, 8 characters hexadecimal number)
;; "Filesystem"="xxx" (supported types are 'msdos'/'dos'/'fat', 'win95'/'vfat', 'unix')
;; This is the FS Wine is supposed to emulate on a certain
;; directory structure.
;; Recommended:
;; - "win95" for ext2fs, VFAT and FAT32
;; - "msdos" for FAT16 (ugly, upgrading to VFAT driver strongly recommended)
;; DON'T use "unix" unless you intend to port programs using Winelib !
;; "Device"="/dev/xx" (only if you want to allow raw device access)
;;

[Drive A]
"Path" = "/mnt/floppy"
"Type" = "floppy"
"Label" = "Floppy"
"Device" = "/dev/fd0"

[Drive C]
"Path" = "/home/andrew/.wine/fake_windows"
"Type" = "hd"
"Label" = "/home/andrew/.wine/fake_windows"
"Filesystem" = "win95"

Your "C:\" drive has been configured to be a folder created by WINE, in your $HOME$ directory, in the hidden .wine folder, called, fake_windows. If you look in there, you will see subfolders called Program Files, Windows, Windows\System and Windows\System32. These folders are (hopefully) filled with symlinks to the WINE libraries (in the WINE install folder, somewhere in /usr/lib) that replicate the functionality of the "named" Windows dlls (meaning the Windows dlls that the symlinks are named after, that the Windows programs are looking for). A "fake_windows" setup is the default configuration, both because WINE does not need Windows to run, often runs better without it, and of course, as Linux users, many of us don't have Windows available in the first place.

However, some of us do, and in some respects, some programs do run better using Windows native system libraries. Further, some Windows system libraries cannot be replicated by WINE at all, so the Windows ones need to be used.

Myself, I just like to copy my backed-up Windows98 system files to my fake_windows, but WINE does allow you to use a real C:\ drive as the WINE C:\ drive. If you wanted to do that, you would have to

1) mount the Windows partition so that it would be accessible to Wine (and everything else; unmounted drives are not useable)
2) change the "Path" statement in the Wine configuration above to point to the mounted Windows partition.

However, this is not in any way necessary for the running of Wine. It is a personal choice.

So my question at this point is, have you tried to run any Windows apps with Wine? Do you have some reason to believe that WINE is not working? If so, then please tell us what that is, and we can focus on the real problem.

At this moment you are trying to fix something that is not broken.

As to the question of how to mount your Windows drive (perhaps it has some programs on it that you would like to try to run with WINE), first of all, please take out that last mount thing you added to /etc/fstab; it's most likely completely wrong (as there's no reason that any of your HDD partitions should be designated /dev/sd-anything, and they most likely are not).

Then do as Chinaman said and
Quote:

Originally posted by Chinaman
As a normal user issue
$ df -h
and then issue
$ cat /etc/fstab
and then as root issue
# fdisk -l
and post the output. In order for it to be readable in the forum, put [_code_] without the underscores before the output and [_/code_] without the underscores after the output.

We will then be able to tell you how to properly create an entry in /etc/fstab for your Windows drive, and/or how to mount it manually.

ahimsel08 06-26-2004 03:05 PM

ok, i know wine works.. when i run as normal user and type wine in the terminal it gives me
Wine*version number*
Usage: Wine
--help
--version
$

i've tried installing morpheus on it.. it worked once... but i couldn't get it to run i got some DLL errors so i just uninstalled. and i've had trouble reinstalling it just hangs, but it does come up and prompt me to install morpheus... i get the window's mouse and box look. and no errors from wine.
so now, here are the first 2 commands:

Code:

[andrew@comp.name andrew]$ df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda2              12G  6.2G  5.3G  55% /
/dev/hda1              99M  24M  71M  25% /boot
none                  125M    0  125M  0% /dev/shm

[andrew@comp.name andrew]$ cat /etc/fstab
LABEL=/                /                      ext3    defaults        1 1
LABEL=/boot            /boot                  ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                  proc    defaults        0 0
none                    /dev/shm                tmpfs  defaults        0 0
/dev/cdrom              /mnt/cdrom              udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1            /mnt/cdrom1            udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0                /mnt/floppy            auto    noauto,owner,kudzu 0 0
[andrew@comp.name andrew]$

*logged out and in as root.*

[root@comp.name root]# fdisk -l
 Disk /dev/hda: 13.6 GB, 13676544000 bytes
255 heads, 63 sectors/track, 1662 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
  Device Boot    Start      End    Blocks  Id  System
/dev/hda1  *        1        13    104391  83  Linux
/dev/hda2            14      1597  12723480  83  Linux
/dev/hda3          1598      1662    522112+  82  Linux swap
 
Disk /dev/hdb: 41.1 GB, 41110142976 bytes
255 heads, 63 sectors/track, 4998 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
  Device Boot    Start      End    Blocks  Id  System
/dev/hdb1  *        1      4997  40138371    c  Win95 FAT32 (LBA)
[root@comp.name root]#

and yeah heres some directories
/home/andrew/.wine/fake_windows/windows/system
/home/andrew/.wine/fake_windows/Program Files
/home/andrew/.wine/dosdevices/

/home/andrew/.wine/fake_windows/windows/system32 is empty system has 100+ files all DLLs. is this because it's acting like windows 98 and system32 started at 2000?

motub 06-26-2004 05:17 PM

Yes and no; if you look at the system32 folder, you'll see it's a symlink to system, so no matter which version of Windows you're having WINE emulate, it will work.

Moving to the Morpheus issue: you do know that there are a large number of native Linux P2P clients, right? I don't use P2P, and a fast search seems to indicate that there aren't any multi-protocol clients, but there are several for each of the major protocols.

There are any number of reasons that any program in general and Morpheus in particular might not install under Wine; I would suggest that you first try to run any instance of Morpheus you already have installed under Windows with WINE rather than try to install it.

Second option would be to delete the Morpheus folder in the b0rked Linux install and attempt to reinstall; if the install completes, rather than running the newly installed version, copy your Windows install over it (you can try running the newly-installed version as well, but Morpheus contains a number of additional bundled programs which may or may not be installable via WINE, which may in itself be what's borking your install attempt-- it's happened to me with other programs). In addition, you might want to export the Morpheus Registry entries from Windows and import them into the WINE Registry.

In any case, you'll probably need to make your Windows partition accessible to try any of this; you can mount it manually by opening a terminal, su-ing to root, cd-ing to /mnt and creating a folder /windows in that directory (assuming you want to mount the partition to the /mnt folder, and that you want to call the mount point /windows-- both of which are optional decisions, as you can mount a partition anywhere in the filetree, and there are certain advantages to mounting into your own ~/ folder, for example, rather than /mnt-- and that the mount point /mnt/windows does not currently exist). Once you've made the mount point, you can then mount the partition by using the command mount -t vfat /dev/hdb1 /mnt/windows.

That should be good enough for the moment; you can read man mount and man fstab at your leisure for more information on the mount command, and how to edit /etc/fstab to create a permanent mount point so that you can mount the partition automatically, or use the shortened version of the mount command (mount /mnt/windows, in this example) to mount the partition more easily by hand.

Bruce Hill 06-26-2004 06:25 PM

reply to Holly
 
Holly,

Thanks for your posts and helping this guy out. After reading your wealth of information, I'm embarassed for starting to help at all. ;-) And, you answered my question perfectly.

First, I don't play computer games - any - period. I build and repair computers, and am learning *nix (via Slackware at the present time) with the goal to be able to build *nix based open source systems (that I can properly support) and refuse to install any Windoze OS. Today I won't install a copy CD (almost the only CD's used here) so that's eliminated a lot of new Windoze builds. I can build Slack based comps for most people, because like you mentioned, most people only surf the web, check email, and use an occasional office doc. For these needs Slack is easily configurable and has apps just as good as those built for Micro$loth.

The only thing keeping me from being "Windoze free" right now is a good DTP program. Scribus is available, and I run the cvs version, but it's far too immature an app to consider for serious work. GIMP has come a long way since I first used it in 1999, and it works just fine for most of my daily needs. There are still things I can't do in GIMP that I can do easily in Photoshop, like "extract." I've yet to even find that tool in GIMP. I come from a publishing background, and have over a decade of experience with PageMaker - less with Photoshop.

I have W2K installed for using PageMaker, and for Photoshop when I have some serious work I can't do in GIMP. I don't go online in Windoze, so there's no need to worry about virii, worms, and trojans. I've also got WinXP installed for those "tech calls" when I need to see the funky gui stuff someone's talking about over the phone. It makes me want to barf, but I'm in it to help others. ;-)

My W2K system works great - as good as my Slack system with one exception - it doesn't multi-task as well. And everything "just works," which isn't true for me in *nix. I spend 90% of my Slack time trying to get apps and hardware to work properly at the moment.

I've tried Wine for several apps that I own that were written for Windoze. I've also tried Codeweaver's Crossover Office. It worked better for me than Wine, but still didn't run PageMaker properly. I also tried some other apps under them, but have since found a way to replace them, or can live with the "less than perfect" way they run under Wine - rather drunk, usually. ;-)

I will follow your advice in this thread, since I've already learned more about Wine, and then later try to install it again and see how things work. I won't buy CrossOver Office for two reasons:
(1) I think it's a crime that Codeweavers bought the Wine maintainer (Alexandre Julliard) and now their "for sale" proprietary product works better than the open source version
(2) since I already own Windoze and apps like PageMaker, etc. that were made for Windoze and run perfectly under Windoze, it would be stupid IMO to pay for something that runs them second rate.

And please explain why WINE stands for Wine is not a Windoze emulator, but it is...

So, post on, Holly. I always enjoy reading your threads. You don't ever give someone a quick 5-word answer, but real useful information and stick with it until it's either fixed, or they give up.

ahimsel08 06-26-2004 07:48 PM

sorry but, what's the purpose of mounting /mnt/windows ? how does it involve with wine?
also, can you tell me where i can get those P2P linux programs? that's all i really needed to use wine for... and i tried XNAP and that didn't work... then i tried gIFT and that sucked. any others?

also, heres the error i get

XtreamLok Alert
DLL Loading Problem
or
Debugger Detected
or
Integrity Violated

it's a popup box, comes up when i try to load morpheus.

motub 06-26-2004 10:15 PM

Quote:

Originally posted by ahimsel08
sorry but, what's the purpose of mounting /mnt/windows ? how does it involve with wine?
You were originally trying to mount your Windows partition. That was an example of how you would do it. Despite the fact that you don't need to have your Windows partition available for the reason that you thought you did, there are still a couple of reasons that you might want to mount it:

1) it contains applications that you have installed under Windows that you want to try to run under WINE;

2) you might want to copy some of the system files from your Windows folders to the WINE "fake_windows" system folders;

3) you might want to export Registry keys from the Windows Registry and import them into the WINE Registry.

None of these things is possible if the Windows partition is not available, which means, "mounted". You cannot use any of the data on an unmounted drive or partition. However, if you do not want to do any of these things, then you do not have to mount your Windows partition(s).

Quote:

Originally posted by ahimsel08
also, can you tell me where i can get those P2P linux programs? that's all i really needed to use wine for... and i tried XNAP and that didn't work... then i tried gIFT and that sucked. any others?
You're using RedHat 9? I don't, but you should look in the repositories listed at FreshRPMs links page and DAG repository page for any or all of the following packages (taken from Gentoo's online Portage database, since I don't use P2P and don't know what all the applications are called, so that was the easiest way for me to generate a list):
  • amule (eMule)
  • Azeurus (BitTorrent)
  • bittornado (Bit Torrent)
  • bittorrent (Bit Torrent)
  • cccp (DirectConnect)
  • Circle (Circle)
  • dc-gui (Direct Connect)
  • dcgui-qt (Direct Connect)
  • dctc (Direct Connect)
  • dchub (Direct Connect hub)
  • ed2k-gtk-gui (Overnet)
  • fidelio (Hotline)
  • freenet (Freenet)
  • g2gui (gui for mldonkey)
  • You said you tried giFT, but did you use any of the various plugins for it? Or any of the frontends?
  • gnapster (Napster)
  • gnunet (gnunet)
  • gnut (Gnutella)
  • gtk-gnutella (Gnutella)
  • gtkhx (Hotline)
  • kmldonkey (eDonkey)
  • knapster2 (Napster)
  • ldcc (Direct Connect)
  • lopster (Napster)
  • mhxd (Hotline)
  • mldonkey (eDonkey)
  • mnnet (mnnet)
  • mutella (Gnutella)
  • nap (Napster/OpenNap)
  • napshare (Napster)
  • nicotine (Soulseek)
  • opendchub (Direct Connect hub)
  • overnet (overnet, formerly eDonkey)
  • pysoulseek (Soulseek)
  • qtella (Gnutella)
  • qtorrent (Bit Torrent)
  • sancho (mldonkey frontend)
  • teknap (Napster/OpenNap
  • xmule (eDonkey/eMule/lMule)
  • zuul (mldonkey frontend)

As I said, I don't use P2P, so I don't know anything more about these programs than their names and what networks they connect to. But hopefully one or more of them will suit your needs.


Quote:

Originally posted by ahimsel08
also, heres the error i get

XtreamLok Alert
DLL Loading Problem
or
Debugger Detected
or
Integrity Violated

it's a popup box, comes up when i try to load morpheus.

The important line here is Debugger Detected. That means that there is some kind of copy protection on the application, and it has detected something that indicates that it is not being run under "legitimate" circumstances. The circumstances it thinks have occured are that you are running a "cracked" or otherwise illegal version, because "running the program under replicated Windows API calls" is not really in its vocabulary.

You might be able to get around this with importing the Windows Registry entries, if you have the program installed under Windows. You might also be able to get around this by copying the Windows system dlls to the fake_windows system directory, as the DLLs that the program can't find ("DLL Loading Problem") may be very well be DLLs that the program itself installed to C:\Windows\System(32), or to C:\(either Windows or Documents and Settings\blah blah blah, depending on your Windows version)\Application Data\Morpheus. Placing those files in the proper WINE system directories might enable the program to run, but frankly, it's a crapshoot with a program like that, because it has so many subprograms and processes going on.

Up to you if you want to fight with it and try to get it running, or just find a native alternative. You could ask on the Wine User's Mailing List or the Frank's Corner forums as to whether there is a known way to get it working.

--------------------------------------------------------------------------------------------

Chinaman, thanks for the compliments. Naturally, WINE is not only to run games-- many people run apps that they need under it, but I find that the Linux alternatives are mostly adequate for my needs. There's only two apps that I occasionally use WINE for; the vast majority of what I use it for is games.

And as far as why Wine Is Not an Emulator... well, I looked this up once to explain it to someone else, and apparently you can only "emulate" hardware (and most specifically a CPU). The emulators we are familiar with replicate the hardware language of the emulated system on the real hardware. WINE does not do this; it's more accurate to say that it translates the software language from the real hardware to what the software expects, then back again (so that the real hardware can communicate with the software). It tells notepad that ~/.wine/fake_windows/ is the C:\ drive, but that's just because notepad is too dumb to deal with being in ~/.wine/fake_windows/; all it understands is being on C:. But no system resources are changed, and If DeusEx wants to use the DirectX sound device, all Wine is really doing is trying to understand what DeusEx wants to do (in DX language), telling it to ALSA or OSS (in ALSA or OSS language) then telling DX what ALSA said (in DX language again).

This is completely unlike, for instance, the Bochs emulator, which says in its User Guide:
Quote:

Bochs is a program that simulates a complete Intel x86 computer. It can be configured to act like a 386, 486, Pentium, or Pentium Pro. Bochs interprets every instruction from power-up to reboot, and has device models for all of the standard PC peripherals: keyboard, mouse, VGA card/monitor, disks, timer chips, network card, etc. Because Bochs simulates the whole PC environment, the software running in the simulation "believes" it is running on a real machine. This approach allows Bochs to run a wide variety of software with no modification, include most popular x86 operating systems: Windows 95/98/NT, all Linux flavors, all BSD flavors, and more.
or

Quote:

An emulator is a product designed to imitate one system with another so that both accept the same data, execute the same programs, and achieve the same results. The concept was invented by IBM systems engineer Larry H. Moss in 1964 to describe how the new IBM System/360 would provide support for programs that had been designed to work with older IBM mainframes, such as the IBM 7070. There are three basic types of emulator - the 'firmware emulator' (all in hardware - examples include SMS support built into G/MD and PSX support built into PSX2), the 'combo emulator' (part hardware, part software - like A-Max, the various Amiga Bridgeboards, the Mac Houdini board, etc.), and the 'true' or 'software' emulator (coded entirely in software, no special hardware required for operation).
(from home.t-online.de/home/detain/emula/info_dict.htm)

It seems like splitting hairs to a user, but WINE is about as much of an "emulator" of Windows as Linux is a "clone" of UNIX. Not least because it would be just about as illegal to really "emulate" Windows as it would be to have really "cloned" UNIX. WINE allows Linux to communicate with Windows programs so that the programs consent to run. TuxNES (an Nintendo Entertainment System emulator) recreates the entire Nintendo 8-bit environment so that the "programs" do not even know that they're no longer in a cartridge on a set-top box. It's hard to explain, but WINE really is not an emulator, but as they say on the Wine homepage, a Windows compatibility layer.

Bruce Hill 06-26-2004 10:31 PM

Thanks, Holly. But there's still a huge difference between just "running an app" and it "functioning correctly". I've tried three main apps under Wine and CrossOver Office - Photoshop 7.0, PageMaker 7.0, and Wenlin 3.0. None of them function "correctly" under either Wine or CrossOver Office.

I will allow that I have never setup Wine with it's best optimization, though I have set it up following three different sets of directions exactly - from the Wine website, from the gunzipped Wine file, and from Frank's Corner website. All the instructions contain differences, I might add. One thing I can do is follow the directions - heck, I've even been know to cut and paste successfully. ;-)

Maybe I'll glean some new information from you in this thread and give Wine a shot again - not CrossOver, though, for reasons previously stated. IMO Wine is aptly named, for it functions about like a drunk human. ;-)

motub 06-27-2004 06:34 AM

That's actually the proof that WINE is not an emulator-- if it was, the apps would function 'perfectly', like they do under, say, VMWare's "virtual machine" (which is a lot closer to an emulator than Wine is, if in fact it is not an emulator, which it might well be).

Wine changes (is improved) every month, and Crossover Office improves constantly as well (the Wine project and Codeweavers work together closely).

Currently, the Codeweaver's homepage says:
Quote:

CrossOver Office is capable of running a range of Windows software, but CodeWeavers will support the following applications:

* Microsoft Office XP, 2000 and 97
o Microsoft Word
o Microsoft Excel
o Microsoft PowerPoint
o Microsoft Outlook
o Microsoft Internet Explorer
* Microsoft Access *
* Microsoft Project
* Adobe Photoshop
* Microsoft Visio
* Lotus Notes 5.0 and 6.5.1
* Quicken
* Various Web Browser Plugins
o QuickTime
o Shockwave Director
o Windows Media Player 6.4
* and more...
The fact that the instructions on Frank's Corner for MSOffice 2000 use Wine version 20030618 (a year old, thus), the instructions for MSOffice 97 use Wine version 20030813 (10 months old) and the instructions for Photoshop 7 use Wine version 20030813 (10 months old) indicate that these programs have been "runnable" under Wine for quite some time. The fact that Codeweavers will now officially support these programs if you buy CX Office indicates that they not only run, but run quite well, and they have enough confidence in their product's ability to run these apps that they can fix any "minor" problems you may encounter (you may not consider any problems you encounter "minor", but you're just a user ;) ). This would strongly suggest that they run very well now under regular WINE as well (since Codeweavers does share code with the WINE project), though presumably not quite so well as they do under CX Office. But depending on your individual needs, WINE may run the apps well enough. If not, then one would pony up for CX Office.

For instance, a year ago, Frank's Corner reported in their Photoshop 7.0 how-to that "Imageready doesn't work. You can't resize the tool windows." That may still be true, or it may no longer be true. It is probably not true of CX Office (given that I wouldn't much want my technical support desk to have to report that to paying customers and call it "official support" of the Photoshop product. I think we would have heard the screams of rage about such behaviour even if we don't follow WINE news much, or at all).

I don't even know what Wenlin is (OK, I looked it up, and that's interesting, as I have a few pieces of software to help me with my Dutch, which I haven't yet attempted to install or run under Wine, either-- and one of them is a DOS program, so I really have no idea if it will work. The other is heavily multimedia-based, and was rather buggy under Win 98, so I also have no idea if it will run). But of course, you're talking about Chinese, which is not a Latin-based language, so you then get into Asian character support, and alternative directional support (Chinese is not written left-to-right, is it?) which are not exactly "core" issues-- insofar as you are not running your computer wholly in Chinese (I presume; I did look up your location, but if you were Chinese-born, why would you be learning it?), but are running some programs that use Chinese, under WINE, on a PC that normally uses a Latin-based, left-to-right character set. This is a lot to ask, when put that way. Wine not only has to "emulate" Windows, to get the program to load and run in the first place, but also has to "change gears" to support a new character set and display paradigm (vertical characters as opposed to left to right characters), while still displaying the "standard" character set and display paradigm (since English is also used in the program). Not to mention multiple keyboard maps and user input variables (I assume you can type in both languages when using this program, to answer questions or use the dictionary) on the same keyboard. On the fly. I mean, it really is a lot to ask WINE to manage at all, much less "perfectly", when the Wine project doesn't necessarily have access to the mechanisms (Windows API calls) that the program uses to do this under Windows in the first place.

Wine is a moving target, because Windows applications are a moving target, but it is under constant development, and it does noticeably improve quite often.

However, it must be said: If you want a Windows program to work "perfectly" (as if it was being run under Windows), then the best way to achieve that is.... to run it under Windows. Y'know? :) Perspective is everything, and WINE is an "extra", a gift if you will, not a necessity. You've already given up the most "popular" operating system in the world. Giving up a few apps shouldn't be that tough, next to that. And if it is, well, then "you" (general you, not you you) have some thinking to do. Which is as it should be, because changing OSes is not-- and should not be thought of as if it is-- like changing socks.

Bruce Hill 06-27-2004 07:54 AM

Quote:

Originally posted by motub
Wine changes (is improved) every month, and Crossover Office improves constantly as well (the Wine project and Codeweavers work together closely).
The technical truth is Codeweaver's hired (bought) the Wine maintainer, Alexandre Julliard, and now their CrossOver Office product is better built and supported than Wine. No need to read between the proprietary lines.
Quote:

Originally posted by motub
Currently, the Codeweaver's homepage says: CrossOver Office is capable of running a range of Windows software, but CodeWeavers will support the following applications:
They also say
Quote:

The software you get now will be fully functional--no intentionally broken or missing features. It's the real deal.
so if it doesn't run the software correctly now, it's not going to if one pays for it. I would consider it poor judgment to purchase their proprietary software, which does not run Photoshop or PageMaker properly, when I can run it perfectly under W2K. But I'm not concerned about, or interested in, Codeweaver's CrossOver Office. When Wine runs PageMaker correctly, I'll use it.

If we could guage it, I don't think you'd find anyone who wants to be Micro$loth FREE any more than I. However, today our Linux OSs and open source apps aren't fully ready to replace Windoze. I'm not the one claiming Wine runs those programs correctly, rather, the one saying it doesn't. Just the facts, which I will openly challenge anyone who thinks they can get PageMaker (keep it to one app) to work properly under Wine. It just ain't gonna happen, no matter how much of a *nix guru one happens to be...

But, hey, I don't want to hijack the guys thread. I'd have emailed you but that's not an option.

You got a lot of knowledge, and I just wanna tap into your Wine experience, that's all. I hate Mirco$loth more than you'll ever know. Today I booted into W2K to finish my monthly newsletter, because Scribus just can't get the job done. It makes me want to vomit, using Windoze, but today I have to do it.

Holly, you're cool...let's drop the bantering and get back on the same side of the fence. Truce?


All times are GMT -5. The time now is 09:28 AM.