-   Linux - Hardware (
-   -   Mounting SCSI hard disk (

michael_mead 09-21-2003 06:10 AM

Mounting SCSI hard disk
Hi all,

I have searched but found nothing on this to help me, so I am starting a thread.

I have a mandrake 9.1 server that has 2 x 4GB IDE and 1 x 10GB IDE hard disks and a CD-rom.

It has finally run out of hard disk space, so a friend of mine gave me a adaptec scsi controller and an 18GB hard disk.

I have tested them - the 18GB has win98 installed and boots from it without any problems.

I have put the card and disk in the linux server and checking Harddrake I can tell you it has picked up and installed the adaptec card but there is no mention of a hard disk.

I have tried mounting it using

mount -t vfat /dev/sda1 /mnt/scsi

but it says the device cannot be found.

Is there something I need to do before linux picks up the scsi hard disk.

Because I had just IDE disks in the server during install - could it have skipped some package or module that it needs?



michaelk 09-21-2003 08:28 AM

Did you test the disk on the same computer as installed now or a different one?

Just going over the basics:
Does the controller BIOS see the hard drive during boot. It the SCSI cable terminated correctly.

Check dmesg for any errors relating to SCSI. What modules are being loaded related to scsi (/sbin/lsmod).

Also check output of:
cat /proc/scsi/scsi to see if it lists any devices.

/dev/sda1 will be a link to the actual device. Do you have anything under /dev/scsi/host0/?

maroonbaboon 09-21-2003 08:32 AM

If linux has picked it up there should be a mention in the output of the 'dmesg' command. This will also tell you the correct device name, assuming it is there.

michael_mead 09-22-2003 12:41 PM

Thanks for your responses,

I have tested the disk on its own in this machine and it works. The controller bios picks it up.

I have checked dmesg and the only thing it says about scsi is;

SCSI subsystem driver Revision: 1.00

Checking lsmod I found
scsi_mod 103284 4 (autoclean) [sg st sr_mod sd_mod]

Which shows the scsi module has been loaded

The contents of /proc/scsi/scsi are

Attached devices: none

Under /dev/scsi/ there is nothing

What I cannot figure out, is that it has picked up the card but not the disk even though the disk does work when I set to boot from it.

michaelk 09-22-2003 01:02 PM

What does the following command show:
cat /proc/scsi/scsi

Look at the ouput of dmesg reated to SCSI. Any errors associated with the controller or drive?

michael_mead 09-22-2003 05:24 PM

As I said before the output of /proc/scsi/scsi is

Attached devices: none

Here is the whole output from dmesg - I posted before an extract from it that said some stuff about scsi - but here it is just incase I missed something.

Linux version 2.4.21-0.13mdk ( (gcc version 3.2.2 (Mandrake Linux 9.1 3.2.2-3mdk)) #1 Fri Mar 14 15:08:06 EST 2003
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000000bff0000 (usable)
BIOS-e820: 000000000bff0000 - 000000000bff3000 (ACPI NVS)
BIOS-e820: 000000000bff3000 - 000000000c000000 (ACPI data)
BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
191MB LOWMEM available.
ACPI: have wakeup address 0xc0001000
On node 0 totalpages: 49136
zone(0): 4096 pages.
zone(1): 45040 pages.
zone(2): 0 pages.
Kernel command line: auto BOOT_IMAGE=linux ro root=345 devfs=mount acpi=off quiet
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
Initializing CPU#0
Detected 583.478 MHz processor.
Console: colour dummy device 80x25
Calibrating delay loop... 1163.26 BogoMIPS
Memory: 191012k/196544k available (1410k kernel code, 5148k reserved, 1118k data, 136k init, 0k highmem)
Dentry cache hash table entries: 32768 (order: 6, 262144 bytes)
Inode cache hash table entries: 16384 (order: 5, 131072 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer-cache hash table entries: 8192 (order: 3, 32768 bytes)
Page-cache hash table entries: 65536 (order: 6, 262144 bytes)
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 128K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: After generic, caps: 0183fbff 00000000 00000000 00000000
CPU: Common caps: 0183fbff 00000000 00000000 00000000
CPU: Intel Celeron (Mendocino) stepping 05
Enabling fast FPU save and restore... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
enabled ExtINT on CPU#0
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 583.4410 MHz.
..... host bus clock speed is 72.9299 MHz.
cpu: 0, clocks: 729299, slice: 364649
mtrr: v1.40 (20010327) Richard Gooch (
mtrr: detected mtrr type: Intel
ACPI: Subsystem revision 20030122
ACPI: Disabled via command line (acpi=off)
PCI: PCI BIOS revision 2.10 entry at 0xfb0e0, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: ACPI tables contain no PCI IRQ routing entries
PCI: Probing PCI hardware (bus 00)
PCI: Using IRQ router VIA [1106/0686] at 00:07.0
PCI: Disabling Via external APIC routing
PCI: Via IRQ fixup for 00:07.3, from 255 to 0
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16)
Starting kswapd
VFS: Disk quotas vdquot_6.5.1
devfs: v1.12c (20020818) Richard Gooch (
devfs: boot_options: 0x1
vesafb: framebuffer at 0xd4000000, mapped to 0xcc800000, size 8128k
vesafb: mode is 800x600x16, linelength=1600, pages=7
vesafb: protected mode interface info at c000:4cec
vesafb: scrolling: redraw
vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0
Looking for splash picture.... found (800x600, 25593 bytes).
Console: switching to colour frame buffer device 80x16
fb0: VESA VGA frame buffer device
Detected PS/2 Mouse Port.
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI ISAPNP enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 32000K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00beta-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 00:07.1
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: VIA vt82c686b (rev 40) IDE UDMA100 controller on pci00:07.1
ide0: BM-DMA at 0xa000-0xa007, BIOS settings: hda:DMA, hdb:DMA
ide1: BM-DMA at 0xa008-0xa00f, BIOS settings: hdc:pio, hdd:DMA
hda: FUJITSU MPC3043AT, ATA DISK drive
hdb: SAMSUNG SV0432A, ATA DISK drive
hda: DMA disabled
blk: queue c03cb420, I/O limit 4095Mb (mask 0xffffffff)
hdb: DMA disabled
blk: queue c03cb55c, I/O limit 4095Mb (mask 0xffffffff)
hdd: DMA disabled
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
hda: task_no_data_intr: error=0x04 { DriveStatusError }
hda: 8448300 sectors (4326 MB), CHS=525/255/63, UDMA(33)
hdb: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
hdb: task_no_data_intr: error=0x04 { DriveStatusError }
hdb: 8421840 sectors (4312 MB) w/482KiB Cache, CHS=524/255/63, UDMA(33)
Partition check:
/dev/ide/host0/bus0/target0/lun0: p1 p2 < p5 p6 p7 p8 >
/dev/ide/host0/bus0/target1/lun0: p1 p2 < p5 >
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 1024 buckets, 8Kbytes
TCP: Hash tables configured (established 16384 bind 32768)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 47k freed
VFS: Mounted root (ext2 filesystem).
Mounted devfs on /dev
Mounted devfs on /dev
Freeing unused kernel memory: 136k freed
Real Time Clock Driver v1.10e
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.275 $ time 15:32:56 Mar 14 2003
usb-uhci.c: High bandwidth mode enabled
PCI: Assigned IRQ 5 for device 00:07.2
PCI: Sharing IRQ 5 with 00:07.3
usb-uhci.c: USB UHCI at I/O 0xa400, IRQ 5
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
PCI: Found IRQ 5 for device 00:07.3
PCI: Sharing IRQ 5 with 00:07.2
usb-uhci.c: USB UHCI at I/O 0xa800, IRQ 5
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
usbdevfs: remount parameter error
Adding Swap: 465844k swap-space (priority -1)
Journalled Block Device driver loaded
kjournald starting. Commit interval 5 seconds
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,7), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,8), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,1), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,65), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
8139too Fast Ethernet driver 0.9.26
PCI: Found IRQ 10 for device 00:08.0
eth0: RealTek RTL8139 Fast Ethernet at 0xcd16d000, 00:e0:7d:ec:af:c0, IRQ 10
eth0: Identified 8139 chip type 'RTL-8139C'
inserting floppy driver for 2.4.21-0.13mdk
FDC 0 is a post-1991 82077
eth0: Setting half-duplex based on auto-negotiated partner ability 0000.
Installing knfsd (copyright (C) 1996
PCI: Found IRQ 5 for device 00:07.5
PCI: Setting latency timer of device 00:07.5 to 64
hdd: ATAPI 24X CD-ROM drive, 128kB Cache, DMA
Uniform CD-ROM driver Revision: 3.12
SCSI subsystem driver Revision: 1.00
parport0: PC-style at 0x378 [PCSPP,EPP]
parport_pc: Via 686A parallel port: io=0x378
lp0: using parport0 (polling).
Splash status on console 0 changed to off

Brian1 09-22-2003 06:06 PM

Doesn't look like you loaded the scsi module for the Adaptec controller
Do this. insmod aic7xxxx
Now see what cat /proc/scsi/scsi shows.
If it shows the drive and host, then add this to your /etc/modules.conf file. alias scsi_hostadapter aic7xxx

I believe the one scsi item you seen is the emulation for IDE cdrom to work with older versions of cdrecord.

Good Luck.

michael_mead 09-23-2003 12:22 PM

Ah I see that explains that scsi entry.

Do I replace the 7xxx with the model number of the controller card - or is it just a generic module.

michael_mead 09-23-2003 05:11 PM

Ignore my last post - I did not have access to the server at the time.

But I have since got home and it has worked, dmesg shows

scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.8
<Adaptec 2940 Ultra SCSI adapter>
aic7880: Ultra Wide Channel A, SCSI Id=7, 16/253 SCBs

Vendor: IBM Model: DDRS-39130W Rev: S92A
Type: Direct-Access ANSI SCSI revision: 02
scsi0:A:0:0: Tagged Queuing enabled. Depth 253
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
(scsi0:A:0): 40.000MB/s transfers (20.000MHz, offset 8, 16bit)
SCSI device sda: 17850000 512-byte hdwr sectors (9139 MB)
/dev/scsi/host0/bus0/target0/lun0: p1

Which shows it picks up the card and hard disk. It shows it as 9Gig, but I know its 18Gig.

When I try and mount it, it gives a filesystem error - using vfat for a fat32 partition.

Checking dmesg again it shows;

FAT: bogus cluster size 0
VFS: Can't find a valid FAT filesystem on dev 08:01.

Thanks for your help so far,


Brian1 09-24-2003 05:14 PM

If you can, I repartition and format it.


michael_mead 09-25-2003 04:35 AM

I would but it sees the whole disk as 9GB when I know its 18GB.

I also have some docs I need to get off of there and onto another computer on the network.

I do not have access to the server at the moment, but this evening I will down it and take a look at the controller settings to see if it picks it up as 18GB.

If it does not I will boot from that hard disk and copy the docs up and then try a low level format using the controller utilities.

michaelk 09-25-2003 04:54 AM

A quick search of DDRS-39130 says that it is a 9.1 gb hard drive.

michael_mead 09-25-2003 07:34 AM

Checking out the hard disk that model number is on it. I have done the search myself and there is no doubt that it is 9GB. Someone gave it to me and told me it was 18GB.

I still have a problem mounting it though? Its definatly fat32 as I booted from it into windows 98

michaelk 09-25-2003 07:43 AM

How is it partitioned?

fdisk -l /dev/sda

Need to be logged in as root.

michael_mead 09-25-2003 08:22 AM

Heres the output

/dev/sda1 * 1 1111 8924076 c Win95 FAT32 (LBA)

michaelk 09-25-2003 08:41 AM

And do you still get a invalid FAT filesystem?

What about trying:
mount -t auto /dev/sda1 /mnt/scsi

All times are GMT -5. The time now is 01:41 AM.