LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Mounting a USB pen drive in Fedora Core 1 (https://www.linuxquestions.org/questions/linux-hardware-18/mounting-a-usb-pen-drive-in-fedora-core-1-a-126065/)

mrde50garfield 12-15-2003 01:04 PM

Mounting a USB pen drive in Fedora Core 1
 
Any USB pen drive plugged into a Fedora Core 1 box will not automount or be mountedc as a file system at all.

Red Hat is definately behind the times if they don't support them yet.

How can I use USB pen drives with Fedora?

Pcghost 12-15-2003 11:24 PM

Fedora is totally capable of using usb flash drives. Normally they show up as /dev/sda0 or the like. What have you tried?

I mount mine with the following command.

mount /dev/sda0 /mnt/flash -t vfat

After having created the /mnt/flash directory and the sda0 is assuming no other usb mass storage devices are plugged in, otherwise it becomes sda1 etc..

moshebagelfresser 07-26-2010 02:14 AM

usb flash on key
 
I seemed to have solved the problem in Madriva 2010 and I reckon that this may well work in other distros.

In root do
dmesg to see what you got.

mkdir /dev/flash
mkdir /dev/sd0
mkdir /dev/sda1
mkdir /dev/sdb1
mkdir /mnt/flash
mkdir /media/usb_storage

give permissions for udev, dev, mnt

chmod o+r /dev/flash
chmod o+r /mnt/flash


All times are GMT -5. The time now is 12:34 PM.