-   Linux - Hardware (
-   -   Mounting a UFS volume on CentOS 6 (

FancY_Hat 08-01-2012 01:47 AM

Mounting a UFS volume on CentOS 6
Okay. so I've got a FileServer that I've put a lot of work into; I decided to have one HDD be the OS, and my brand new 1TB drive be my actual file serving volume.

I got it set up, however ran into a few problems regarding my domain name, BSD, and then a bug, which led me to change my OS to CentOS 6.3. the problem is, that my fileserver volume is UFS which CentOS doesn't recognize by default. I Did some online searching, and found and installed the proper kernel module from here. however now when I attempt to mount it, I get this:

[root@FileServer files]# mount -t ufs /dev/sda /mnt/FilServe/
mount: wrong fs type, bad option, bad superblock on /dev/sda,
      missing codepage or helper program, or other error
      In some cases useful info is found in syslog - try
      dmesg | tail  or so

then I decided to follow my system's suggestion (I figured it knew what it was talking about). I got this:


[root@FileServer files]# dmesg | tail
ufs was compiled with read-only support, can't be mounted as read-write

however an ls -al of the directory returns:

[root@FileServer files]# ls -al /dev/sda*
brw-rw----. 1 root disk 8, 0 Aug  2 01:15 /dev/sda
brw-rw----. 1 root disk 8, 1 Aug  2 01:15 /dev/sda1
brw-rw----. 1 root disk 8, 2 Aug  2 01:15 /dev/sda2

so I'm a little worried here. I'm pretty sure, that the hard drive itself is intact, as it was working just fine before, however, I'm confused as to why this is being so uncooperative. I'm not sure why it's saying it's read only, when the permissions say it's not, and even if it is read only, I don't really know how to fix it. I REALLY don't want to have to reformat that volume, as I don't have anything with which to backup the data; so I'm hoping that I missed something, or typed something in wrong. Any help is appreciated

roger_heslop 08-01-2012 02:39 AM

A bit of a disclaimer, I'm not all familiar with UFS, so if what I'm saying sounds off, let me know. It looks like the mount command used only included the disk, not the partition. For example:


mount -t ufs /dev/sda /mnt/FilServe/
as opposed to


mount -t ufs /dev/sda1 /mnt/FilServe/
When you did a listing of /dev/sda*, it did show two partitions, have you tried mounting both partitions with the same result?

FancY_Hat 08-01-2012 06:00 PM


Originally Posted by roger_heslop (Post 4742819)

When you did a listing of /dev/sda*, it did show two partitions, have you tried mounting both partitions with the same result?

yes. Sorry. I should have mentioned that before, I've tried both partitions with the same error returned

TommyC7 08-01-2012 06:03 PM

I'm not sure if CentOS can mount UFS. I know the Linux kernel had modules for mounting UFS but last time I recall, it was read-only (and a warning about how dangerous it was also included). Perhaps the configuration is not set in the CentOS kernel?

FancY_Hat 08-01-2012 06:18 PM

That would support the error message. "kernel compiled as read only". Even so, It should at least MOUNT, if even as a read only file As for ufs being dangerous, I can't speak for that. I hadn't heard of the that type of file system until I installed freeNAS. But that said, freeNAS had absolutely no problems with it for about a month and a half

TommyC7 08-01-2012 10:12 PM

UFS isn't dangerous or anything, mounting it using the Linux kernel is what's dangerous.

All times are GMT -5. The time now is 12:19 AM.