-   Linux - Hardware (
-   -   mount: wrong fs type, bad option, bad superblock on /dev/cdrom, (

Adil_uk 02-03-2005 01:28 PM

mount: wrong fs type, bad option, bad superblock on /dev/cdrom,

Everytime I try to access the cdrom I keep getting this error, the floppy open but I can't see anything on it, its empty:

this is the error i get when clicking on the cdrom icon:

mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems

when I type :

# mount

I get this

/dev/hda2 on / type ext3 (rw)
/dev/hda1 on /usr/local type ext2 (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
proc on /proc type proc (rw)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/fd0 on /mnt/floppy type vfat (rw,nosuid,nodev)

this is the fstab file:

# cat /etc/fstab
/dev/hda2 / ext3 defaults 1 1
/dev/hda1 /usr/local ext2 defaults 1 2
/dev/cdrom /mnt/cdrom iso9660 ro,noauto,owner 0 0
/dev/fd0 /mnt/floppy auto noauto,user 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

Thanks in advance!

kscott121 02-03-2005 04:08 PM

What is the output of the command
ls -l /dev/cdrom

Here is mine
[kens@mybox kens]$ ls /dev/cdrom -l
lrwxrwxrwx 1 root root 9 Jan 20 13:36 /dev/cdrom -> /dev/scd0

This means it points the CDrom device at a emulated scsi device which is the actual CD-Rom device. A common practice.

Right after you reboot the machine what is the output of the dmesg command and is there anything in there about the CDrom?

What distribution are you running?
Have you tried running briefly off of a live-CD (MEPIS, KNOPPIX etc.) to see if that distro sees your CD rom ok.
If so, how does it refer to the CD in these commands?


Easy to use is easy to say!

michaelk 02-03-2005 04:16 PM

What type of CD are you trying to mount?
You can not mount audio CDs.

Adil_uk 02-04-2005 07:37 AM

I was just trying to play music from the cd.

michaelk... was right,

I thought I could mount cd with audio on it :-),

I replaced the cdrom that contain audio, and put one with slackware and wallaahaah worked,

just curious thou, why can't i mount audio cdrom?

thank you both ( michaelk + kscott121)

michaelk 02-04-2005 07:43 AM

An audio CD does not contain a valid filesystem.

Adil_uk 02-04-2005 07:56 AM

thanks for clarifying that!

m_goku 02-11-2005 12:44 AM

hi, i dont use audio cd but i got simillar problem. whenever i mount my cd, i got some message :
/dev/hdb: Input/output error
mount: block device /dev/hdb is write-protected, mounting read-only
dev/hdb: Input/output error
mount: can't read superblock

help please

kscott121 02-11-2005 06:53 AM

Post your /etc/fstab contents. Maybe your CD is defined as read-only somehow.

m_goku 02-11-2005 05:49 PM

yes right, fstab set my cdrom as read only, but i think its no matter.

however, my friend use the same device, the same fedora core 3 OS, and the same fstab configuration on his computer, but he got no problem with his cdrom

MikeLeRoi 02-16-2005 05:50 PM

I have the same problem when I try to mount a Fat32 partition.

Peter:/home/pedro# mount -t vfat /dev/hda5 /mnt/Programas/
mount: wrong fs type, bad option, bad superblock on /dev/hda5,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

What can I do??


All times are GMT -5. The time now is 10:45 PM.