LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Mount image file of a partition (https://www.linuxquestions.org/questions/linux-hardware-18/mount-image-file-of-a-partition-4175519340/)

ViniciusBorges 09-18-2014 05:52 PM

Mount image file of a partition
 
Hi,

I have generated an image file (.dd) of a partition (/dev/sda4) from my HD (/dev/sda) using the software TestDisk. The refered partition has bad sectors, so the idea is to recover some remaining data. Moreover, the partition is a Windows 8-type (Testdisk recognized as "MS Data"). I stored the image file into my Expansion Drive.
I have tried to mount the image file on my Slackware64 14.0, but I am receiving this message:

Code:

# mount -o loop -t auto /media/Seagate\ Expansion\ Drive/joao\ backup/image.dd /mnt/joao/
NTFS signature is missing.
Failed to mount '/dev/loop0': Invalid argument
The device '/dev/loop0' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

What can I do to mount it and see the files inside it?
Thanks!

yooy 09-18-2014 06:51 PM

have you tried opening .dd file with Testdisk(if that is even possible)?

maybe you should try to do recovery on disk with bad sectors instead of disk image.

jefro 09-18-2014 07:09 PM

Maybe this for ideas. http://madduck.net/blog/2006.10.20:l...-a-disk-image/

Similar sort of ideas. http://askubuntu.com/questions/69363...re-disk-device


All times are GMT -5. The time now is 05:07 AM.