-   Linux - Hardware (
-   -   Motorola SB5100 USB Cable Modem only works after booting from Windows (

mrdarka 08-18-2004 07:22 AM

Motorola SB5100 USB Cable Modem only works after booting from Windows

I'm having a weird problem with my Motorola SURFboard Cable Modem SB5100 connected through USB (uses eth0). I'm dual booting Fedora Core 2 and WinXP. My cable modem only works if I reboot from Windows and then boot Fedora. Otherwise, if I just reboot Fedora, it hangs when trying to bring up eth0. Same applies to shutting down the system.
Another distro I tried, Kanotix BH7 (HD install), had the same problem, except I could use Ctrl+C on boot to make it ignore eth0.

The modem uses the usbnet module on 2.6 kernels and CDCEther on 2.4 kernels. I believe it's a problem in usbnet, as the only distro I got my modem to work flawlessly was Knoppix 3.4 (HD install), which uses the 2.4 kernel. Unfortunately, Knoppix isn't very good as a HD install, so I wanted to try something different :)

I tried connecting it through ethernet too, but it didn't work with two different Realtek cards.

I would be very grateful if someone could help me get the modem to work through USB.

Other specs:
Intel Pentium 4 1.50GHz
256 MB RAM
GeForce2 Ti
Fedora Core 2, WinXP SP2

kilgoretrout 08-18-2004 10:44 AM

I have the identical setup using ethernet and have never had any problems. I found ethernet to work better in both windows and linux. Some realtek cards require you to pass the "noapic" boot option to work. Apparently, there's a problem with acpi and certain realtek chipsets. Try using your realtek nic and booting kanontix using the noapic option and see if that works.

mrdarka 08-18-2004 01:16 PM

Unfortunately, I couldn't get it to work through ethernet on Windows (tried all the steps my ISP gave), so I doubt it would work on Linux :( (can't really try it, as I would have to provide my nic MAC addresses to my ISP again)

doody 09-01-2004 12:16 AM

Ha! So it isn't only me!

I have Road Runner (high speed cable internet) and they gave me a Motorola SURFboard Cable Modem SB5100. I was trying to get it to work in Slack 10 (which I installed a few hours ago) but I couldn't get it to work. So I booted into xp and tried to set it up (using ethernet) but no matter what I did I couldn't get it to work. I was talking to the road runner tech support guy for like 45 minutes trying everything we could think of. Eventually, I tried switching to usb and then it worked!!

But now, I'm still trying to figure out how to get this usb modem to work in slack. Have you gotten it to work yet?

- Stephen

mrdarka 09-01-2004 06:50 AM

heh, I actually switched to slackware not so long ago. It uses the 2.4 kernel, so my modem works perfectly. I just used this howto to set it up:
It's for Motorola Surfboard 4000 series, but it worked for me :)

QuickSHADOWMAN 09-02-2004 05:07 PM

While I have the exact same cable modem, I found that while the drivers for the USB connection worked great in the 2.4.X kernels, they did not once I upgraded to the 2.6.X kernel. So I got a 10/100 ethernet card and used cat 5 to the modem, it was working again. It appears that they still need to do bug fixes on the 2.6.X kernel for the USB cable connections.

All times are GMT -5. The time now is 11:18 AM.