-   Linux - Hardware (
-   -   Monitor problems -- changing resolution back w/o monitor (

Jiawen 03-17-2004 10:53 AM

Monitor problems -- changing resolution back w/o monitor
I recently shipped my Mandrake 9.1 box back to the US and hoped it would work. I sold the old monitor when I was still in Taiwan and bought a new one here in the US - a used Hitachi SuperScan Supreme 803 21" CRT. I hooked it up to my Mandrake box and hoped for the best. The power supply conked out on me, so I replaced it. After I fixed this, the system booted up quite nicely. I had it set for 1024x768, which doesn't use all that screen space very well, so I changed it to 1280x1024. It worked, but had a noticeable flicker, so I tried another resolution. I don't remember what resolution, specifically, I tried, because I now have the following problem.

My monitor flashes "Invalid Sync." when I start my computer, then reverts to some sort of standby mode. At no point do I see the boot sequence; the monitor doesn't show me anything about the BIOS settings or whatever. I need to set it to a usable monitor resolution, but my monitor is unusable, so I can't do anything.

I tried hitting ctrl+alt+f1 to change the X session mode, but still the monitor was unresponsive/black. The monitor is apparently still working, because it does flash "Invalid Sync." on booting, and the power light then goes into a steady blinking mode. Also, the monitor was working fine when I tried 1024x768 resolution.

I also tried unplugging everything and replugging it, but it didn't help. I could try a different monitor, but I'm afraid that I might screw that one up somehow.

How do I change the monitor resolution without using a monitor?

aaa 03-17-2004 11:31 AM

I think it is a stubborn monitor, you should be able to go to text mode fine. Try unplugging the monitor totally, then try to boot in text-mode without looking. Then plug it in. If you try another monitor, be sure to boot in text-mode and change the setting before starting X.

You can boot in text-mode without going to X at all by adding the '3' option. If you are using the graphical lilo bootmenu, press tab or esc, and type the os you want to boot, a space, then '3', then enter.

Jiawen 03-17-2004 11:51 AM

Thank you for the reply! However, I was unclear on how to boot into text mode. How do I type the OS I want to boot? Do I type "LINUX" or "linux" or "mdk" or "MANDRAKE" or what?

FYI, if it's useful, the bootmenu I use is the standard Mandrake one - a Mandrake screen asking what OS to use, then the user login screen.

Also, how do I know if the system is actually doing what I want? I can't see what it's doing at all, since the monitor is unresponsive. Will I be screwing things up even worse, not being able to see what I'm doing?

Oh, also -- I would try booting from a CD (I have Knoppix, for example), but when I did manage to get Mandrake up and running, the system didn't seem to recognize the CD drives. I tried goofing around with that, but to no avail. That's the next thing to work on once I get the monitor working. :rolleyes:

Thanks again for helping.

aaa 03-17-2004 12:00 PM

Type the name of what you usually choose. I think it would be 'linux', lowercase. If you boot successfully, you'll hear the hd working. To find out out if you are in text mode, log in and type a command ('du', lists folder size), and if you hear the hd working when you press enter, you are in text-mode. Then try plugging the monitor in. You wouldn't be messing up anything, 'du' is pretty benign.

Jiawen 03-17-2004 06:08 PM

Unfortunately, it didn't work. I tried my other computer and, at least for now, have given up on fixing the resolution on the one that was causing me the problems.

Thanks for the help, though! :)

AutOPSY 03-17-2004 11:06 PM

This is ridiculous, how would you fix your problem if you were booted into dos even, or any other OS.

I think the smartest thing to do would have been, "Get another Monitor".

All times are GMT -5. The time now is 02:36 AM.