LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 08-31-2014, 11:33 AM   #1
orcaja
Member
 
Registered: Aug 2008
Posts: 86

Rep: Reputation: 1
Unhappy Monitor brightness


I have a hp Pavilion 23, with windows and debian wheezy. The monitor in debian is too bright, and I have not been able to change the brightness.
The output of lspci is:
Quote:
00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)
I looked on system settings -> color and icon for the monitor says "unknown - default uncalibrated"

I downloaded the "Brightness Controller 1.1" from here:
http://linuxg.net/manage-your-displa...ative-systems/

But it doens't doe anything, and the messages on the console are:
xrandr: Gamma size is 0.
xrandr: Gamma size is 0.
xrandr: Gamma size is 0.

I typed this:
"egrep -i " connected|card detect|primary dev" /var/log/Xorg.0.log"
that I saw on a Ubuntu forum:
http://askubuntu.com/questions/28033...-video-drivers

but doesn't give anything back.

I also typed
Quote:
xrandr --output HDMI1 --brightness 45
and got this:
Quote:
xrandr: Failed to get size of gamma for output default
warning: output HDMI1 not found; ignoring
xrandr: Need crtc to set gamma on.
Is there any way to change the brightness on debian, lcd monitor? the brightness is too intense that cause the eyes to become tired.
Any advice will be really appreciated.

Thanks
/Joc
 
Old 08-31-2014, 06:08 PM   #2
ferrari
Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE 13.1
Posts: 628

Rep: Reputation: 67
Can you not adjust the monitor brightness directly?

Check the following
Code:
xrandr --verbose |egrep '(Bright|Gamma)'
If values are not returned, then it may not be possible to make a brightness adjustment.

For reference, I get
Code:
xrandr --verbose |egrep '(Bright|Gamma)'
        Gamma:      1.0:1.0:1.0
        Brightness: 1.0
The sensible range for my laptop display (LVDS1) is between ~0.2-1.0.
 
Old 09-01-2014, 03:45 PM   #3
orcaja
Member
 
Registered: Aug 2008
Posts: 86

Original Poster
Rep: Reputation: 1
I got this:

Quote:
xrandr: Failed to get size of gamma for output default
 
Old 09-01-2014, 07:47 PM   #4
ferrari
Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE 13.1
Posts: 628

Rep: Reputation: 67
Anything listed with the following?

Code:
ls -l /sys/class/backlight
If not, it could be due to a kernel or video driver bug I guess.

For reference, I get
Code:
lrwxrwxrwx 1 root root 0 Aug 31 13:33 acpi_video0 -> ../../devices/pci0000:00/0000:00:02.0/backlight/acpi_video0
lrwxrwxrwx 1 root root 0 Sep  1 14:40 intel_backlight -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-LVDS-1/intel_backlight
and acpi_video0 contains
Code:
-r--r--r-- 1 root root 4096 Aug 31 13:34 actual_brightness
-rw-r--r-- 1 root root 4096 Sep  2 12:37 bl_power
-rw-r--r-- 1 root root 4096 Aug 31 13:33 brightness
lrwxrwxrwx 1 root root    0 Sep  2 12:37 device -> ../../../0000:00:02.0
-r--r--r-- 1 root root 4096 Sep  1 14:41 max_brightness
drwxr-xr-x 2 root root    0 Sep  2 12:37 power
lrwxrwxrwx 1 root root    0 Sep  1 14:40 subsystem -> ../../../../../class/backlight
-r--r--r-- 1 root root 4096 Sep  1 14:41 type
-rw-r--r-- 1 root root 4096 Aug 31 13:33 uevent
Current brightness reported via
Code:
 # cat brightness
10
I can adjust with something like
Code:
echo "7" > brightness
Are you able to do similar?

Last edited by ferrari; 09-01-2014 at 07:48 PM.
 
Old 09-01-2014, 10:11 PM   #5
ferrari
Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE 13.1
Posts: 628

Rep: Reputation: 67
It might be useful to see what boot options are in use
Code:
cat /proc/cmdline
This might be relevant to you

http://www.techjail.net/solved-brigh...-pangolin.html

In particular, the following boot parameter might help
Code:
acpi_backlight=vendor
Examine /var/log/Xorg.0.log to confirm that the intel driver is actually in use (rather than the vesa driver for example).
 
Old 09-03-2014, 02:53 PM   #6
orcaja
Member
 
Registered: Aug 2008
Posts: 86

Original Poster
Rep: Reputation: 1
for

Quote:
ls -l /sys/class/backlight
I get
Quote:
total 0
 
Old 09-03-2014, 02:55 PM   #7
orcaja
Member
 
Registered: Aug 2008
Posts: 86

Original Poster
Rep: Reputation: 1
Boot options:

Quote:
cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-3.2.0-4-amd64 root=UUID=4fd53150-e7f5-4df1-ace0-821d1251cfbc ro quiet
 
Old 09-03-2014, 03:19 PM   #8
ferrari
Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE 13.1
Posts: 628

Rep: Reputation: 67
All I can recommended (beyond submitting a bug report), is to try adding the boot parameter I suggested in post #5.
 
Old 09-05-2014, 10:03 AM   #9
Soadyheid
Member
 
Registered: Aug 2010
Location: Near Edinburgh, Scotland
Posts: 966

Rep: Reputation: 169Reputation: 169
As per ferrari:
Quote:
Can you not adjust the monitor brightness directly?
what sort of monitor is it? Most monitors allow you to manually adjust brightness, contrast, colour temperature, etc, via control buttons or am I missing something?

Have you tried setting it up manually for Debian then tweeking Windows to suit? Why is Windows assumed to be the default?

Oooooh controversial!

Play Bonny!

 
Old 11-01-2014, 11:38 AM   #10
orcaja
Member
 
Registered: Aug 2008
Posts: 86

Original Poster
Rep: Reputation: 1
Quote:
what sort of monitor is it? Most monitors allow you to manually adjust brightness, contrast, colour temperature, etc, via control buttons or am I missing something?
This is an "all in one", and only has one button to turn on. This computer came with windows preinstalled (8.1, and also has UEFI), and from windows you can change the brightness with the keyboard, but there are no controls on the monitor. The brightness menu is not available on my gnome
 
Old 11-01-2014, 04:10 PM   #11
ferrari
Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE 13.1
Posts: 628

Rep: Reputation: 67
Did you ever try the boot parameter suggestion that I mentioned?
 
Old 11-02-2014, 07:00 PM   #12
orcaja
Member
 
Registered: Aug 2008
Posts: 86

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by ferrari View Post
Did you ever try the boot parameter suggestion that I mentioned?
I did, but I don't know what I am supposed to see on /var/log/Xorg.0.log. This is what I did:
Code:
$ cat /var/log/Xorg.0.log | grep "intel"
[    16.168] (==) Matched intel as autoconfigured driver 0
[    16.168] (II) LoadModule: "intel"
[    16.168] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    16.200] (II) Module intel: vendor="X.Org Foundation"
[    16.219] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
[    16.341] (II) UnloadModule: "intel"
[    16.341] (II) Unloading intel
The intel module is being Unloaded. Is there anything else that I should do?
Thanks in advance.
/joc
 
Old 11-02-2014, 07:36 PM   #13
ferrari
Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE 13.1
Posts: 628

Rep: Reputation: 67
Ah, if the Intel driver is being unloaded, then that may explain why screen brightness adjustment is not working. It is likely that a basic framebuffer driver (eg fbdev or vesa) is in use. This problem needs addressing first. It might be useful to upload your entire Xorg.0.log to http://pastebin.com/, and post the link to it here.

You should supply your graphics card details from
Code:
/sbin/lspci -nnk |grep VGA -A3
It may well be that you're running a kernel that is too old to support this graphics hardware.
 
Old 11-02-2014, 07:59 PM   #14
ferrari
Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE 13.1
Posts: 628

Rep: Reputation: 67
Perhaps this Debian thread is relevant to your situation.
 
Old 11-03-2014, 04:54 PM   #15
orcaja
Member
 
Registered: Aug 2008
Posts: 86

Original Poster
Rep: Reputation: 1
Talking

Quote:
Originally Posted by ferrari View Post
Perhaps this Debian thread is relevant to your situation.
It worked!. Now in system settings I have a bar, that I can move and change the brightness!. Thanks man, your'e the awesomest
I owe you a beer.

/Joc

Last edited by orcaja; 11-04-2014 at 06:41 AM.
 
  


Reply

Tags
brightness, debian, monitor


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how can one adjust the monitor brightness? harryhaller Slackware 3 02-25-2011 04:44 AM
change the monitor brightness naveenisback Programming 1 02-08-2010 07:10 AM
Increase monitor brightness Lorian Linux - Hardware 5 10-08-2006 05:45 AM
monitor brightness issue 54d1 Debian 3 09-17-2004 08:02 PM
Monitor Brightness question igorogre Linux - Hardware 1 08-15-2003 09:41 AM


All times are GMT -5. The time now is 05:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration