LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Monitor blanks during text boot (http://www.linuxquestions.org/questions/showthread.php?t=4175455008)

FabriRama 03-21-2013 10:41 AM

Monitor blanks during text boot
 
Hello everybody,
I have this setup: Scientific Linux 6.1 64 bit, NVIDIA quadro 4000 with nvidia proprietary drivers 310.32.
The monitor is a 2560x1440 only resolution via Display Port.
I followed the right procedure to install the proprietary drivers(deinstalled nouveau ecc)

When I boot up the pc there are about 20 seconds when the monitor blanks (during text mode), when Xorg starts the video is displayed correctly.
I tried to start the PC in text mode only (runlevel 3) and when the booting sequence is about half done the monitor starts blanking and is gone completely.
If I connect to the pc via ssh and issue a init 5 to switch to runlevel 5 the video is shown ok and if I reissue a init 3 to go back to runlevel 3 the video is shown ok as well, seems that something is changed in the graphic board.
I've found that the problem arises only when the system boots in runlevel 3 or is switching from textmode to graphics(runlevel 5).
When the system is started in runlevel 3 and the monitor blanks, if I issue the command:
/usr/bin/nvidia-smi -L
the video is suddenly shown ok (I see Linux login) but after some seconds goes away again, and if I reissue the same command above the login turns back then goes away again.
I tried to put the board in Persistent mode ( /usr/bin/nvidia-smi -pm 1 ) but it didn't work either issuing the nvidia-smi -L .
I've looked with the command: nvidia-smi -q and found that when I am in text only mode the attribute: Display Mode is set to Disabled
whereas when in runlevel 5 the Display Mode is set to Enabled
Is there a way to solve this problem? seems that when in text mode (runlevel 3) or in the way to switch to runlevel 5 the Graphic board seems to sleep and doesn't provide the signal to the monitor and if I query the board with the nvidia-smi -L she wakes up for some seconds and then back again to sleep and the console is not displayed on the monitor.
Any help?
Best regards

PhoenixAndThor 03-22-2013 05:45 AM

First, I have absolutely no experience with Scientific Linux. The first thing I have to ask is how are you trying to boot into textmode? Are you using GRUB? Are you selecting an option from a boot menu, or are you hitting the Tab or E keys to edit an existing entry? One possible workaround is to modify the configuration for runlevel 3 so that it actually starts up in runlevel 5, but then switches to runlevel 3 after everything loads.

FabriRama 03-22-2013 05:55 AM

Hello PhoenixAndThor,
Thanks for the reply, I boot into Linux via Grub (0.97), to boot into text mode directly I changed the file /etc/inittab and put 3 as the default runlevel at startup.
Regards
Fab

PhoenixAndThor 03-23-2013 02:22 AM

According to the entry on DistroWatch, Scientific Linux is based on Red Hat, so you may be able to use this: 10.2 Configuring the Services - Red Hat Customer Portal

One of the tools on that page should give you more information about runlevels 3 and 5. That way, you can figure out what 5 is doing that 3 is not and what seems to be a necessary adjustment.

I hope that solves your problem. If not, then somebody else has to help you as my usual solution to screen problems is using a different graphics card or installing a new distribution.


All times are GMT -5. The time now is 09:39 PM.