-   Linux - Hardware (
-   -   Momentus XT not seen (

Shpawk 07-04-2013 06:39 PM

Momentus XT not seen
Ok, I hope someone can help. I'm using Knoppix which I once read was not covered by Linux Questions but I never had this problem before so I don't think its particular to Knoppix.

My new and otherwise impressive Novatech elite has a Seagate Momentus XT hybrid 750GB SHDD. It is not seen in the filesystem however. The suppliers suggest I send the machine or the drive back to them but I am very reluctant to do this without exhausting every other possibility. I ran "dmesg | less" and saw some messages mentioning "ata3.00 ACPI _SDD failed" and similar but I'm not certain this guarantees an actual physical failure. The manufacturers say they do not "officially" support Linux.

I have a USB external drive which works fine and makes the computer usable even in this far less than perfect state. Until now I've been using year 2000 or so vintage towers and so even without the internal hd the speed at my disposal now is just amazing. Any suggestions as to what I could do?

Shpawk 07-05-2013 08:12 AM

Ok, so here is the answer to my own question in case anyone needs it:

Drive was not partitioned. I partitioned it with GParted. Had come accross this before but do not need to do it often so I'd forgotten. A visit to Seagate website is reminded me to do this.

Shpawk 07-05-2013 08:42 AM

Still not quite sure everything will be as I want it however. Because I'd had problems with a Western Digital external "My Passport" drive - (problems formatting and accessing ext2 partitions whereas formatting and accessing an NTFS partition worked ok) - I took the "easy" option of creating an NTFS partition on the Seagate drive. I didn't really want to do this. I want as pure Linux as poss.

So now I guess I'll have to try creating a new partition with ext2 or whatever is the best Linux format. Do you think this will work with this drive or am I likely to similar problems as I had with WD drive? By the way, in GParted the ext2 partitions I created have key symbols next to them. What does this tell me?

I am grateful for any answers you folks may have.

Shpawk 07-05-2013 09:01 AM

No, things aren't yet looking as they should. I still get the same above-mentioned "failed" messages when I run dmesg.

Shpawk 07-07-2013 04:06 AM

As well as the error messages, I can't seem to install any OS, only Knoppix, which runs on RAM so this also suggest some hard disk problem. The latest OS I tried was Debian 7 64-bit. I get GRUB. I think this happens when the normal installation procedure has stalled. I will check the online Debian documentation again.

Hey! this post is beging to look like my own little blog. A diary of my experiences with my new computer and its Momentus XT drive. That's cool. Maybe someone will benefit by reading this some day but I was really looking for some help.

onebuck 07-07-2013 10:58 AM

Member Response

I would think that you could use the manufactures diagnostic set to test the drive. If not then use a LiveCD;

From: Tools, Recovery, Diagnostic, Emergency

UBCD Ultimate Boot CD <- 'UBCD allows users to run floppy-based diagnostic tools from most CDROM drives on Intel-compatible machines, no operating system required. The cd includes many diagnostic utilities.'

SystemRescueCd <- 'is a Linux system on a bootable CD-ROM for repairing your system and recovering your data after a crash. It aims to provide an easy way to carry out admin tasks on your computer, such as creating and editing the partitions of the hard disk. It contains a lot of system utilities (parted, partimage, fstools, ...) and basic tools (editors, midnight commander, network tools).' + 'Online-Manual

You could use one of the above LiveCD diagnostics to test the drive.

If it is under warranty then the best thing would be to return with authorization(RTA) from the vendor and get a known good drive. Longer you wait then a return may not be authorized.


Shpawk 07-07-2013 12:29 PM

Thanks for the reply it is very much appreciated.

But reading back I seem to have left out one possibly vital piece of information. I do not think I mentioned that the disk IS accessible as storage when I use Knoppix. I can read and write to the disk. But still it happens that if I try to install any operating system the procedure fails.

I downloaded Debian 7 for amd64 last night and it gets as far as a brief message saying: 'Error "Prefix" not set"' Then I get 'Welcome to GRUB!' and a GRUB command propmt. Do not know what to do from here but I think this would not happen if everything was OK. To make matters harder, the GRUB commands listed are not the same as in the ones in the online GRUB manual. That is for GRUB2 wheras the version I see is 1.99. Could not find the manual for this.

I cannot tell you how reluctant I am to return this hard drive let alone the computer itself. I have come accross so many situations with machines from computers to cars where the way round the problem turned out to be something very silly.

If I return this machine I suspect the manufacturers will just try to persuade me to install Windows. I only bought from them because they sold machines without an OS pre-installed. I mistook this for a Linux-friendly attitude but any support I will get from them, they tell me will be "unofficial".

And I should repeat that in addition to problems installing an OS (as well as the recent Debian I've also tried older versions of OpenSuse and Ubuntu and even an old Windows xp installation fails), I also, when I use: "dmesg | less", get output such as:

[ 7.273205] ata5.00: ACPI _SDD failed (AE 0x5)
[ 7.273208] ata5.00: ACPI: failed the second time, disabled

I'm asking myself if it is possible for the conventional part of the hybrid disk to function while the solid-state part fails? I'm also concerned that it may be a matter of firmware designed to be difficult if not used with Windows? I would really like to hear from someone running Linux from this particular type of disk. I would at least know then that what I'm trying to do is possible.

Shpawk 07-08-2013 04:28 PM

Ok I've sent it back. Could not delay any longer. I may wish to add further comments so I'll keep the thread open for now.

All times are GMT -5. The time now is 09:56 PM.