-   Linux - Hardware (
-   -   modules prob after kernel update (

CycloneInDC 02-18-2003 09:17 PM

modules prob after kernel update
Well, I must be a glutton for punishment. I swear that I live by the motto "If it ain't broke, fix it until it is". Here's my dilemma:

I installed Red Hat 8.0 on a Dell Inspiron 8200 and all is good. The display works great, sound good, wired ethernet AOK, wireless not so good. So I go out surfing to find the latest and greatest to get my wireless working and in the process decide to upgrade my kernel to 2.4.20. The steps that I did are:

1) make xconfig
2) make dep
3) make
4) make bzImage
5) make modules
6) make modules_install
7) make install
8) Edit Grub

If I remember correctly I had a little bit of problem with #5 the first time around, but I THOUGHT that I fixed it the 2nd time around. Anyway, I boot up my new shiny 2.4.20 and I get a few errors:

Initializing USB HID interface: Cannot locate module hid [ERROR]
Initializing USB keyboard interface: Cannot locate module keybdev [ERROR]
Initializing USB mousedev interface: Cannot locate module hid [ERROR]
Initializing Firewire 1394 interface - Cannot locate module ohci1394 [ERROR]

There's also a problem now with my wired ethernet port, but I'm not worried about that right now.

After I type in my username and password I get a popup box in KDE saying:

Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such device)
The sound server will continue, using the null output device.

I looked and there is a /dev/dsp and I never had a problem with the sound until I moved to this 2.4.20. Somehow I must have screwed something up, but I don't know how. Anyway, I'd like to fix this problem. I've tried doing what the 48 other posts on this say, which is try the redhat-config-soundcard, but this just pops up a box saying:

Vendor: Intel Corp.
Model: 82801CA/CAM AC'97 Audio

When I click on the play test sound I get the error message:
sox: Can't open output file '/dev/dsp': No such device

lsmod produces:
Module Size Used by Tainted: P
nvidia 1592352 11 (autoclean)
orinoco_cs 5768 2
orinoco 37464 0 [orinoco_cs]
hermes 7780 0 [orinoco_cs orinoco]
ds 8840 4 [orinoco_cs]
yenta_socket 13056 2
pcmcia_core 59968 0 [orinoco_cs ds yenta_socket]

How do I fix this and the other modules problems? I felt proud of myself after getting the NVidia drivers to work (well, the RPMs didn't, but the tarballs did) but this is starting to frustrate me.


finegan 02-18-2003 09:49 PM

Make sure to run "depmod -a" after creating new modules... also, /dev/dsp doesn't get "created" unless there is a recognized audio device, so its just a matter of compiling in support for the i810_audio module under the list of soundcards... that's about it really...



CycloneInDC 02-19-2003 12:12 AM

OK, I'm slightly confused on this. At what point should I have run the depmod -a? I didn't download any drivers or anything since they were already working in my original setup. I figured that since they were there before that they would be there when I went to the new kernel. I looked at the man page for depmod briefly and it talked about putting /sbin/depmod -a in the rc.d dirs, but I don't think that I like that solultion. There must be a better way - some way to rectify this wrong I have done.

I looked in my /lib/modules/2.4.18-24.8.0/kernel/drivers/sound
and there is an i810_audio.o, but there isn't even a sound dir in the /lib/modules/2.4.20/kernel/drivers directory (actually, there are only 3 dirs - net, pcmcia, and video). I did a locate on i810_audio and I see that there is /usr/src/linux-2.4.20/drivers/sound/i810_audio.c I figure that somewhere in the process this should have been turned into the .o, but what at what point was that?

finegan 02-19-2003 12:18 AM

You can, and this is rather hackish, but I do it a lot because I'm lazy, make say the 2.4.20 kernel, then make and install the modules... then say you want a new feature, an ethernet module, make menuconfig (or xconfig, whatever), add the module, skip make clean, and just run make modules, make modules_install, run depmod and load the module... works most of the time, not all the time, but even 5 minutes for a full run compile makes me bored these days...

I assumed that you make a 2.4.20 and its associated modules, went and "make clean", then added what you need, re-built everything, and installed the new kernel... well, you just added to an already full stack of modules in /lib/modules/2.4.20, and still need to run depmod -a to get the new ones to modprobe right... sometimes.

Did you not build a new i810_audio.o with the new kernel?



CycloneInDC 02-19-2003 12:33 AM

Yah, I didn't build the new i810_audio.o with the new kernel because I didn't know that I needed to. Also, those are the steps that I exactly typed in, so I did no make cleans of any sort. Do I have to manually compile all of the things that I am missing, and if so, where do I find them. Like I posted above, I might have found the .c file, but How do I get that to where it needs to go?

finegan 02-19-2003 11:58 PM

i810 is under

< > Intel ICH (i8xx), SiS 7012, NVidia nForce Audio or AMD 768/811x

after the make dep its best to run a "make clean" Also, when compiling another kernel from the ground up, its best to run a "make clean" as the first step. If you want to zap your current configuration file, you can run "make mrproper" which will take the source all the way to the way you downloaded it.



whohasit 11-14-2003 05:35 PM

Sound on Inspiron 8200

Did you ever get this to work properly?

I am running 9 now, and previously was running 8 on this machine and had the same problem. Sometimes the sound would work even if it warned me that "cannot locate..using the null...".

Please let me know what you had to do, (if you remember), and if it wroks now...

Anyway, as you may agree, I am surprised that with the ubiquity of Dell laptops and sound applications, that this issue still exists on a vanilla installation.... but alas..


All times are GMT -5. The time now is 03:58 PM.