-   Linux - Hardware (
-   -   midi / synth sound with SIS7012 aka Intel i8x0 onboard sound card does not work (

wahwah 11-03-2003 06:40 AM

midi / synth sound with SIS7012 aka Intel i8x0 onboard sound card does not work

I've posted this problem on the Newbie list some time ago, but didn't arrive at a solution; and now the thread has moved to the neverland of remote pages. Perhabs the Hardware list is more appropriate.

I've recently installed SuSE 8.2 on a new machine (intel P4 2600 MHz, P4 Titan GA-8SG800 board).
There were some (3D acceleration) problems with the NVidia GEForce video card, but I've got all that working now. One thing remains problematic, and that's sound.

This P4 board has got an onboard sound system, detected by SuSE as a
SIS7012 / Intel i8x0.

The problem is that I can get the simple system sounds (wav files and the like) to work, but all other sound options / progs (Midi, Brahms, etcetera) do not work.

The boot.msg says:

++++++++++++<snip> ++++++++++++
<notice>'/etc/init.d/rc5.d/S10smbfs start' exits with status 6
<notice>/etc/init.d/rc5.d/S13alsasound start
<notice>'/etc/init.d/rc5.d/S13alsasound start' exits with status 0
<notice>/etc/init.d/rc5.d/S13fbset start
<notice>Searching for unresolved configuration files

Please check the following files (see /var/adm/rpmconfigcheck):

++++++++++++<snip> ++++++++++++

and in /etc/mailman.mail-gid.rpmnew is just '65533'.

(boot.msg ends with "Skipped services in runlevel 5: smbfs")

The TTY10 console says things like:
- modprobe: can't locate Module sound-slot-0
- modprobe: can't locate Module sound-service-0-0
- modprobe: can't locate Module char-major-116
over and over again.
I can see there's two lines in modules.conf mentioning 'major-116', but thery're commented out.
I do not know if I can simply start fiddling with these lines in modules.conf, but since I'm reasonably new to Linux, I thought it's better to ask first before I start breaking things :-)

Some days ago I ran alsaconf; which indeed succeeded insofar that I could now play device sounds (before, there was no sound at all) ... but they sound very bad (like multiple modules are loaded) and MIDI and the like are still dead; I get repeated messages saying 'no sound card available or not yet configured'.

So, I deleted the ALSACONF portion again from the modules.conf and ran the sound setup of Yast2 again: system (wav) sounds returned, but the rest still doesn't work.

Here my lack of experience starts to take its toll: I'm at a loss.
Anyone any idea what to try next?

thanks a lot ...


wahwah 11-10-2003 05:25 PM

Midi and synth sound problem SOLVED
Hello Gentlepeople,

finally solved the problem.
It took quite some time though and a lot of work.
I discovered after kicking the modules.conf around for a while that the ALSA drivers were not compiled successfully due to something relating to the kernel being compiled with a different cpp compiler than I was currently having.
The solution was to recompile the kernel myself, but being such a newbie, I first refrained.

Well, to cut short, I did yesterday.
And after some tweaking (I first forgot to include reiserfs support :-) and recompiling nvidia drivers to be able to actually start the X server again, I could rebuild the ALSA drivers and everything worked!

One could complain that it took so long to get it going ... not me ... I've learned quite a lot about the system and am on my way out of Kindom Newbie to Kingdom LinuxGeek. Well, sort of; at least the proud owner of a home-compiled kernel.

Tastes good :-)


All times are GMT -5. The time now is 04:31 AM.