-   Linux - Hardware (
-   -   middle button doesn't work (

laurentwahl 05-26-2005 05:40 PM

middle button doesn't work
I have an IBM thinkpad r50p. I have a trackpoint pointing device(the little red button). with the red button there are three buttons, like on a normal 3-button-mouse. but the middle button doesn't work. I have set in the mouse configuration my mouse to a generic 3 button mouse (PS/2).
I also tried other types of mouses but none worked. The "emulate 3 button click" is switched of.
Does anybody have a suggestion?

I use redhat9 with gnome

johnson_steve 05-26-2005 06:45 PM

post your xf86config or xorg.conf file

laurentwahl 05-27-2005 03:43 AM

I have no xorg.conf file and nothing similar.
I neither have a xf86config file, but I found a xf86conf.vim file.
here as some lines which are related with the mouse(or do you want the hole document)

" Options
if b:xf86conf_xfree86_version >= 4
command -nargs=+ Xf86confdeclopt syn keyword xf86confOptionName <args> contained
command -nargs=+ Xf86confdeclopt syn keyword xf86confOptionName <args> contained nextgroup=xf86confValue,xf86confComment skipwhite

Xf86confdeclopt 18bitBus Accel AllowMouseOpenFail AllowNonLocalModInDev AllowNonLocalXvidtune
Xf86confdeclopt AlwaysCore AutoRepeat BaudRate BeamTimeout Beep BlankTime BlockWrite
Xf86confdeclopt ButtonNumber Buttons ButtonThreshold CacheLines ChordMiddle ClearDTR
Xf86confdeclopt ClearDTS ClickMode ColorKey Composite CompositeSync CoreKeyboard CorePointer
Xf86confdeclopt CrtScreen CyberShadow Dac6Bit DacSpeed DataBits DDC Debug DeltaX DeltaY
Xf86confdeclopt Device DeviceName DisableModInDev DisableVidModeExtension DontZap DontZoom DoubleScan
Xf86confdeclopt DozeMode DozeScan DozeTime DPMS DualCount EarlyRasPrecharge Emulate3Buttons
Xf86confdeclopt Emulate3Timeout EnterCount EstimateSizesAggressively ExternDisp FastDram
Xf86confdeclopt FifoAggresive FifoConservative FifoModerate FireGL3000 FixPanelSize FlipXY
Xf86confdeclopt FlowControl FPClock16 FPClock24 FPClock32 FPClock8 FpmVRAM FrameBufferWC
Xf86confdeclopt HistorySize HWClocks HWCursor Interlace InternDisp LateRasPrecharge LcdCenter
Xf86confdeclopt LCDClock Linear MaxX MaxY MGASDRAM MinX MinY MMIO MMIOCache MTTR NoAccel
Xf86confdeclopt NoAllowMouseOpenFail NoAllowNonLocalModInDev NoAllowNonLocalXvidtune
Xf86confdeclopt NoBlockWrite NoCompositeSync NoCrtScreen NoCyberShadow NoDac6Bit NoDDC
Xf86confdeclopt NoDebug NoDisableModInDev NoDisableVidModeExtension NoDontZap NoDontZoom
Xf86confdeclopt NoFireGL3000 NoFixPanelSize NoFpmVRAM NoFrameBufferWC NoHWClocks NoHWCursor
Xf86confdeclopt NoLcdCenter NoLinear NoMGASDRAM NoMMIO NoMMIOCache NoOverClockMem NoOverlay
Xf86confdeclopt NoPC98 NoPciBurst NoPciRetry NoPM NoProbeClock NoShadowFb NoShowCache
Xf86confdeclopt NoSlowEDODRAM NoSTN NoStretch NoSuspendHack NoSWCursor NoTexturedVideo
Xf86confdeclopt NoTrapSignals NoUseFBDev NoUseModeline NoUseVclk1 NoVTSysReq NvAGP OffTime
Xf86confdeclopt Origin OverClockMem Overlay Parity PC98 PciBurst PCIBurst PciRetry Pixmap PM
Xf86confdeclopt PressDur PressPitch PressVol ProbeClocks Protocol PWMActive PWMSleep ReleaseDur
Xf86confdeclopt ReleasePitch ReportingMode Resolution RGBBits Rotate SampleRate ScreenNumber
Xf86confdeclopt SendCoreEvents SendDragEvents SetLcdClk SetMClk SetRefClk ShadowFb ShowCache
Xf86confdeclopt SleepMode SleepScan SleepTime SlowDram SlowEDODRAM StandbyTime STN StopBits
Xf86confdeclopt Stretch SuspendHack SuspendTime SWCursor SyncOnGreen TexturedVideo Tilt TouchTime
Xf86confdeclopt TopX TopY BottomX BottomY KeepShape Port DebugLevel Serial Threshold
Xf86confdeclopt TrapSignals USB UseBIOS UseFBDev UseModeline UseVclk1 VideoKey Vmin VTime VTInit
Xf86confdeclopt VTSysReq XaaNoScanlineCPUToScreenColorExpandFill XaaNoScanlineImageWriteRect
Xf86confdeclopt XkbCompat XkbDisable XkbGeometry XkbKeycodes XkbLayout XkbModel XkbOptions
Xf86confdeclopt XkbKeymap XkbRules XkbSymbols XkbTypes XkbVariant XLeds ZAxisMapping
Xf86confdeclopt LeftAlt RightAlt RightCtl ScrollLock ServerNumLock

delcommand Xf86confdeclopt
I am new with linux, so I don't know what to do with these files, and how I can get the xorg.conf file

johnson_steve 05-27-2005 11:36 AM

if you didn't have one of those 2 files your computer would only work in text mode (no X) try looking in /etc/X11/

laurentwahl 05-29-2005 04:07 PM

Here is the XF86Config file. I didn't find it, because I wrote everything with small letters

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr_CH"

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "IBM 9513 T55A TFT Monitor"
HorizSync 30.0 - 61.0
VertRefresh 56.0 - 75.0
Option "dpms"

Section "Device"
Identifier "Videocard0"
Driver "vesa"
VendorName "Videocard vendor"
BoardName "VESA driver (generic)"

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x960" "1024x768" "800x600" "640x480"

Section "DRI"
Group 0
Mode 0666

samael26 05-29-2005 04:53 PM

Option "Emulate3Buttons" "no"

This is part of your config file. Shouldn't it be a 'yes' in there instead of a 'no' ? :)
You could begin by editing it and replace the "no" by a "true" ?

Option "Emulate3Buttons" "true"

here is the relevant part of mine. I am giving
you mine in Debian, though. No warranty it should work for you.


laurentwahl 05-29-2005 05:02 PM

I thought that the emulate3buttons option, is there when you have a 2button mouse, and then you can push the 2buttons simulately to replace the third button?

laurentwahl 05-30-2005 01:23 AM

Replacing this Option with "Emulate3Buttons" "true" doensn't help.

laurentwahl 06-01-2005 04:35 PM

When I add:

Option "Emulate3Buttons" "true"
now when I push the left and right button simultaneously I receive the effect of the middle button, but my middle button doesn't work.
with Option "Emulate3Buttons" "no", it doesn't work too. what can I do?

All times are GMT -5. The time now is 01:47 AM.