-   Linux - Hardware (
-   -   Microsoft Intellimouse Explorer v.3 Buttons in SUSE 10.1 (

Ancient12 05-14-2006 03:26 AM

Microsoft Intellimouse Explorer v.3 Buttons in SUSE 10.1
In Suse 10.1, KDE 3.5.1 Level"a" :

4th 5th Thumb (side) Buttons didn't work.
Now they do as should. ScrollWheel too. All ..

well , for posterity and the community here is my solution:

/etc/X11 xorg.conf section is :

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "7"
Option "Device" "/dev/input/mice"
Option "Name" "Microsoft 5-Button Mouse with IntelliEye(TM)"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"

than -
xmodmap -e "pointer = 1 2 3 4 5 8 9 6 7 10 11"
if it works ok, than-
create textfile .Xmodmap in home/user and add the line :
pointer = 1 2 3 4 5 8 9 6 7 10 11


rjwilmsi 05-15-2006 07:27 AM

Good info.

Similarly for my mouse with two thumb buttons:


Section "InputDevice"
  Driver      "mouse"
  Identifier  "Mouse[1]"
  Option      "Buttons" "5"
  Option      "Device" "/dev/input/mice"
  Option      "Name" "ImExPS/2 Generic Explorer Mouse"
  Option      "Protocol" "explorerps/2"
  Option      "Vendor" "Sysp"
  Option      "ZAxisMapping" "4 5"
  Option      "ButtonMapping"  "1 2 3 6 7"

thumb buttons operate as back / forward buttons and no need to us xmodmap


KimVette 05-15-2006 10:25 AM

signmeuptoo 05-19-2006 06:07 PM

I followed Ancient's instructions to make my MS Wireless Intellimouse Explorer 2.0 work, and now my forward and back side buttons work but not my scroll wheel (it works as a button properly, but does not scroll, but instead changes words being highlighted erratically). Can anyone suggest what I should do, as I have tried so many things and I have lost a lot of sleep over trying to get this to work over the last couple of days, it's driving me nutso.

signmeuptoo 05-20-2006 01:29 AM

Well, I suspect that part of my problem was that I had a second mouse plugged into the PS/2 port of my computer, so I disconnected it. Now scrolling works, but the forward and backward buttons do not work. Please, can someone offer me some insights?

Edit: I got it:

Here is what I set my xorg.conf to:

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "4 5"
Option "Device" "/dev/input/mice"
Option "Name" "Microsoft Wireless Intellimouse Explorer 2.0"
Option "Protocal" "ExplorerPS/2"
Option "SendCoreEvents" "true"
Option "ZAxisMapping" 6 7"

and I ran xmodmap -e "pointer = 1 2 3 4 5 6 7 8 9 10 11"

and added that line to .Xmodmap.

It turns out I don't have to much with the button order. We will see how it goes when I reboot...

Ancient12 05-20-2006 04:08 AM

Well , first thing to do in a situation like that is have a good night sleep.

If you will notice , your Mouse section in Xorg.conf is different. What seems to me more important is the line:
Option "Buttons" "4 5"
- you are specifying 2 (2!) Number of Buttons. either the mouse has 4 buttons or 5 .

No Vendor ? ...

Zaxis is for the ScrollWheel

Did you edit the file manually ? you have to start IMO with the best fitting SAX2 definition , and THAN tweak

signmeuptoo 05-21-2006 02:55 AM

I am not sure yet, but it seems like I might have it working now. I will post back when I know for sure that all of the parameters are right after rebooting, but right now I am doing all kinds of installs.

BTW: How does one enable forward and backward mouse browsing in Konqueror?

signmeuptoo 05-21-2006 03:05 PM

ok, I have it working now, except that after I reboot, I have to run xmodmap:

xmxmodmap -e "pointer = 1 2 3 10 11 4 5 6 7 8 9"


I DID make the one line file .Xmodmap in my home user directory, but I think that that might be what I did wrong. If I use mcedit, what should the file look like? Thanks.

Ancient12 05-21-2006 04:59 PM

Remove the .xmodmap file. reboot, if u have to run the xmodmap cmd to get things working, than you did not create the .xmodmap file properly.

one line starting at top :
pointer = 1 2 3 10 11 4 5 6 7 8 9
Exactly what u input in the command, no quote marks though.

tripson 05-28-2006 10:36 PM

i just installed one window manager (enlightenment), and i wanna set my mouse (ms intellimouse explorer 2 wireless) to work properly.

i set xorg.conf:
Driver "mouse"
Identifier "Mouse1"
Option "Buttons" "7"
Option "Device" "/dev/mouse"
Option "Name" "ImExPS/2 Generic Explorer Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"

and i wanted to use xmodmap to set thumb buttons (for forward/back) like you, Ancient12 wrote, but i got the error:

$ xmodmap -e "pointer = 1 2 3 4 5 8 9 6 7 10 11"
xmodmap: commandline:0: bad number of buttons, must have 7 instead of 11
xmodmap: 1 error encountered, aborting.

and i really dont know, how it is possible that it works for u, Ancident12. i dont get it.

so, for now (just edited xorg.conf, without xmodmap:S) basic 2 buttons works cool, wheel and wheel button too, BUT thumb buttons not!

for moore information, i use enlightenment and slackware.

Ancient12 05-29-2006 03:30 AM

Must be Enlightment (vs KDE 3.5a here)..
But also, its a different mouse, so I would first get the definitons as close to reality.
The buttons are mapped differently in the Integer string. Since there are 2 side buttons, one must try to position them properly.
If Xmodmap complains than oblige by using 7 (for the model u defined) and than reposition the side buttons

Since there isn't , apparently, a humanly decipherable / graphical universal app to set the functions/buttons properly, we must do with Trial and Error.


basically i started this thread just to inform Linux community, by Google, of my solution. I think a global DB, set by Googling Google results (etc) is a great idea. especially if it can be interfaced to user desktop/system configurator.

All times are GMT -5. The time now is 01:40 PM.