LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-09-2003, 07:33 AM   #1
jbaribeault
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Rep: Reputation: 0
Microsoft Intellimouse 1.2a PS/2 Woes...


I know a LOT of questions/answers have been posted in regards to this mouse and getting it to work under X. Thanks to all who posted/answered as I finally have the mouse working -- *ALMOST* perfectly.

The only trouble I have is that when I send a display from another server (Openview server on Solaris 8) the right-mouse button doesn't seem to accept clicks. Now the kicker -- if I turn off ZAxisMapping in my XF86Config then the mouse wheel doesn't work of course, but the right mouse button clicks do work in the remotely thrown window -- weird!!

I ran xev to see what events are generated under each configuration, and "button3" the right-mouse button is missing a release event with the ZAxisMapping turned on.

There are no error messages in the SSH session that launched the application being thrown to my workstation about invalid events or anything (i had some that had to do with fonts earlier that I have since fixed as well)

Here are the details:
Linux From Scratch -- Running GCC 3.2.3, Kernel 2.4.20, GLIBC 2.3.2, GTK+ 2.2.2 and 1.2.10 (old one needed by Opera)
XFree86 4.3.0 Running either Windowmaker or KDE (tried both)
Microsoft Intellimouse 1.2a PS/2 Compatible (PS/2 port, no adapter)

Config that works on remote window:

Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "Buttons "3"

Config that all buttons work, wheel works wonderfully in local X , but not right click in the remote X window

Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "Buttons "5"
Option "ZAxisMapping" "4 5"

Any ideas??
 
Old 09-09-2003, 07:45 AM   #2
nhs
Member
 
Registered: Aug 2003
Location: Edinburgh, Scotland
Distribution: Gentoo
Posts: 246

Rep: Reputation: 30
Try using Option "Buttons" "5" without ZAxisMapping and see whether the right mouse button becomes button four or five. If so try Option "Buttons" "6" and see whether this helps keep every button separately.
 
Old 09-09-2003, 08:16 AM   #3
jbaribeault
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks for the quick response, but no dice. Further experiments tell me that the minute I set the XF86Config file to more than 3 buttons, the remote session no longer recognizes Button3 properly...it seems to doubleclick it every time (if I look close I can see the pointer change to the other direction and then back right away) -- unfortunately, this happens with both the Microsoft mice I have tried and now this morning even my trusty old Logitech <sigh>. Same thing happens the second I add ZAxisMapping...is there a patch missing or something, this is getting really frustrating.

Last edited by jbaribeault; 09-09-2003 at 08:18 AM.
 
Old 09-12-2003, 07:52 AM   #4
nhs
Member
 
Registered: Aug 2003
Location: Edinburgh, Scotland
Distribution: Gentoo
Posts: 246

Rep: Reputation: 30
I have never seen this problem before however try changing the Protocol option in the XF86Config file to Mouse as the protocols may only differ when handling three or more buttons. If this doesn't work then I am at a loss.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Microsoft Intellimouse Rayston Slackware 7 11-15-2005 11:27 AM
Microsoft intellimouse? JeffSquared Linux - Hardware 1 09-17-2004 09:49 PM
Microsoft Intellimouse 1.2A PS/2 Compa dmedici *BSD 2 05-06-2004 08:59 PM
Wireless Intellimouse woes bax Linux - Hardware 5 01-14-2004 12:23 AM
Microsoft Intellimouse Hmmz0rz Linux - Hardware 3 06-21-2003 09:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration