-   Linux - Hardware (
-   -   Michrophone not working on Hercules Fortissimo II (

Ashrack 08-07-2006 05:00 PM

Microphone not working
I've Hercules Fortissimo II record sound from my MIC. Microphone works as when I choose microphone as the recording source from alsamixer I can hear sound thru the loudspeakers. Problem is that I can't record this sound. Gnome-sound-recorder just hangs on recording or produces a file of 4 bytes. Arecord also hangs and produces the same kind of 4b file even when going to INIT 1. Needless to say nor SKYPE or WENGO works.

So then I installed the SOX package and tried to record with 'REC' which comes with the package and with it it works. It clearly records everything I say into the MIC.

So afterwards I compiled latest ALSA-utils-libs-drivers 1.0.12, thinking there must be a problem with ALSA since it works with SOX but it still doesnt work.

In alsamixer I've set the following 3 channels to "capture": MIC, CAPTURE, and ADC and of course I had to unmute and set levels. As per this guide:

lspci -v:

0000:01:0a.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24 [CrystalClear SoundFusion Audio Accelerator] (rev 01)
      Subsystem: Hercules: Unknown device a010
      Flags: bus master, slow devsel, latency 32, IRQ 201
      Memory at e6100000 (32-bit, non-prefetchable) [size=4K]
      Memory at e6000000 (32-bit, non-prefetchable) [size=1M]
      Capabilities: [40] Power Management version 2

ps. I've tried this GUIDE:
but after it just gives me this error when lunching arecord:

ALSA lib pcm_dmix.c:762:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
arecord: main:544: audio open error: Invalid argument

Using UbuntuDapper

Ashrack 08-18-2006 12:19 PM


All times are GMT -5. The time now is 11:27 PM.