-   Linux - Hardware (
-   -   mesa problem, screwed up hardware acceleration? ( 05-05-2003 07:46 PM

mesa problem, screwed up hardware acceleration?

I`m having quite a stupid problem.
I tried to get OpenGL working, and installed a new version of Mesa
(5.01 i think it is) on my Slackware 9.0 (kernel 2.4.20).

But it still was not working, until I realized that I just need to uncomment
"glx" and "dri" in my XF86Config.

So far so good, now opengl is working, but when I run glxgears I only get:
1195 frames in 5.0 seconds = 239.000 FPS
( I have an IBM Thinkpad T30, which is 1,8 GHZ processor with 256 RAM)

This is a little low value I think for my system... really low :(

Well, I was searching on the homepage, and found this in the FAQ:

1.4 How do I upgrade my DRI installation to use a new Mesa release?

You don't! A copy of the Mesa source code lives inside the XFree86/DRI source tree and gets compiled into the individual DRI driver modules. If you try to install Mesa over an XFree86/DRI installation, you'll lose hardware rendering (because stand-alone Mesa's is different than the XFree86

Does this mean that I now lost all my hardware rendering ability because I installed the mesa package again?

Help, I`m screwed! :(

neenee 05-06-2003 01:44 AM

if you have an nvidia graphics card, go here to get
a nice installer for the latest nvidia drivers, which will
give you proper 3D acceleration. instructions are there too.

as for other gfx cards; i hope someone else can help you,
since i only know how to get nvidia cards working.

good luck. 05-06-2003 05:47 AM

Sorry I have forgotten to mention my graphics card,
it is an onboard ATI Mobility Radeon 7500.

Mithrandir 05-29-2003 08:18 PM

I am having a similar problem with the same card. I noticed that when i startx as a user, i get this error repeated over and over.

libGL error: failed to open DRM: Operation not permitted
libGL error: reverting to (slow) indirect rendering

Whenever i try to run OpenGL software, it either fails, or runs really slowly.

If i startx as root, i get no errors, and all the opengl stuff works perfectly.

I am using Slackware 9.0, and i guess it must be a permission problem or something similar... Does anyone have any ideas where to start???

e1v!$ 07-14-2003 05:45 PM

Similar problem
I've a desktop system with an ATI 9700 Pro Running RH 9.0. I used the default drivers, but man... all the OGL stuff I run is really friggin' slow. Just last week I was playing UT2003 at 30-50 fps with all the eye candy on(@1600x1200). Now my system can't even run a screen saver faster than .5 fps @ 12080x1024.

Anyone know what RH left out that's bogging my hardware? How can I fix it?

Tyfoune 08-26-2003 06:38 AM

Ati and OpenGL configuration
You can't use Mesa 5.0 with "DRI" rendering.
DRI uses only from XFree86.
I have the trouble with RedHat 7.3, Mesa 5 and an "Ati Rage 128" video card.
I have to re-install Mesa from Xfree86.

May be, someone can tell us, when Mesa 5 (and more) will be compatible with XFree86 ?

leonscape 08-26-2003 06:49 AM

Unfortunatley IBM isn't supporting the GFX Card on Linux.

So your stuck with mesa.

All times are GMT -5. The time now is 03:22 AM.