LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Memtest86+ v4.20 fails consistently on two Zoostorm AMD A6 3670K quad core processors (http://www.linuxquestions.org/questions/showthread.php?t=4175434680)

PAix 10-29-2012 07:38 PM

Memtest86+ v4.20 fails consistently on two Zoostorm AMD A6 3670K quad core processors
 
http://www.ebuyer.com/389624-zoostor...p-pc-7873-1067

I have recently had two quad cored AMD A6 boxes with AMD A55 chipset and AMD Radeon HD6530D integrated graphics on a Gigabyte motherboard fail Memtest86+ v4.20 memory testing.


8Gbyte of DDR3 memory comprising two sticks and in both systems the memory was reported failing at a wall time of approx 21min 24sec and pass 43%, test 0%, test #7 [random number sequence].


The memory sticks were swapped over with the same result. One stick was removed and the remaining one tested in both slots with the same result and the second stick of memory behaved in the same manner, The wall time at first failure with single sticks was in the order of 9min 52sec, but the identical test failures occurred. The memory address of first failures was not noted except in one case where it was 135.0Mbyre.


The source of Memtest86+ v4.20 was variously SUSE 12.2 64 bit, SUSE 12.1 64 bit and SUSE 12.2 32 BIT iso direct downloads from OpenSUSE.org to DVD. Each failed in the same manner and a firmware test on the same distro disk gave several MTRR errors which I didn't record. The distros appeared not to get to the first base when selecting the install option. There being no live CD option.


Interestingly a download of Fedora 17 appeared to work and the Memtest86+ facility on that disk ran successfully overnight and the Live CD appeared to be function happily as far as I was able to check it out.


A standalone copy of Memtest86+ iso downloaded and cut to CD ran fine on a the AMD Sempron system where it was downloaded and cut to CD, but appeared not to want to boot successfully on the target AMD A6 system.


Does anyone have any clues as to why Memtest86+ is behaving in this manner and why they are not all borne equal when it comes to testing this system? Both systems were rejected as faulty back to the vendor, who was happy to confirm that the first one was indeed faulty. I am awaiting their received wisdom on the second one. I am very aware that the system is not unduly expensive and the vendor has stood the carriage bill for two systems in two directions already.

thorkelljarl 10-29-2012 08:13 PM

?...

Was the downloaded ISO of Memtest86+ the latest version, 4.20?

PAix 10-29-2012 09:35 PM

Yes, each copy run was v4.20 from opensuse, fedora and memtest86+

The stand alone copy reported that it was loading the OS and just came back to that, retrying every ten seconds or so. Yet the disk had booted fine on this box. It wasn't something that I had expected.

I was wondering if there were any known issues that would make one or other of the memtest86+ images work differently, perhaps default options that Fedora might use that I would not be aware of?

Unfortunately a bare box with no OS doesn't necessarily infer that it's going to run Linux. I spoke with a tech at Zoostorm who had a little Ubuntu hands on, but he is unique in the team and I might be on a hiding to nothing.

H_TeXMeX_H 10-30-2012 02:58 AM

Try using GIMPS (not GIMP):
http://www.mersenne.org/freesoft/#source

Use mode #1 (small FFTs) and see if you can exclude a bad CPU.

PAix 10-30-2012 08:17 AM

Thanks H_TeXMeX_H, I appreciate your reply. I don't have the system anymore. It was returned to the vendor as a defective item. The second such, which is why I am attempting to understand why Memtest86+ v4.20 on one family of distros doesn't behave exactly the same as the same program/version on another.

With an installed system I appreciate that GIMPS would be a good option to run, but alas I didn't get that far.

I'm looking for explained Memtest86+ v4.20 or AMD A6 anomalies that might give me some insight into what might be going on.

Identifying a Zoostorm AMD A6 3670K user running SUSE 12.2 Linux would be real bonus. At least then I would be aware that I wasn't trying to beat the odds that might otherwise be stacked against me.

It seems that since my last install with a single core AMD Sempron based system, the stakes have been raised with multi-core CPUs over the intervening years of course.

PAix 10-30-2012 11:41 AM

"Following extensive tests by our Returns staff, this item was found to be faulty".

That's a Zoostorm Desktop PC AMD A6 3670K quad core 2.73GHz with integrated AMD Radeon HD6530D graphics, Sans OS. So outwardly an excellent machine to buy to install Linux upon.

This was the second of two systems that I returned with the same fault and were both declared faulty under warranty after a returns inspection.

Alas, I am unlikely to know how much luckier I might be with a third system of the same type or to understand how both these machines managed to duck under the Zoostorm post build/pre-dispatch testing regime.

Thank you all for your kind assistance.

H_TeXMeX_H 10-30-2012 12:35 PM

Did they say if the RAM was at fault ?

business_kid 10-31-2012 01:14 PM

I had something like this when a nominally equal ram stick couldn't be transferred to a nominally equal box with a different chipset.

I would increase wait states in the ram, and see if it affects anything. Try the ram in another box, and beware of static damage - I've lost ram that way before. Lastly, lower bus speeds.

The fact that Fedora works would point to a kernel problem. Fedora significantly patch the kernel source (Over a Meg's worth of patches typically) - I'm not aware of them patching memtest86 (Which doesn't mean they don't!)

jefro 10-31-2012 10:09 PM

Memtest is not fool proof. One can try different versions and get different results. Even Window's vista and 7 have a memory test that can be used. I think ultimate boot cd or a system rescue cd has both or three versions to try.

PAix 11-13-2012 05:55 PM

No, the report was quite vanilla, just faulty under warranty and the whole issue drops into a commercial black hole. It doesn't inspire confidence and I'm having a think before I take another stab at replacing my aging platform.

Thanks for all your help guys, it has been appreciated.

bayard1music 03-03-2013 08:34 AM

Hello,

Sort of curious. I've got the same Zoostorm AMD A6 3670K system I think , with 8Gbytes of RAM. But I'm having issues with spurious lines on the video output. I've also had this system replaced twice . So wonder what prompted the memtest86 tests in the fist instance? I'm actually running Windows 7/64 today which ought to be fairly standard. Thanks in advance.


Alan


All times are GMT -5. The time now is 05:29 PM.