-   Linux - Hardware (
-   -   memtest issues, again (

cellist 03-02-2005 08:05 PM

memtest issues, again
Just a quick question: using an Intel D865PERL and dual-channel RAM, why would Memtest86+ 1.51 freeze on test 3? It goes through the first two tests at light speed, then test three just hangs at 0%.


My system runs fine otherwise, except my PCI wifi card stopped working when I installed a second NIC in another PCI slot. It says the primary firmware for the wifi card is missing!? When I remove the secondary NIC the wifi card still doesn't work when it worked fine before the other NIC came in the picture. Are these problems related? Should I replace the motherboard again?

FYI: I'm running memtest because Blackdown JDK keeps giving me segmentation faults when I try to run java applets or when I try to compile anything java.

Any help would be greatly appreciated!

nonzero 03-03-2005 01:17 PM

You have at least two problems that I can see.

The first is an apparent conflict between plug and pray devices. If the WiFi card is not
recognized and initialized when installed by itself, the firmware got dorked by the previous configuration and I would start googling to find out how to reflash the card firmware.

Second, not knowing what programs you run or how you use this machine, why would you change out a motherboard (again?) when it may be just as simple as moving cards to different slots or reloading or (removing/reloading - blackdown jdk for Sun's jdk). If you've compiled any software on this machine without error I would not suspect anything more than a hardware config problem.

I've fixed machines (Macs included) that had everthing from memory errors to hard beep faults by moving pci cards (or removing them altogether). Even today in the year 2005, mobo and bios builders can't get this right. Start with a bare board, with video, insert your network card. reboot, insert the next one, reboot, etc.etc. You should be able to locate the problem shortly.


cellist 03-04-2005 12:10 AM

So do you think my memtest problems are a result of some conflict, or should I not even worry about it? The reason I've had to change motherboards is because I had 6 memory sticks go bad (as diagnosed by memtest, and due to kernel compilations and other compilations crashing). As for my wifi card, the only method I know of to reflash the card (using linux) doesn't work because the flashing program returns the following:

ioctl[PRISM2_IOCTL_HOSTAPD]: Inappropriate ioctl for device
Missing wlan component info
Could not read wlan RIDs

Perhaps there is another way to flash this prism2 card?

Darin 03-04-2005 05:50 AM

Flash it in a state that nonzero suggested, ie no add-in cards except video and the WiFi card.

cellist 03-04-2005 08:36 AM

I'll try that. Thanks. Will keep you posted.

nonzero 03-04-2005 07:40 PM

Well, the reason I asked if you could cleanly compile anything is that it is a good indication that your memory subsystem is in working order. But I still would not rule out a card conflict. As far as the flash not taking, are you flashing from a DOS boot disk or trying to do it from Linux? Traditionally these flash programs run in DOS and should be loaded from a straight DOS boot.


cellist 03-05-2005 01:05 AM

I feel like most things compile cleanly, except Xorg compilation crashed once, and Blackdown JDK gives me segmentation faults every time. I wonder if there's some incompatibility though because I'm using an older version of it on my laptop and it works fine, but the newerversion on the same laptop (the same version that I'm trying to run on the desktop) also gives seg. faults. I suppose this is a good sign for the memory, though it troubles me that memtest is crashing consistently in the same place.

As for flashing the card, I was doing it through linux. I suppose I'll have to research how to flash the card in dos mode with a dos bootable disk. Will keep you posted. Thanks for all the feedback!

nonzero 03-05-2005 09:23 AM

Although I've built programs from source, I've not attempted X because the distributions I use have always provided (mostly) troublefree binaries. Ignoring X compilation and memtest issues for a while, does the machine have relative stability while running X? I have had numerous problems with lockups, segfaults, and crashes on various versions of KDE, certain multimedia programs, and such. This was not due to any fault of the hardware. It was beta software. Unless you are building apps from stable branches of the source tree, all bets are off as far as stability. I've not had any issues with the Blackdown JDK's though I moved back to the SUN JDK's on my systems for their ease of setup with Ant, junit, etc., and the latest Netbeans IDE is working well for me.
Providing bug reports to the development team helps the situation in the next release.
The link above should provide you with a DOS bootdisk capable of running your flash program.


cellist 03-05-2005 10:26 AM

Thanks so much, nonzero, for all your help. I'll see where this takes me.

AFAIK, the software I'm using is all from the stable portage tree, with one or two packages from the "~x86" tree. A few things here and there don't work but I'm used to that. Overall I'm pretty happy with the stability of the system so far. Just Blackdown JDK is an issue, and the problem with that is that since it is a dependency for quite a few things, there are several programs (pilot-link for instance) that simply won't compile because the java compiler keeps crashing.

cellist 04-11-2005 10:58 PM

I've researched how to flash new firmware into my card, and everything seems to point to using flash.exe (which comes from we110.exe which was extremely hard to find!). People have also said I should run legacy.exe (from the same package). I made a boot disk that has both apps, plus the firmware files. I booted into DOS and ran flash.exe. As long as flash.ini was in the floppy it would find my card, but downloading the firmware always gives me an error (code 1). I've tried running flash.exe -legacy etc, but this command won't find my card because it is a PCI card running in PCMCIA emulation mode.

I also read somewhere that I should try to use an older version of flash.exe because 0.5f has issues. Well, flash.exe 0.3b won't find my card because it doesn't read the flash.ini file like the other one does. Legacy.exe gives me the quaint message "There are no controller!", so apparently this won't work for me either, probably because it's a PCI card masquerading as a PC card. So I'm stuck right now.

What do I do now? Thanks.

All times are GMT -5. The time now is 03:11 PM.