LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Memory and Graphical Consoles / Installers (https://www.linuxquestions.org/questions/linux-hardware-18/memory-and-graphical-consoles-installers-40333/)

Freaksta 01-04-2003 11:23 PM

Memory and Graphical Consoles / Installers
 
Alright, Get your thinking caps on! This might be a hard one....


I have recently purchased and additional 512 megs of DDR (making a total of 1 gig, both chips are Samsung, but one chip is plain and the other has [transcend] on it)


The problem has become that when both sticks of ram are installed and I attempt to run either a hi-res console (like slackware, with a linux logo in it(in the console) or use a graphical installer such as provided by mandrake and redhat, i get a blank screen... the screen is lit.. like it's on.. it does not cycle off, it just goes blank, and sometimes my keyboard capslock and scroll lock keys flash, but sometimes not. In either case, If i use just one 512 chip, it loads fine, shows all the pretty pictures, etc... but with both it does not work. I have tried switching the order of chips on the MB, but no change..


do you think this is a memory addressing error, like the ram is not sync'd? X11 runs fine. the only problem is when i use a graphical console (like a console at 800x600 (or like graphical installers use))

Please help!! Thanks alot!

Matthew

Freaksta 01-04-2003 11:27 PM

A little more info
 
I was searching the archive and came across this:

http://www.linuxquestions.org/questi...=hires+console

but it does not explain why it works with 512 megs / 1stick and not 1 gig / 2 sticks....


thanks again.. :)

Aussie 01-04-2003 11:46 PM

If I was going to SWAG the problem I'd say incompatable ram modules, just because each stick has the same chips dosn't always mean they will play nice together.

Mephisto 01-04-2003 11:58 PM

Is it making it past POST? Also what MB/chipset do you have.

Freaksta 01-05-2003 10:17 AM

MotherBoard is IWill XP333 and it posts great.. shows all my ram.. lilo loads fine with VGA=normal (plain console) and linux registers all my ram (exept slackware, where i have to recompile with hi mem support) but even that works afterwards.

Chipset
ALi® ALiMAGiK 1 chipset (C version)
• ALi® M1647 Northbridge
• ALi® M1535D+ Southbridge

(http://www.iwillusa.com/products/Pro...p?vID=8&CID=93)


Thanks :)

Freaksta 01-05-2003 10:46 AM

Also, i have a Xtasy G4 Ti 4200 128MB video card..

here are some links.. most refer to distro-specific stuff because they are distro boards, but i am looking at the problem in general.. it seems to be common, but not so well documented officially hope you don't mind the links.. just think the more info i can provide the better :)

1. http://lists.suse.com/archive/suse-l...-Nov/0120.html
2. http://mandrakeforum.com/article.php?sid=2011&lang=en (seems more about lilo)

The problem That i see is that everything works fine with one stick of ram.. I really hope i don't have to stck with txt.. the problem is that then i have to use txt only installers.. boring! ;) i'm going to go through every single fb mode, and i'll get back to you when i'm done.. if there is any change i'll let you know :)

Freaksta 01-05-2003 12:08 PM

Wow.. that was not fun.. I used a spare drive and installed linux, and tried every framebuffer setting available. vga=ask works fine, and i can do diff screen sizes / fonts er whatever it does.. but as soon as i use framebuffer, the screen goes blank... it seems to me it must be a ram problem.. but how can i buy a stick of ram and know it's going to be the exact same as the one i already have? i guess i should have bought from the same place both times? *sigh* very frustrating

:(

Mephisto 01-05-2003 01:13 PM

You are posting fine, and the memory is recognized by the BIOS. So at least at the hardware level everything seems kosher. If you dual boot then I would say run the memory through one of the various "burn in" programs but I doubt that is the problem. The memory might be the problem but that is an expensive thing to have faith on, buy it from a local store with a good return policy.

This may (probably is) a stupid question but is your problem only during installs? That is what your initial message sounds like, but if that is the problem why not just do the install with one stick and put the other in afterwords.

If the problem is with the hires console, not X, then why not just use a VGA console? Not as pretty I admit but it would be more pleasant than beating your head against a proverbial wall. It sounds like an issue with FB and large memory addressing but I don't have a spare machine that has 1GB of RAM that I can test this theory on. I hate leaving problems unsolved but you are running a conventional system on a (I believe) supported chipset with a not unreasonably large amount of RAM. Let us know if oyu find anything else out, your searches produced more than mine.

Freaksta 01-05-2003 01:37 PM

The problem is with anything that uses FB for example, graphical installs, and the hires console.


Any information on who codes FB? Is there possible a mailing list or a webboard specifially for FB that might help alot..


I guess i'll just have to use standard console.. no problem there, it was just that i don't like having problems :)


I must say that i am very impressed with the help and support i have recived from this board.. i'm sure if i ever have problems i will return here first, and definatly give WOM advertising :)

Thanks again!

Electro 01-05-2003 04:40 PM

You may want to add a line in LILO that tells it you have 1 gigabyte of memory.

Try swapping out the old memory module and use the new memory module.

You may need to decrease the front side bus to 133 MHz or even 100 MHz. ALi is not good at handling high FSB for multiple modules. Also reduce the aggressive times such as CAS. Set CAS to 3.

Freaksta 01-05-2003 07:22 PM

Wow.. that's a little rough .. it's nice to have a few ideas, but i'm not sure i want to take it that far.... although... it would be nice for testing, just to see what the problem really is... i guess i'll try it....


i know both of the modules work in any one of the 3 slots alone, but in any combo together FB does not work.

Freaksta 01-05-2003 07:22 PM

Also how do i add that line to lilo?

Mephisto 01-05-2003 08:43 PM

I try and avoid answering questions like this because I would feel guilty if someone screwed up thier LILO but the command is mem=<memory size>

This site gives an example of how to do it, or do a google for "mem lilo linux" sans quotes.


All times are GMT -5. The time now is 06:48 AM.