LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 01-26-2004, 09:57 PM   #1
dcoder
LQ Newbie
 
Registered: Aug 2003
Location: Valemount BC
Distribution: Mandrake 9.1 (desktop) Debian (server)
Posts: 10

Rep: Reputation: 0
Angry mdk9.2 - nvidia video (GeForce4) X will not start


Hi all,
I am almost there with loading nvidia drivers for my GeForce4 but I need a little bit of help. Here is what I have done and my problem.

ran NVIDIA-Linux-x86-1.0-5328-pkg1.run
installed ok but X did not work. Read instructions and they said
"Please note that the convention for the location of kernel header files changed approximately at the time of the 2.4.0 kernel release, as did the location of kernel modules. If the kernel module fails to load properly, modprobe/insmod may be trying to load an older kernel module (assuming you have upgraded). cd'ing into the directory with the new kernel module and doing 'insmod ./nvidia.o' may help."
and so I ran that and low and behold it worked but everytime I reboot I had to reaload the nvidia module so search mandrakeclub for solution and found a message that said to put the line /sbin/modprobe nvidia into rc.local
Did not work so check boot.log to see if it loaded and
" 24 09:55:06 localhost : Loading module: nvidia.o"
so it looks like it loaded but if I run lsmod and look for it I do not see it.

so my question is how do I get this module loaded so I do not have to do it by hand everytime I boot?

I have tried to configure modules.conf but I have not had success at that. My modules.conf looks like:
"above snd-cmipci snd-pcm-oss
alias sound-slot-0 snd-cmipci
probeall usb-interface usb-uhci ehci-hcd
probeall scsi_hostadapter aic7xxx ide-scsi
alias eth0 3c59x
alias /dev/nvidia* nvidia "
and I have added the line
sbin/insmod /boot/nvidia.o (where I copied the module)
but this did not help anything.





Thanks very much for any help in advance.
 
Old 01-28-2004, 01:13 AM   #2
faheyd
Member
 
Registered: Jun 2003
Location: Northern California (NorCal)
Distribution: Ubuntu 7.04 and DSL/Puppy etc
Posts: 342

Rep: Reputation: 30
If it were me, and I'm lazy, I would put the 'insmod ./nvidia.o' (with proper directory listings) into rc.local instead of "line /sbin/modprobe nvidia into rc.local" and see if that works. Just check your 'dmesg' or /var/log/messages to see if it loaded.
 
Old 02-01-2004, 08:04 PM   #3
dcoder
LQ Newbie
 
Registered: Aug 2003
Location: Valemount BC
Distribution: Mandrake 9.1 (desktop) Debian (server)
Posts: 10

Original Poster
Rep: Reputation: 0
Finally, I have been able to get back to this problem. I tried that but when I boot the screen flashes three times and then it goes to command line mode. My XFree86 log looks like this
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

So, I am thinking, that the rc.local is run after X tries to start.
 
Old 02-01-2004, 09:42 PM   #4
dcoder
LQ Newbie
 
Registered: Aug 2003
Location: Valemount BC
Distribution: Mandrake 9.1 (desktop) Debian (server)
Posts: 10

Original Poster
Rep: Reputation: 0
I also have looked at the messages file and as I read it, it states:

Feb 1 16:59:14 localhost rc.sysinit: Remounting root filesystem in read-write mode: succeeded
Feb 1 16:59:14 localhost rc.sysinit: Activating swap partitions: succeeded
Feb 1 16:59:17 localhost rc.sysinit: Finding module dependencies: succeeded
Feb 1 16:59:18 localhost : Loading module: scsi_hostadapter
Feb 1 16:59:19 localhost : Loading module: nvidia.o
Feb 1 16:59:20 localhost fsck: /dev/hda6: clean, 46198/9175040 files, 2946511/18348230 blocks

and then several lines later

Feb 1 17:00:00 localhost kdm[1970]: IO Error in XOpenDisplay
Feb 1 17:00:00 localhost kdm[1748]: Display :0 cannot be opened
Feb 1 17:00:00 localhost kdm[1748]: Display :0 is being disabled (restarting too fast)

so I am not sure what is going on yet ...
 
Old 02-02-2004, 12:02 AM   #5
faheyd
Member
 
Registered: Jun 2003
Location: Northern California (NorCal)
Distribution: Ubuntu 7.04 and DSL/Puppy etc
Posts: 342

Rep: Reputation: 30
After pondering this, and not wanting to reinvent the wheel...

Uninstall that version you have now, Goto http://www.nvidia.com/object/linux_d..._1.0-4496.html
download that and and install it per the instructions contained within. It's not always 'good' to have the latest and greatest. There is also nothing wrong with .4496 and my quake3 does not freeze with that version. Go forth and install, please come back with your results.
 
Old 02-08-2004, 02:10 PM   #6
dcoder
LQ Newbie
 
Registered: Aug 2003
Location: Valemount BC
Distribution: Mandrake 9.1 (desktop) Debian (server)
Posts: 10

Original Poster
Rep: Reputation: 0
I tried this and no joy. I am keeping an eye out on the forum for anyone else who might have a similar problem. If no one does then it is something I messed up, but I thing there might be others who are having this problem and then it would be nvidia or mandrake. Thanks for the suggestions I will keep trying.
 
Old 02-08-2004, 02:28 PM   #7
faheyd
Member
 
Registered: Jun 2003
Location: Northern California (NorCal)
Distribution: Ubuntu 7.04 and DSL/Puppy etc
Posts: 342

Rep: Reputation: 30
Hi,
Take a look at this post http://www.nvnews.net/vbulletin/show...+kernel+module in another forum, and read it all very closely. The drive is picky picky picky. It gives some clues about 'how' to check your kernel and other things. I'm sure you are close to getting it to work.
 
Old 02-12-2004, 09:02 PM   #8
Richard Rasker
LQ Newbie
 
Registered: Feb 2004
Posts: 7

Rep: Reputation: 0
Simply adding the line "nvidia" to /etc/modules did the trick for me. The reason why adding the modprobe command to rc.local doesn't work, is probably because the X-server is started before rc.local is processed.

Regards,

Richard
 
Old 02-13-2004, 10:17 PM   #9
lachlan
Member
 
Registered: Jan 2002
Location: New Zealand
Distribution: Mandrake 9.1,Suse 8.2
Posts: 139

Rep: Reputation: 15
When I installed my nvidia driver (as per instructions from Nvidia),the only line I changed was "nv' to "NVIDIA" in the device section in /etc/X11/XF86Config-4.It might be also be a good idea if you change into run level 3 in /etc/inittab and run startx.

Lachlan
 
Old 02-14-2004, 11:30 AM   #10
dcoder
LQ Newbie
 
Registered: Aug 2003
Location: Valemount BC
Distribution: Mandrake 9.1 (desktop) Debian (server)
Posts: 10

Original Poster
Rep: Reputation: 0
hmmmm.....D@m - what can I say. I tried that and it did not work. Although that was an uninstall....reinstall older......uninstall......reinstall newer but now it works :-) . Wish I could understand why but sometimes I guess stuff happens. Well thanks all for your help now on to the next challenge...... a script that reads a text file that contains user names, default passwords, group association and then creates accounts (samba as well).
 
Old 02-14-2004, 09:45 PM   #11
repeater75
Member
 
Registered: Jan 2004
Location: Laguna Niguel, CA
Distribution: Mandrake 10 Official
Posts: 52

Rep: Reputation: 15
I may be firing in the dark here, but I had a sort of similar problem with this recently under Mandrake 9.2 and had to use the exact same fix when I upgraded to Mandrake 10 beta 2.

I had to go to /etc/rc.d/ and edit rc.modules to include the line /sbin/modprobe nvidia
once I added that to my rc.modules, it would load up the driver correctly every time. Strangely enough I had to do this same procedure with the newer MAndrake. Also, I only had to change the "nv" to "nvidia" in my XF86Config-4 file as it was already set to use glx with the default install setup for Mandrake. BTW, I am using a Geforce 3.

Again, not sure if this is the exact problem you are having but another forum guy here named Phorem posted that fix and it worked for me!

GOOD LUCK! And get Enemy Territory once you get that baby running!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia geforce4 mx 64mb video ram and agp vertex data .... lowpingnoob Linux - Newbie 2 06-16-2005 10:21 PM
lspci -v showing wrong memory size for video card (NVIDIA Geforce4 Ti4200 8X) [NL]_Target Linux - Hardware 0 06-27-2004 11:17 AM
choppy video nvidia geforce4 frog-newbie Linux - Hardware 7 09-06-2003 02:06 AM
Nvidia Geforce4 Error kai_rana Red Hat 1 09-02-2003 10:10 AM
NVIDIA GeForce4 MX installation Hachaso Linux - Hardware 5 03-21-2003 04:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration