-   Linux - Hardware (
-   -   Maxtor One Touch 4 USB 500GB External HDD Not showing up in Linux Mint Elyssa (

nonexist 12-22-2008 07:04 PM

Maxtor One Touch 4 USB 500GB External HDD Not showing up in Linux Mint Elyssa
Just as the title says.
I got the drive earlier today and it was reformatted from NTFS to exFAT(?or something) and I opened it in Windows Vista which is on the first partition of my hard drive.
I rebooted into Linux and have tried many things. Unplugging, replugging, "sdparm /dev/sda --set SCT=12000 --save"(Found Online, not really sure what it does??).

Any help is always good. This is being run on an HP DV6915nr Pavilion Laptop with a 200gb internal HDD.


David the H. 12-23-2008 02:16 AM

If your drive is exFAT then that's your problem right there. exFAT is a new MS proprietary file system with unclear IP rights, and therefore open source vendors can't legally supply support for it. Not to mention that it takes time to develop and test a new file system driver. I don't think I'd trust any FOSS implementation of it even if it existed at this point.

There may be some kind of unofficial driver available somewhere, but I looked around a bit and couldn't find anything definite. I don't doubt there are people working on it though. But for now your best bet is to simply reformat the drive with a file system that is well supported. You can use NTFS if you plan on using it with both Windows and Linux, because you can use the ntfs-3g driver to access it from Linux. Optionally you could format it to et3, and get one of the 3rd party Windows ext2/3 drivers that exist to access it from Windows.

BTW, just for the record, who did the formatting to exFAT? Was the drive sold this way or did someone reformat it after the fact? It might be helpful for others to know if they have to be careful about this drive.

nonexist 12-23-2008 08:34 AM

Well to tell you the truth, I was the one that reformatted it to that.
I have vista and when I was reformatting, there was NTFS or exFAT, so I was guessing that was suppose to be ext3.

Didn't know NTFS worked but I will go with reformatting it to that and see how it goes after that.

farslayer 12-23-2008 08:46 AM

I have a couple of those drives they come formatted as NTFS by default.

I repartitioned mine as Fat32 and EXT3 and it works flawlessly under Linux using either the USB or Firewire Connection.
(one of The Maxtor One Touch 4 Plus drives is USB only the Other is USB/Firewire)

David the H. 12-23-2008 09:11 AM

Fat32 certainly is an option, but the 4GB limitation in file size and the fact that it gets easily corrupted and fragmented makes it a less desirable choice for such a large drive. NTFS is generally a better solution here, although it has its problems too. FAT is much more useful on smaller usb sticks and such, because it has less overhead and almost universal support.

But in any case neither one is really ideal for Linux, because they don't support *nix style permissions and ownership.

So if you want interoperability you're going to have to make some trade-offs no matter what your choice.

farslayer 12-23-2008 09:24 AM

Yeah my Fat32 Partition is a 'just in case' partition I set aside so if I am somewhere else and want to use the drive on a windows box of any age... all home use is the much larger EXT3 portion of my drive..

nonexist 12-24-2008 07:58 AM

Well easiest case scenario, I could have just reformatted it as NTFS. Turns out when I got it there were errors popping up left and right about not being able to mount it, but a simple reformatting of the drive seemed to fix it.

Hooray for 500GB of open source Linux Glory.
Though if I have another 4 hours to format, EXT3 might be the way to go.
~David the H

All times are GMT -5. The time now is 07:41 PM.