LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Mandrake 9.2: Installed Alsa, now no sound. Infamous NVidia Nforce2. (https://www.linuxquestions.org/questions/linux-hardware-18/mandrake-9-2-installed-alsa-now-no-sound-infamous-nvidia-nforce2-158513/)

dangerboy 03-16-2004 01:50 PM

Mandrake 9.2: Installed Alsa, now no sound. Infamous nVidia nForce1.
 
All right. In trying to solve one problem, it seems I've gone back to square one.

I'm running Mandrake 9.2 with KDE 3.1(the 9.2 release version), I am running the 2.4.22-10mdkenterprise kernel. This installation is about 4 months old. After installation, I had sound as Mandrake automatically updated to this kernel because of my chipset, the infamous and notorious NVidia Nforce2 chipset. I was able to do many things, except set default startup volume. Myself being the purist that I am found this unacceptable. I read in many places that I should install ALSA so that I have full functionality. I figured what the heck.

I followed the procedure exactly as listed at:
http://www.alsa-project.org/alsa-doc...intel8x0#intro

I adjusted the volumes as recommended through AlsaMixer. When I went to save with AlsaCtrl, I found that it is missing. After an extensive search, I have come to the conclusion that it is not installed on my computer. I installed Aumix to see if it would let me adjust volumes, but everytime I try to move the main "PCM" volume slider from 0 to 100, it moves, by itself, back to 0. KMix is of no help, although I now have more channels than I did previously. I just now have no sound what-so-ever.

dmesg outputs this:
Linux version 2.4.22-10mdkenterprise (nplanel@no.mandrakesoft.com) (gcc version 3.3.1 (Mandrake Linux 9.2 3.3.1-2mdk)) #1 SMP Thu Sep 18 11:46:49 CEST 2003
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000003dff0000 (usable)
BIOS-e820: 000000003dff0000 - 000000003dff3000 (ACPI NVS)
BIOS-e820: 000000003dff3000 - 000000003e000000 (ACPI data)
BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
95MB HIGHMEM available.
896MB LOWMEM available.
ACPI: have wakeup address 0xc0002000
On node 0 totalpages: 253936
zone(0): 4096 pages.
zone(1): 225280 pages.
zone(2): 24560 pages.
ACPI: RSDP (v000 Nvidia ) @ 0x000f7470
ACPI: RSDT (v001 Nvidia AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x3dff3000
ACPI: FADT (v001 Nvidia AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x3dff3040
ACPI: DSDT (v001 NVIDIA AWRDACPI 0x00001000 MSFT 0x0100000c) @ 0x00000000
ACPI: MADT not present
Building zonelist for node : 0
Kernel command line: auto BOOT_IMAGE=linux-enterpris ro root=301 devfs=mount acpi=ht splash=silent
bootsplash: silent mode.
Found and enabled local APIC!
Initializing CPU#0
Detected 1152.611 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 2300.31 BogoMIPS
Memory: 897000k/1015744k available (1677k kernel code, 15892k reserved, -2322k data, 176k init, 98240k highmem, 0k BadRAM)
Dentry cache hash table entries: 131072 (order: 8, 1048576 bytes)
Inode cache hash table entries: 65536 (order: 7, 524288 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 65536 (order: 6, 262144 bytes)
Page-cache hash table entries: 262144 (order: 8, 1048576 bytes)
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: After generic, caps: 0383fbff c1cbfbff 00000000 00000000
CPU: Common caps: 0383fbff c1cbfbff 00000000 00000000
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
Intel machine check reporting enabled on CPU#0.
CPU: After generic, caps: 0383fbff c1cbfbff 00000000 00000000
CPU: Common caps: 0383fbff c1cbfbff 00000000 00000000
CPU0: AMD Athlon(tm) XP stepping 02
per-CPU timeslice cutoff: 731.42 usecs.
SMP motherboard not detected.
enabled ExtINT on CPU#0
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 1152.6321 MHz.
..... host bus clock speed is 200.4576 MHz.
cpu: 0, clocks: 2004576, slice: 1002288
CPU0<T0:2004576,T1:1002288,D:0,S:1002288,C:2004576>
Waiting on wait_init_idle (map = 0x0)
All processors have done init_idle
ACPI: Subsystem revision 20030813
ACPI: Interpreter disabled.
PCI: PCI BIOS revision 2.10 entry at 0xfb3e0, last bus=2
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: ACPI tables contain no PCI IRQ routing entries
PCI: Probing PCI hardware (bus 00)
PCI: Using IRQ router default [10de/01a4] at 00:00.0
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16)
Starting kswapd
allocated 32 pages and 32 bhs reserved for the highmem bounces
kinoded started
VFS: Disk quotas vdquot_6.5.1
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
pty: 1024 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI ISAPNP enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 32000K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
NFORCE: IDE controller at PCI slot 00:09.0
NFORCE: chipset revision 195
NFORCE: not 100% native mode: will probe irqs later
AMD_IDE: Bios didn't set cable bits corectly. Enabling workaround.
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
AMD_IDE: nVidia Corporation nForce IDE (rev c3) UDMA100 controller on pci00:09.0
ide0: BM-DMA at 0xe400-0xe407, BIOS settings: hda:DMA, hdb:pio
ide1: BM-DMA at 0xe408-0xe40f, BIOS settings: hdc:DMA, hdd:DMA
hda: IBM-DTLA-307020, ATA DISK drive
blk: queue c01a6360, I/O limit 4095Mb (mask 0xffffffff)
hdc: Lite-On LTN483S 48x Max, ATAPI CD/DVD-ROM drive
hdd: IDE DVD-ROM 16X, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 40188960 sectors (20577 MB) w/1916KiB Cache, CHS=2501/255/63, UDMA(100)
Partition check:
/dev/ide/host0/bus0/target0/lun0: p1 p2 < p5 p6 >
ide: late registration of driver.
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 8192 buckets, 64Kbytes
TCP: Hash tables configured (established 262144 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 304k freed
VFS: Mounted root (ext2 filesystem).
Mounted devfs on /dev
Journalled Block Device driver loaded
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Mounted devfs on /dev
Freeing unused kernel memory: 176k freed
Real Time Clock Driver v1.10e
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
PCI: Setting latency timer of device 00:02.0 to 64
usb-ohci.c: USB OHCI at membase 0xf8844000, IRQ 11
usb-ohci.c: usb-00:02.0, nVidia Corporation nForce USB Controller
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 3 ports detected
PCI: Setting latency timer of device 00:03.0 to 64
usb-ohci.c: USB OHCI at membase 0xf8846000, IRQ 11
usb-ohci.c: usb-00:03.0, nVidia Corporation nForce USB Controller (#2)
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 3 ports detected
usbdevfs: remount parameter error
usb.c: registered new driver usblp
printer.c: v0.11: USB Printer Device Class driver
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,1), internal journal
Adding Swap: 506008k swap-space (priority -1)
kjournald starting. Commit interval 5 seconds
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,6), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
3c59x: Donald Becker and others. www.scyld.com/network/vortex.html
See Documentation/networking/vortex.txt
01:01.0: 3Com PCI 3c905C Tornado at 0xc000. Vers LK1.1.18-ac
00:01:02:6e:51:6c, IRQ 11
product code 4552 rev 00.13 date 06-27-00
Internal config register is 1800000, transceivers 0xa.
8K byte-wide RAM 5:3 Rx:Tx split, autoselect/Autonegotiate interface.
MII transceiver found at address 24, status 782d.
Enabling bus-master transmits and whole-frame receives.
01:01.0: scatter/gather enabled. h/w checksums enabled
inserting floppy driver for 2.4.22-10mdkenterprise
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
hdc: attached ide-cdrom driver.
hdc: ATAPI 48X CD-ROM drive, 120kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
hdd: attached ide-cdrom driver.
hdd: ATAPI 48X DVD-ROM drive, 512kB Cache, UDMA(33)
i2c-core.o: i2c core module version 2.8.0 (20030714)
i2c-proc.o version 2.8.0 (20030714)
i2c-core.o: i2c core module version 2.8.0 (20030714)
i2c-isa.o version 2.8.0 (20030714)
i2c-proc.o version 2.8.0 (20030714)
lm80.o version 2.8.0 (20030714)
lm75.o version 2.8.0 (20030714)
eeprom.o version 2.8.0 (20030714)
w83781d.o version 2.8.0 (20030714)
IPVS: Connection hash table configured (size=4096, memory=32Kbytes)
IPVS: Each connection entry needs 120 bytes at least
IPVS: ipvs loaded.
Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
PCI: Setting latency timer of device 00:06.0 to 64
intel8x0_measure_ac97_clock: measured 49881 usecs
intel8x0: clocking to 47412
SCSI subsystem driver Revision: 1.00
parport0: PC-style at 0x378 [PCSPP,TRISTATE]
lp0: using parport0 (polling).
spurious 8259A interrupt: IRQ7.

this is lsmod's output:
Module Size Used by Not tainted
binfmt_misc 7820 1
parport_pc 27752 1 (autoclean)
lp 8864 0 (autoclean)
parport 39592 1 (autoclean) [parport_pc lp]
sg 38012 0 (autoclean) (unused)
st 33304 0 (autoclean) (unused)
sr_mod 20888 0 (autoclean) (unused)
sd_mod 14572 0 (autoclean) (unused)
scsi_mod 113344 4 (autoclean) [sg st sr_mod sd_mod]
snd-seq-oss 36480 0 (unused)
snd-seq-midi-event 6592 0 [snd-seq-oss]
snd-seq 51280 2 [snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 46564 0
snd-mixer-oss 16792 0 [snd-pcm-oss]
snd-intel8x0 25416 2
snd-ac97-codec 60284 0 [snd-intel8x0]
snd-pcm 92544 0 [snd-pcm-oss snd-intel8x0]
snd-timer 21764 0 [snd-seq snd-pcm]
gameport 3508 0 [snd-intel8x0]
snd-page-alloc 11060 0 [snd-intel8x0 snd-pcm]
snd-mpu401-uart 5696 0 [snd-intel8x0]
snd-rawmidi 20096 0 [snd-mpu401-uart]
snd-seq-device 6464 0 [snd-seq-oss snd-seq snd-rawmidi]
snd 51076 2 [snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-ac97-codec snd-pcm snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 7236 0 [snd]
nfsd 83280 8 (autoclean)
af_packet 16904 1 (autoclean)
ip_vs 79532 0 (autoclean)
w83781d 26164 0 (unused)
eeprom 4852 0 (unused)
lm75 4028 0 (unused)
lm80 6752 0 (unused)
i2c-proc 8692 0 [w83781d eeprom lm75 lm80]
i2c-isa 1332 0 (unused)
i2c-core 22052 0 [w83781d eeprom lm75 lm80 i2c-proc i2c-isa]
ide-floppy 17408 0 (autoclean)
ide-tape 54768 0 (autoclean)
ide-cd 36516 0 (autoclean)
cdrom 35360 0 (autoclean) [sr_mod ide-cd]
floppy 59548 0
3c59x 31536 1 (autoclean)
supermount 87328 3 (autoclean)
printer 9376 0 (unused)
usb-ohci 22568 0 (unused)
usbcore 83468 1 [printer usb-ohci]
rtc 10508 0 (autoclean)
ext3 68720 2
jbd 46696 2 [ext3]

I've read in several places that in order to have AlsaCtrl, I have to install Alsa Tools, but the tools package that is on their website does not appear to contain this.

My main questions are:
1. How do I get Alsa up and running from here?
2. Do I need to uninstall and reinstall alsa? If so, how is that done with a tar.bz2 package?
3. How can I get AlsaCtrl and Alsaconfig installed?
4. If I can't get it up and running properly, how do I go back to the setup I had previously, so that I at least have 90% satisfaction?

Any information you have on this would be greatly appreciated and I thank you in advance.

Alex

dangerboy 03-17-2004 01:54 PM

*Bump*

Anybody know Alsa? Somebody's gotta know somethin? Any clues?

Bueller? Bueller? Bueller?

dangerboy 03-18-2004 11:06 PM

If anyone knows someone who knows something, could you send them here?? Thanx.
*Like The Fly caught in the web* "Heeelp me. Heeeeelp me."

Alex

GoinEasy9 03-18-2004 11:17 PM

Hi Dangerboy

do not feel alone...i have the same problems....been working on it for weeks
downloaded the alsa driver from asus (from whence i got my motherboard)
followed instructions to the tee...still nothing..i joined ur thread to c if u get some answers...if i get one i'll get back to u....

Damn...everythings working on my linux box but sound...

did an lsmod...all the snd drivers are oss...it's like i never installed alsa..

i'm starting to think that the old drivers should have been deleted first

linux is a learning process...lol...i'm learning alot while trying to configure....

till next time
good luck
Tom

dangerboy 03-19-2004 01:14 AM

I actually have good news:
I know now that it is "alsactl" and NOT "alsactrl" and that I do, indeed, have it installed. I also plugged a mic into my mic port and I have sound so I know the driver is working. Now If I could just get the damned PCM Volume up.

This was the basic procedure:

I went into Mandrake Control Center> Hardware> Hardrake> nForce Audio Codec Interface> Run Config Tool Button(draksound), and made sure "ALSA" snd-intel8x0 was selected as the driver.


I made sure that the module was loaded with in root console:
modprobe snd-intel8x0


I made sure my modules.conf had it loading properly, it looks like this (only the sound info shown):

#begin code#
alias snd-card-0 snd-intel8x0

# ALSA portion
alias char-major-116 snd
# module options should go here
# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-intel8x0
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
above snd-intel8x0 snd-pcm-oss
#end code#


I turned up all my volumes, and plugged in a mic and had sound. Then stored the settings.
I ran in root console:
alsamixer
alsactl store 0


Now if I can just get my PCM Volume to budge I will be ready to rock.
Anyone know how to get the PCM Volume to budge?

Alex

GoinEasy9 03-19-2004 10:40 PM

Thanks Alex

i'm gonna play around with your suggestions...did u delete the oss modules before installing alsa? if u did please tell me how u did it.
damn i'm so close...lol
i will let u know how i did
although having to plug things into the mic port seems extreme...it should run thru the regular out port....
i swear that if i figure it out i'm gonna write a how-to so everyone else can see what i did

thanks again
Tom

dangerboy 03-20-2004 01:45 AM

Yeah mic ports aren't all that great, but desperate times call for desperate measures. lol
And no, I didn't delete the original oss drivers, I installed over them (smart? i don't know).

I just want to turn my PCM volume up is that too much to ask? :scratch: lol

Alex

dangerboy 03-22-2004 07:26 PM

Pokin around once again and I'm getting the feeling that something isn't installed right. I keep getting this error message when I run KMIX and I'm wondering if there is something that can be done:

Loading required GL library /usr/X11R6/lib/libGL.so.1.2
kbuildsycoca running...
Loading required GL library /usr/X11R6/lib/libGL.so.1.2
ERROR: kmix: Mixer cannot be found.
Please check that the soundcard is installed and that
the soundcard driver is loaded.

ERROR: kmix: Mixer cannot be found.
Please check that the soundcard is installed and that
the soundcard driver is loaded.

ERROR: kmix: Mixer cannot be found.
Please check that the soundcard is installed and that
the soundcard driver is loaded.

ERROR: kmix: Mixer cannot be found.
Please check that the soundcard is installed and that
the soundcard driver is loaded.

Not entirely sure what to think. I've looked at other posts, and still no definitive answers. If anyone knows a post that deals with this issue and this hardware, as well as ALSA, please post it. I'm a sound addict in need of my Linux Sound fix, literally. lol

Alex

GoinEasy9 03-22-2004 11:19 PM

if your using Manrake 9.2 you have to install Kmix with RPMdrak...
go into config --> software installation --> hit the button for looking at individual packages, not groups...then do a search for "Kmix"
it installs pretty easy..and if your computer is having a problem with the sound card...the Kmix window will be empty after the install

good luck

Aussie 03-23-2004 01:18 AM

What happens when you run "alsamixer" - and remember that linux is case sensitive.
I have a nforce2 mobo and my sound is working fine.

dangerboy 03-23-2004 11:18 AM

When I run alsamixer, I am able to graphically adjust all volumes and and store these settings with alsactl. It gives me no error messages whatsoever. Kmix seems to reflect these settings and I have yet to try Tom's suggestion. I'll let you know how that goes. Also, should I have arts running by default, or should it be disabled?

Alex

dangerboy 03-23-2004 11:31 AM

And as far as reinstalling kmix....... all the channels are there. So something else is amiss.

Alex

Aussie 03-23-2004 03:27 PM

Check the sound device permissions.

dangerboy 03-24-2004 12:28 AM

How do I do that exactly? I'm learning more and more, but permissions still have me confused.

Aussie 03-24-2004 01:34 AM

Have a look at "man chmod" for information on changing permissions, the devices you want to check are /dev/dsp*, /dev/midi*, /dev/mixer*, /dev/sequencer* and the device files in /dev/snd/.


All times are GMT -5. The time now is 06:02 AM.