-   Linux - Hardware (
-   -   'make' giving errors... (

bharathp 11-18-2009 10:36 PM

'make' giving errors...
Hi all,
I am tring to install a driver but resulted in some errors.


linux-dgu5:/home/bharath/microdia # make
make -C /lib/modules/ SUBDIRS=/home/bharath/microdia modules
make[1]: Entering directory `/usr/src/linux-'
make[1]: *** No rule to make target `modules'.  Stop.
make[1]: Leaving directory `/usr/src/linux-'
make: *** [driver] Error 2

what could be the problem? Are any packages missing. If so what to istall and what are the commands...


eth1 11-18-2009 11:26 PM

Did the ./configure process run without errors ? Check the README or INSTALL file inside the source directory for specific compile instructions.

bharathp 11-18-2009 11:38 PM

There was no ./configure that had to be executed..

this is what i was supposed to do...

git clone
cd microdia
sudo insmod ./sn9c20x.ko

knudfl 11-19-2009 08:29 AM

Used to work :

May be the linux- isn't sufficient ?
The package kernel-source-(2.6.27.xx-xx) may be required.

# zypper in kernel-source

bharathp 11-19-2009 09:57 PM

let me try it out...

bharathp 11-20-2009 07:29 AM

Hey thank you knudfl!!!

my problem got solved!!
yup, the kernel headers were missing. I installed them using YaST software manager. :)

bharathp 11-21-2009 07:59 AM

hey, the compilation went well but still no luck with the webcam. When i run 'cheese' the LEDs in my webcam blinks and then thats it.. I get a screen with color bands... What to do?

bharathp 11-21-2009 08:09 AM

Here is my out put with CHEESE and gqcam. Please Suggest Solutions!!



knudfl 11-21-2009 05:21 PM

As you can see in the other thread
.. she gave up , and bought another camera.

bharathp 11-21-2009 11:12 PM

Now there is a good trick :P.... Im off to buy logitech webcam...Thank you knudfl :)

All times are GMT -5. The time now is 06:43 PM.