LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Machine Check Exception 000000000000004 AND CPU context corrupt (https://www.linuxquestions.org/questions/linux-hardware-18/machine-check-exception-000000000000004-and-cpu-context-corrupt-370915/)

RCbeta 10-08-2005 09:08 AM

Machine Check Exception 000000000000004 AND CPU context corrupt
 
I have a working dual Xeon system that I was trying to upgrade to higher speed CPUs.

Current system:

IWILL DP533 motherboard (533 MHz FSB)
Dual 2.4 GHz Xeon Processors
1 GB RAM (2 memory sticks)

System has been working fine with the two 2.4 GHz CPUs. I do a fair bit of computational work, so I was going to upgrade the CPUs to 3.06 GHz, add more memory, etc. I purchased a "matched set" of CPUs off of ebay (yes - one takes their chances here).

The CPUs just arrived the other day and looked in good shape. I installed them, they started to boot, then the boot crashed with the following messages.

CPU1: Machine Check Exception 000000000000004
CPU0: Machine Check Exception 000000000000004
Bank0: e20000ff8c010400
Bank1: c00000000000145
Bank2: d10000000000153
Kernel Panic - not syncing: CPU Context Corrupt

I went into BIOS and changed to the safe/default settings. This set the CPU speed at abut 1.6 GHz. I had initially tried to boot up with a multiplier that gave a 3.06 GHz speed, that is when I got the above error. It would still NOT boot when I slowed it down to 1.6 GHz.

I did use thermal compound when installing the CPUs to insure good contact with the heat sinks. Once I removed those 3.06 CPUs and reinstalled the 2.4 CPUs the system booted without a problem.

All of this seems to me to indicate that the CPUs are not a matched set, or have issues ... particularly since I can put other CPUs back into the system and get it to work.

Thoughts? Comments? Suggestions? I am going to put one of the CPUs back in at a time and see if the 3.06 CPUs will boot one at a time. Then I will see how the BIOS monitors their temperature as they sit there, just to make sure the heat sink/fan combination is providing adequate ventilation.

Thanks in advance for any comments.

Randy

RCbeta 10-08-2005 01:58 PM

Update: Did more work with the CPUs and it appears that one of them is bad.

The system will boot with one of the CPUs installed and set to 3.06 GHz. Doing the same with the other CPU results in the system crashing - not booting. This happens no matter what speed the CPU is set at. System will boot on one of the 2.4 GHz CPUs without a problem as well.

So ... my conclusion is that one of the CPUs is bad.

R


All times are GMT -5. The time now is 01:08 AM.