-   Linux - Hardware (
-   -   LSI SAS RAID driver for Debian (

JMCraig 04-24-2008 03:30 PM

LSI SAS RAID driver for Debian
Hi Folks,

Anyone know where I can get a runnable version of this driver (or some more detailed instructions on building/installing it from source than what LSI provides--not enough for me to follow: too much is just assemed)?

The MB in question (with built-in RAID controller):
Supermicro H8DM3-2

LSI provides source code for their drivers (congratulations to them on that most excellent decision); the source is available here:

Anyone know of available binary or have some useful tips to go with the rather vague instructions on building the driver from source?

OK. With the help of a colleague, we built the driver and tried to install it in the kernel. Here's what /var/log/kern.log had to say about how that went:

Apr 29 06:35:27 localhost kernel: mptbase: no version for "struct_module" found: kernel tainted.
Apr 29 06:35:27 localhost kernel: Fusion MPT base driver
Apr 29 06:35:27 localhost kernel: Copyright (c) 1999-2007 LSI Corporation
Apr 29 06:40:22 localhost kernel: mptsas: Unknown symbol scsi_is_sas_phy_local
Apr 29 06:40:39 localhost kernel: mptsas: Unknown symbol scsi_is_sas_phy_local
Apr 29 06:40:53 localhost kernel: Fusion MPT SPI Host driver
Apr 29 06:41:01 localhost kernel: Fusion MPT misc device (ioctl) driver
Apr 29 06:41:01 localhost kernel: mptctl: Registered with Fusion MPT base driver
Apr 29 06:41:01 localhost kernel: mptctl: /dev/mptctl @ (major,minor=10,220)
Apr 29 06:41:03 localhost kernel: mptsas: Unknown symbol scsi_is_sas_phy_local
Apr 29 06:41:55 localhost kernel: mptctl: Deregistered /dev/mptctl @ (major,minor=10,220)

Presumably the "kernel tainted" just means that it's a non-standard module, but the scsi_is_sas_phy_local problem prevents it from loading and won't work. The kernel happily loads an earlier version of the "Fusion MPT" driver, but that one can't see the controller and

modinfo mptsas
suggest that the module supports 0050, 5504, 0056, 0058 and 0062

The controller is supposedly a model LSI calls a 1068e--but lspci reports:
02:00.0 SCSI storage controller: LSI Logic / Symbios Logic Unknown device 0059 (rev 04)

The kernel version in question is:

2.6.18-6-amd64 #1 SMP Sun Feb 10 17:50:19 UTC 2008 x86_64 GNU/Linux

Any suggestions most gratefully accepted.


JMCraig 06-30-2008 05:14 PM

Apparently were using source for kernel version that was ahead of the Etch kernel. Ended up messing up the install trying to load Lenny and discovering that it wouldn't handle the DB version I needed to run. Rats. Gave up on it while dealing with higher priority stuff.

JMCraig 07-02-2008 01:55 PM

Possible approach to solution
Hi Folks,

In case it may help anyone, see my post in the Red Hat distro forum from 2 Jul 2008:

It's quite possible that the same fix would work with Debian--or another recent distro, for that matter.


farslayer 07-02-2008 03:00 PM

I would also have recommended updating your pci-ids database,


Might have detect that controller properly then, instead of showing as 'Unknown device'

tiburcillo 09-29-2008 04:07 PM

The update-pciids command certainly helped.
Now the card is at least recognised:

02:00.0 RAID bus controller: LSI Logic / Symbios Logic MegaRAID SAS 8208ELP/8208ELP (rev 08)
Subsystem: Intel Corporation Unknown device 3002
Flags: bus master, fast devsel, latency 0, IRQ 10
I/O ports at ee00 [size=256]
Memory at fd9fc000 (64-bit, non-prefetchable) [size=16K]
Memory at fd9e0000 (64-bit, non-prefetchable) [size=64K]
[virtual] Expansion ROM at fd600000 [disabled] [size=2M]
Capabilities: [50] Power Management version 2
Capabilities: [68] Express Endpoint IRQ 0
Capabilities: [98] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Capabilities: [b0] MSI-X: Enable- Mask- TabSize=1

Still struggling with the driver though...

farslayer 09-29-2008 04:40 PM

Hmm looks like that card uses the megasr driver rather than the mptsas which I thought it would use..

Ahh it's a software based controller not a hardware based controller.. That's why it uses a diffrent driver..

Driver How-to:

Driver Source:

tiburcillo 09-30-2008 03:09 PM

Ok I've installed SLES10 SP1 (supported OS according to LSI site). I installed the driver rpm package but when i do fdisk -l, i still can't see the drives attached to the controller.
I just want to use it as sata controller, no raid. Anything else I need to take care of?

farslayer 09-30-2008 04:29 PM

you installed it, but is it loaded ?


if it's not loaded did you try loading it ?

modprobe megasr

did you read the installation instruction PDF from the LSI website ?

tiburcillo 10-01-2008 05:27 AM

I finally managed to load it, but only by reinstalling SLES 10 SP1. At the the start of the installation you have to press F5 and load the closed source driver from USB.
Then the controller is recognized. Performance however is very poor.
I guess next time i'll buy 3Ware or something to avoid all this misery. :/

farslayer 10-01-2008 08:20 AM

LSI makes great products, but you have a fakeraid controller, where the CPU is doing part of the work of the RAID. It's not so much the manufacturer of the card, but the Specs of the card, and the level of RAID you are trying to run. You will pay a premium for a true hardware RAID controller ($225-300 easy) however, but I think it's worth it if you are serious.

JMCraig 12-19-2011 04:43 PM

Current State of Affairs w/ LSI 1608-based controllers
In case anyone comes looking for info on these LSI 1608 or 1608e RAID controllers (either on-the-MB or on a card), the current mptsas drivers available in recent Linux distros still have not worked for me (but I'm dealing with an on-the-MB controller and the ones on actual cards may behave differently, for all I know).

With CentOS 5.5 or Ubuntu 10.04 LTS,
lspci shows the controller on the board as:

02:00.0 SCSI storage controller: LSI Logic / Symbios Logic MegaRAID SAS 8208ELP

The Fusion MPT drivers supplied with either of these OS's have not worked. The LSI MegaRAID driver (megasr) loads up as a driver (using the linux dd style pre-install driver load option for CentOS). There does not seem to be a driver that'll work with Ubuntu 10.04 LTS (or any distros other than RH or Suse or their derivatives--the RH drives work fine with CentOS, unsurprisingly).

The best site for downloading the drivers and other tools I've found is:

There's support for RH/CentOS versions up through 5.4 and Suse up through 11.

There are MPT drivers available for download on this page, but they are only for the earliest versions of the two distros: e.g. RH 5.0 or 5.1. I was not able to see if these worked; too much trouble trying to deal with the driver files (.dd of a floppy image, but the box has no floppy drive and I messed around with it for a while trying to get the files to work from a USB drive and had to quit to work on more pressing problems).

There's also firmware updates for the controller, but applying these did not make the distro-supplied mptsas driver functional (in my fairly cursory testing).

So, if you want this to work, as far as I've been able to determine, you'll need the MegaRAID (megasr) driver which is available for some versions/distros at the above link. Even though the info on the 1608 controller chip says it works with Fusion MPT drivers, that has not been my experience. The source for the megasr module is not available, as of this writing, so you can't compile it for newer versions or other distros.

All times are GMT -5. The time now is 06:29 PM.