-   Linux - Hardware (
-   -   Lost interrupts (

ardvark 07-11-2003 02:08 AM

Lost interrupts

I've been working with Linux (RedHat 7.2) for a little under a year now and have been able to do some basic stuff like installing
simple tar files and RPM's but I've got a long ways to go before
I'm as good with it as my Windows 98 machine. I have one
particular problem that has me stumped. I've been trying to
install an Iomega zip drive (on a Pentium II Dell with 98 MB's
of RAM,) and keep getting the "lost interrupt" error everytime
I plug it in to the rest of the system. Changing IDE cables has
made no difference nor has looking online for specific detailed
solutions. The computer itself sees it just fine and has labeled
it as HD 1. I don't even know where to begin with Linux to solve
this problem. Or is it a matter of, perhaps, changing some
jumper settings or having a zip disc in the drive while Linux is

I would REALLY appreciate some help with this!!!


whansard 07-11-2003 03:40 AM

i think i had a similar problem, and it was a kernel
issue. changing some kernel options or a different
kernel solved it. i can't remember what though.

ardvark 07-15-2003 01:10 AM


I appreciate the one response that I did get but it wasn't exactly
helpful. How would I go about adjusting the kernal, if that's
possible with my version and where would I look?


whansard 07-15-2003 03:16 AM

get new kernel source, compile your own

or search google for your motherboard or motherboard
chipset and the "lost interrupt" message you are getting.

ardvark 07-15-2003 02:08 PM

Compile my own?
I see, well, thanks anyway. That's a bit beyond my abilities
right now. Looks like I need some "hands on" help with this

:Pengy: <--- Unfortunately, this sums up my entire experience
with Linux and its end user support. If you guys
want this OS to "take over the world" and put
an end to Microsoft once and for all, you're going
to have to make it much more intuative and
palatable to the average computer user and get
over your smug, arrogant opinions of yourselfs
as the "elites." Tar.gz's don't cut it in the real world.

whansard 07-15-2003 03:26 PM

what the crap are you yelling at me for?
i've said nothing remotely arrogant.

i try to the best of my memory to say what the problem
was. you tell me i'm not being helpful.

you ask me where to get a kernel, and i tell you, and
you're calling me elitist.

try a newer version of linux that will have a newer kernel
in it. it may just be a problem with that older kernel.

i guess suggesting that makes me a complete
bastard huh.

ardvark 07-16-2003 01:08 AM

What the......??????
Hey, settle down! I wasn't yelling at you or calling you anything!
I was merely trying to make a general statement intended for the designers and programmers who make Linux. I have had a lot of
people (whom I've helped with systems) who have outright
refused to try Linux because of these issues and they are not in
any way "techies" or programmers, just average users who are
barely able to putt around in Windows. These are the folks that Linux should try win over, not the already open source die-hards.

Hey, you remembered what you could and I'm not putting you
down for that but it is not nearly the help I need. I'm not blaming
you for it. The current "support" system is based far too much
on newsgroups and BBB's, where you already have to know a
lot to even begin to understand what people are trying to say.
It took a little under a year to begin to understand the basic
fundamentals of how to use the OS somewhat proficiently besides
just clicking on icons.

Perhaps I should have made more clear that my diatribe was not
intended towards you personally. I'm sorry you took it that way.

whansard 07-16-2003 02:37 AM


installing a kernel is tough work, and i am fully aware
of that. as soon as you said, "where can i get a kernel?"
i sort of knew you were screwed, as far as that problem
goes. the "lost interrupt" things isn't a simple thing, and
i did some searching on the web for it, the same time
i suggested that you do, and i didn't find anything where
somebody had solved it, but i didn't really look very
there are some services you can download like
red-carpet from ximian, and there's another one, but
i forgot the name, that will download and install
software for you, but using that kind of stuff to change
your kernel is dangerous, and might leave your
system unbootable.
the fact that nobody else posted but me shows that
other people haven't any specific answers either.
i was trying to learn linux over 10 years ago, and would
end up extremely mad and yelling at the computer, but
i didn't have anyone to ask questions of.
my girlfriend uses windows, and i'm always having to
fix something on her computer, and just having to use
windows any puts me in a rage. Seriously, within 1 minute
of using any windows i'm usually yelling and cussing.

anyway, enough of that, you're not going to find much of
that elitist stuff at this site. i've been treated harshly
by people at freebsd sites. any question i would ask,
the answer was "read the handbook".

since i update my own kernel by compiling new ones
with what i consider cool patches like Con Kolivas
desktop tuning patches and stuff like that, i don't know
how to update your kernel safely a different way.

there is a cdrom image you can download called
knoppix, that runs all from the cdrom that is
wonderfully easy to use. if you have broadband access,
you could download and run that with your zip drive
hooked up and see if it works. that way you would know
if getting a newer kernel version even a whole newer
distribution would solve the "lost interrupt problem".

if that works, maybe somebody else will post how you
can easily get a new kernel version for redhat 7.2.
i don't know an easy, safe way. i think there are rpm
versions of the kernel at the redhat site, but you probably
should try any of them except the ones under your 7.2
version of redhat.

this page tell's you how to update kernels on redhat

this page has some updated kernels.

i don't know if this will fix your problem or not, but it
is something to try.

i just did a search on this site for lost interrupt,
and many threads came up. some with redhat 7.2,
and zip drives in them. maybe your answer lies there.

ardvark 07-16-2003 03:19 PM

Wow! Thank you for your help and suggestions! I apologize again
if it seemed like I was yelling at you, I should have made more of a distinction there. I'm still trying to reach those who are responsible for the production of various distros with some words
of reason and I find myself venting and raging as you did ten years ago. Thanks again!

Pimple 08-08-2003 12:04 AM

I get the same problem with a Redhat 7.2 box I am running with an IDE Zip 100. I have not been able to find a cure for it as yet so I boot the system with a zip disk in the drive and everything works fine. The only problem I get is that I have to reboot if I want to change zip disks.

All times are GMT -5. The time now is 05:09 AM.