-   Linux - Hardware (
-   -   Logitech s520 wireless keyboard and mouse started to work during upgrade to 9.10. (

KJM88 11-07-2009 08:12 PM

Logitech s520 wireless keyboard and mouse started to work during upgrade to 9.10.
I bought a logitech wireless keyboard and mouse. I plugged in the usb receiver and followed the directions. Nothing happened. I left it plugged in and continued to use the PS2 keyboard while trying to resolve the issue. During this time I decided to upgrade to ubuntu 9.10. When my machine began to configure itself for the upgrade, prior to the actual download and configuration I happened to jostle the wireless mouse and noticed that the cursor moved. I tried the keyboard and it also worked. I continued the upgrade and all worked perfectly. Sadly I was using my windows partition to view a streaming netflix film (pretty much the only reason I have windows!) and left the machine on over night. Windows did some kind of automated system upgrade and in the morning the keyboard and mouse no longer worked.I tried to undo the windows upgrade but it did not change anything. I have searched and experimented but to no avail.

I have an HP Pavillion ADM 64 Dual Core
S 520 wirele3ss keyboard and mouse.
Ubuntu 9.10

Any idea exactly what gets disabled prior to an upgrade that might effect change in the behavior of the keyboard or usb port? Would the answer be in Xorg The device is listed there so it is being detected. I am not that familiar with editing the configuration files so I would appreciate some direction.

Thank you.

business_kid 11-09-2009 04:26 AM

I don't have a clue where your machine stands. Reboot into ubuntu. Get 2 xterms open.
In one type sudo X -Configure (but don't press return)
In the other, dmesg |tail -f Wake up your wireless keyboard & mouse watching the dmesg o/p and as soon as you see the mouse &/or keyboard, press return on the X -Configure. Then restart X

KJM88 11-09-2009 01:21 PM

Thanks. But still having trouble
I set up the two terminals. I ran dmesg which gave me the following

murphy@murphy-dual-boot:~$ dmesg |tail -f
[ 1350.565255] sd 7:0:1:0: [sdb] START_STOP FAILED
[ 1350.565259] sd 7:0:1:0: [sdb] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
[ 1775.121043] usb 2-2.3: USB disconnect, address 4
[ 1777.762039] usb 2-2.3: new low speed USB device using ohci_hcd and address 5
[ 1777.874210] usb 2-2.3: configuration #1 chosen from 1 choice
[ 1777.890724] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:02.0/usb2/2-2/2-2.3/2-2.3:1.0/input/input6
[ 1777.890881] logitech 0003:046D:C517.0004: input,hidraw1: USB HID v1.10 Keyboard [Logitech USB Receiver] on usb-0000:00:02.0-2.3/input0
[ 1777.908055] logitech 0003:046D:C517.0005: fixing up Logitech keyboard report descriptor
[ 1777.910434] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:02.0/usb2/2-2/2-2.3/2-2.3:1.1/input/input7
[ 1777.910712] logitech 0003:046D:C517.0005: input,hiddev96,hidraw2: USB HID v1.10 Mouse [Logitech USB Receiver] on usb-0000:00:02.0-2.3/input1

I then hit return in the other terminal. It gave me the following:

murphy@murphy-dual-boot:~$ sudo X -configure

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

Please consult the The X.Org Foundation support
for help.

ddxSigGiveUp: Closing log

I hit Ctrl/Alt/Backspace(this is the command to restart X, correct? It is checked in my keyboard layout)

Nothing happened. I tried several times. Have I made a mistake?

Nothing seemed to change.

business_kid 11-10-2009 04:44 AM

No, You did nothing wrong, I did. I had better explain what I was trying to do. When you move one of those wireless mouse or keyboards, they come alive and traansmit. Sometimes there's actually suspend/unsuspend buttons on them. I was trying to get the registered on the usb bus, then configure X

Try the instructions I gave in 2 bash consoles with x not running. You can see the basic idea - with dmesg o/p they are registering on the bus (therefore awake).

All times are GMT -5. The time now is 12:41 AM.