LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Logitech MouseMan Wheel Optical in Fedora Core 1, kernel 2.6 (https://www.linuxquestions.org/questions/linux-hardware-18/logitech-mouseman-wheel-optical-in-fedora-core-1-kernel-2-6-a-140513/)

panickedthumb 01-30-2004 05:11 PM

Logitech MouseMan Wheel Optical in Fedora Core 1, kernel 2.6
 
So I'm not new to this stuff, I've downloaded and compiled kernels before. But I just now got around to getting 2.6, and when I load it, the mouse doesn't work, so I decide to use the PS2 port and it ALMOST works but its really jerky. Kudzu automatically picks it up as a Generic PS2 mouse even though it's in the USB port, and I can't get it to work if I reconfigure it to NOT be a ps2. Any ideas?

panickedthumb 01-30-2004 05:33 PM

I might also add that I've tried everything on the board here that I could find, and none of it worked for me.

simbolo 01-30-2004 06:45 PM

Are you sure you chose the correct usb HCD for your motherboard selected in the kernel config under usb support.
USB Human Interface Device (full HID) support enabled, and
HID input layer support (USB_HIDINPUT) enabled?
and Bus Mouse Support (BUSMOUSE) enabled under character devices
and do u have gpm configured properly?

panickedthumb 01-30-2004 07:14 PM

I used "make oldconfig" so it kept the previous configuration except for the new features. So yes, it should be configured properly.

panickedthumb 01-31-2004 02:38 PM

So I tried the rpm from Fedora devel, and it installed fine, but when I restarted, exact same thing happened.

simbolo 01-31-2004 02:44 PM

red-hat is simple to use until something goes wrong :rolleyes:

panickedthumb 01-31-2004 02:47 PM

heh, yeah you're telling me. :) I've looked around and apparently I'm not the only one with the same problem, with the same mouse, same OS and same kernel. There ahven't been any solutions yet though, none that worked for me anyway. SOmeone sais that using IMPS/2 worked for them, someone said that going into the bios and changing the PS2 options worked (but as far as I can tell I don't even have that option). But nothing yet has worked for me. :( Hopefully someone can shed some light.

panickedthumb 02-01-2004 11:15 AM

Anyone else have any clue what it might be?

panickedthumb 02-02-2004 12:11 AM

I hate to keep bumping the thread, but someone has to know what's going on here... any help would be greatly appreciated.

snacky 02-02-2004 12:17 AM

Quote:

so I decide to use the PS2 port and it ALMOST works but its really jerky.
Sounds like it might be a problem which is addressed here:
http://kerneltrap.org/node/view/2199
Quote:

Problems:
~~~~~~~~~

I'm getting double clicks when I click only once.
My scroll wheel scrolls by two lines/screens instead of one.
My mouse moves too fast.

Solution:
~~~~~~~~~

Check your XFree86 config file.

You probably have two "mouse" entries there, one pointing to /dev/psaux and
the other to /dev/input/mice, so that you can get both your PS/2 and USB
mouse working on 2.4.

2.6 uses the input subsystem for both PS2 and USB, and thus both devices
will report events from both mice, resulting in doubled events.

Remove either the /dev/psaux or /dev/input/mice entry, depending what suits
you better for 2.4 compatibility should you ever need go back to 2.4.

panickedthumb 02-02-2004 11:26 AM

Cool deal, I'll try that out and get back to you

panickedthumb 02-02-2004 11:39 AM

Nope, same thing happened when I edited that out. I just don't get it! I'll just have to stick with 2.4 for the time being I suppose.

There are other topics on the board, at least one, where someone had this problem and fixed it, but what they did does nothing for me.

Unless I just can't find the PS2 section in my BIOS... I have an Aopen Athlon XP board with a VIA chipset, if anyone knows where that section would be, please let me know.

Or any other ideas as well.

panickedthumb 02-02-2004 02:10 PM

OK as far as I can tell, I got it to work pretty easily... I don't understand why... before, I heard you should turn on Plug n Play OS, and that didn't help, and now I just read to turn that OFF instead. So its back to the original configuration, but it works. Don't ask how. It just does.

snacky 02-02-2004 02:13 PM

I don't know either, but thanks for following up, it provides more info for others.

panickedthumb 02-02-2004 06:48 PM

that's why I did it :)


All times are GMT -5. The time now is 10:20 AM.