LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Logitech 10 button mouse, scrollwheel not working (https://www.linuxquestions.org/questions/linux-hardware-18/logitech-10-button-mouse-scrollwheel-not-working-95906/)

xlycer 09-23-2003 11:08 AM

Logitech 10 button mouse, scrollwheel not working
 
Ok, before the flames, I've read the other threads on here :D

I've been banging my head on this problem for about a week.

I cannot get my scrollmouse working in X Windows.

It's a fairly recently purchased Logitech MX500.

My XF86Config looks like:

Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMappping" "6 7"
Option "Buttons" "7"

I am not at this point interested in using imwheel (not worried about extra events, just want the scroll working)

Running xev before an xmodmap shows
- the 2 side buttons responding as button 4 and 5
- the scrollwheel does not raise an event
- none of the "extra" buttons raise an event

Running xev after running 'xmodmap -e "pointer = 1 2 3 6 7 4 5" shows:
- the 2 side buttons respond as buttons 6 & 7
- the scrollwheel does not raise an event
- none of the "extra" buttons raise an event

I've tried many different combos of XF86Configs & xmodmaps, but can't seem to get anything working wrt the scrollwheel.

I can move up and down in any window by default by using my side buttons, but it's more than a little annoying :)

fwiw:
- Running slack 9 something, recently moved to kernel 2.6.0-test-pre5
- Running gnome 2.something with metacity wm
- Running latest binary x build (not cvs build etc)
- have the mouse connected currently via a usb -> ps2 connector
- had tried usb before doing that with no difference in results
- had stock 2.4.20 kernel before moving to 2.6.0 test
- previously had a ms intellimouse optical working with all 5 buttons + scroll
- am not a newbie to this stuff, been running slack since v4.something :)

salparadise 09-23-2003 04:04 PM

i've not seen Z AxisMapping set as "6 7"

on mine it says "4 5"
and whe i tried slackware adding that to XF86Config did the trick

xlycer 09-24-2003 12:12 AM

Still not working after attempting that

Tried changing ZAxisMapping to "4 5", still not working, still same results.

xmodmap acts the same way :)

salparadise 09-24-2003 12:52 AM

what distro are you using ????

xlycer 09-24-2003 11:58 PM

slack 9 is the distro

xlycer 09-30-2003 10:26 PM

bumpity bump bump

Any other ideas? Anyone?

On a side note, I've seen other posts similar to this. One was solved by moving to debian?!

I wub my swack, really really don't want to change to a different distro to get my mouse working

ehdwuld 09-30-2003 10:55 PM

usb or ps2

someone else said they had the same trouble
unplugged the ps2 adapter , plugged in the usb
changed to the usb mouse in config

blinked twice and it worked

salparadise 10-01-2003 12:53 AM

on a side note...

isn't 10 buttons on a mouse just a tiny bit excessive

i mean
how many fingers have you got??

i've got 5 buttons on my mouse
2 are never used
3 is just right

just a thought

ehdwuld 10-01-2003 01:17 AM

hehehehehe

xlycer 10-01-2003 01:23 AM

Well, yes, 10 buttons is kind of excessive for regular use..

I'm a pretty heavy gamer (in windows anyways) - and it's nice to be able to remap those buttons to a letter/number, which allows real quick and easy non keyboard access to commands..

Although, I digress..

changing to usb makes no difference (pointing my device at /dev/input/mice now)

I've tried IMPS/2 for the protocol, and is actually worse, none of the extra buttons seem to work now

Using ExplorerPS/2, the top button (just above the wheel) now scrolls up (ie is button 4) and the forward side button scrolls down (ie button 5).. interestingly the other side button also maps out to button 4, and the button just below the wheel maps to 6. The button just below THAT maps to button 1. The other buttons respond as normal (ie: 1,2,3). Scrolling the wheel does not respond with an even in xev.

meh.. too tired to look at this more tonight, perhaps tommorow :)

Romendo 10-01-2003 03:27 AM

Not sure if I can help... I have a Logitech MX700. I thought it was the same as the MX500 except that it was wireless. However, I don't have 10 (!) buttons, only 8.

The mouse is connected through the USB receiver. The device is /dev/input/mice. I set

Option "Buttons" "5"
Option "ZAxisMapping" "4 5"

in XF86Config.

The mouse is working fine after boot - sometimes. I think there is a conflict between usbmouse and mousedev. Sometimes when I boot the mouse moves only up and down when I move it horizontally. Nothing else works, the buttons are kind of funky. Then I do:

rmmod usbmouse
insmod usbmouse

and the mouse works just fine. Left, right and middle click and the scrollwheel are fine. The other buttons work as well but I do not really know their proper function in Linux.

BTW, I am running Slackware 9.1 (also worked - even better - in 9.0).

xlycer 10-01-2003 10:16 AM

hmm.. never have tried "Buttons" "5", I'll give that a rip tonight..

And when I say 10 button mouse, I was meaning X style buttons (8 buttons + 2 for scrollwheel = 10). The mx500 is the same as the mx700, just not optical.

Thanks.

xlycer 10-01-2003 11:54 PM

Well.. tried 5 buttons as well, still no go :(

This is really strange, I've never before had problems like these...

Romendo 10-03-2003 01:21 AM

Which modules do you have loaded? I found out that usbmouse and mousedev and hid don't play along nicely. My mouse used to behave strangely (cursor moves up and down when moving mouse left or right). So make sure only one mouse module is loaded, preferrably hid and mousedev and no usbmouse. I also compiled usb support not as module and everything works like a charm.

jakudlaty 11-23-2003 09:57 PM

I've found a reason...
 
There is a driver in kernel 2.6 test, named: mousedev.c (drivers/input) , its a driver for "ExplorerPS/2". driver works good up to 5 buttons (but no more...) Im thinking, how (if it's possible) to change this code... i need 7 buttons


All times are GMT -5. The time now is 12:57 PM.