LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-21-2006, 11:55 PM   #1
mrfixit1951
Member
 
Registered: May 2005
Location: Ladysmith, WI USA
Distribution: FC14
Posts: 42

Rep: Reputation: 15
Lm_sensors & i2c errors on boot-up


This is starting to bug me, although it's not life threatening. When i boot up to FC3, kernel 2.6.12, ECS motherboard, Linux jumps to the text based boot complaining:
Starting lm_sensors: loading module i2c-viapro i2c-isa eeprom it87
Can't access procfs/sysfs file
[FAILED]
Unable to find i2c bus information:
For 2.6 kernels, make sure you have mounted sysfs and done
'modprobe i2c_sensor'!
[FAILED]
Well, one of the first things i did was search for files that contain 'procfs', i didn't find any. Second, i searched for 'sysfs' and ran across 2 broken links. Both of these are in the /usr/local/lib folder. They are: libsysfs.so, & libsysfs.so.2.
I don't know how to repair broken links, or if i really need to,so.
On to the cure that the kernel recommends. I looked in the fstab file and found : none /sys sysfs defaults 0 0.
Does this mean anything?
Then i tried the 'modprobe i2c_sensor', which seemed to go smoothly.
But i still get the annoying boot-up messages.
Like i said before, this is just annoying, 'cause gkrellm works just fine, showing CPU temp, and fan speeds, and everything else just fine.
Does anyone know of a cure for this?
 
Old 06-04-2006, 12:06 AM   #2
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 841

Rep: Reputation: 165Reputation: 165
Too bad no one could help you. I get the same errors.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
i2c and lm_sensors, sensors-detect johnnydangerous Fedora 2 03-15-2005 04:28 PM
Yet another lm_sensors errors question slitz Linux - Software 1 09-13-2004 09:33 AM
Tottaly confused with lm_sensors and i2c! Braveheart1980 Linux - General 1 03-04-2004 08:52 AM
lm_sensors and i2c install help Giallo998 Linux - Software 0 11-08-2003 12:16 AM
I2c & lm_sensors installation question. nidua18 Linux - General 1 10-16-2003 05:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration