LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 08-28-2003, 06:08 PM   #1
LooseCanon
Member
 
Registered: Aug 2003
Location: Canada
Distribution: RH, Fedora, Debian
Posts: 128

Rep: Reputation: 15
Liteon 52x cdrw - K3b doesn't see it as cdrw


hello,

I'll start this off with a quick rundown of my system config right now:
hda - Maxtor HDD
hdb - Maxtor HDD
hdc - Liteon 52x32x52x cdrw
hdd - LG 16x DVD
hde - Quantum Fireball HDD

In short, the problem is that during K3b setup, the program doesn't see my Liteon as a cdrw. Interestingly I can read CD's off it but when I try to setup K3b it sees it only as a CD drive.

Now, I read someplace that the version of K3b distributed with SuSE is "crippled" somehow, so I've already downloaded the new rpm and I'm ready to uninstall the SuSE distributed version and reinstall the version from K3b.
rpm -e k3b
and then rpm -ihv k3b.whatever.rpm

Next I read that CDRW's have to be emulated as SCSI devices - yes?
How is this so and where would I make the change for the system to see it as SCSI? /dev/fstab? would I need erase the current fstab entry for /dev/hdd (cdrw)?

Here's the result when I run (as root): cdrecord -scanbus
  • linux:~ # cdrecord -scanbus
    Cdrecord 2.0 (i686-suse-linux) Copyright (C) 1995-2002 Jörg Schilling
    cdrecord: No such file or directory. Cannot open '/dev/sg*'. Cannot open SCSI driver.
    cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
    cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

Since I'm running GRUB, here's the config file (menu.lst):
  • color white/blue black/light-gray
    default 0
    gfxmenu (hd1,0)/message
    timeout 8

    title Linux yay
    kernel (hd1,0)/vmlinuz root=/dev/hdb6 vga=0x317 splash=silent showopts
    initrd (hd1,0)/initrd

    title Winblows boo
    root (hd0,0)
    chainloader +1

    title floppy
    root (fd0)
    chainloader +1


and of course my fstab:
  • /dev/hdb6 / reiserfs defaults 1 1
    /dev/hdb1 /boot reiserfs defaults 1 2
    /dev/hdb7 /home reiserfs defaults 1 2
    /dev/hdb8 /var reiserfs defaults 1 2
    /dev/hdb5 swap swap pri=42 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    proc /proc proc defaults 0 0
    usbdevfs /proc/bus/usb usbdevfs noauto 0 0
    /dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
    /dev/dvd /media/dvd auto ro,noauto,user,exec 0 0
    /dev/fd0 /media/floppy auto noauto,user,sync 0 0
    /dev/hde1 /mnt/storage vfat defaults 1 0

Thanks for the help!

//Canon
 
Old 08-28-2003, 06:19 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 60
yes you need scsi emulation
so show the output of:
lsmod |grep ide-scsi
if nothing you can simply start off by typing (as root):
modprobe ide-scsi
if that works, you can append to the end of this line:
kernel (hd1,0)/vmlinuz root=/dev/hdb6 vga=0x317 splash=silent showopts hdc=ide-scsi
so add bootup it will initialize that..
 
Old 08-28-2003, 06:25 PM   #3
BenV
LQ Newbie
 
Registered: Jun 2002
Location: Netherlands
Distribution: Slackware 8
Posts: 21

Rep: Reputation: 15
The reason your CDRW drive isn't detected as CDRW drive is usually because SCSI emulation hasn't been turned on. (unless you use a 2.6 kernel).

In order to turn on SCSI emulation on a drive you'll have to add a kernel boot option "hdX=ide-scsi", where X is the drive letter.
In your case: "hdc=ide-scsi".
However, for this to work, generic scsi and scsi-cdrom support has to be enabled in your kernel.

I've never used GRUB, but from the looks of your config, I'd say you'd have to change "kernel (hd1,0)/vmlinuz root=/dev/hdb6 vga=0x317 splash=silent showopts", so it says:
"kernel (hd1,0)/vmlinuz root=/dev/hdb6 vga=0x317 splash=silent showopts hdc=ide-scsi"

Note that afterwards your drive will probably be called scdX in stead of hdX
 
Old 08-28-2003, 07:04 PM   #4
LooseCanon
Member
 
Registered: Aug 2003
Location: Canada
Distribution: RH, Fedora, Debian
Posts: 128

Original Poster
Rep: Reputation: 15
'k great, thanks, I'll try that. So I wouldn't have to change anything in /etc/fstab then? Would that line /dev/cdrom/ in fstab just interfere at all - should I erase it?

BTW, sorry for the dumb question, but what's the reason behind SCSI emulation for cdrw's?
 
Old 08-28-2003, 07:08 PM   #5
BenV
LQ Newbie
 
Registered: Jun 2002
Location: Netherlands
Distribution: Slackware 8
Posts: 21

Rep: Reputation: 15
The devices /dev/cdrom and /dev/dvd are probably just symlinks to the real device nodes. Therefore you might want to change those.
The reason for SCSI emulation? Probably because SCSI is easy to code for
 
Old 08-28-2003, 08:08 PM   #6
LooseCanon
Member
 
Registered: Aug 2003
Location: Canada
Distribution: RH, Fedora, Debian
Posts: 128

Original Poster
Rep: Reputation: 15
hmmm. something's not working...

1) - added "hdc=ide-scsi" to the menu.lst in GRUB bootloader
2) - added "/dev/scd0 /mnt/cdrw auto ro,noauto,user,exec 0 0" to my /etc/fstab

ran "cdrecord -scanbus" and I still get the message that /dev/sg* doesn't exist.

 
Old 08-28-2003, 08:36 PM   #7
BenV
LQ Newbie
 
Registered: Jun 2002
Location: Netherlands
Distribution: Slackware 8
Posts: 21

Rep: Reputation: 15
Can you check your boot procedure for any scsi related stuff or errors?
For instance, with my Plextor on /dev/hda I get something like:
Jul 26 12:35:18 benv kernel: hda: attached ide-scsi driver.
Jul 26 12:35:18 benv kernel: Vendor: PLEXTOR Model: CD-R PX-W2410A Rev: 1.04
Jul 26 12:35:18 benv kernel: Type: CD-ROM ANSI SCSI revision: 02
Jul 26 12:35:18 benv kernel: Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
Jul 26 12:35:18 benv kernel: sr0: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray

Also, what does K3B detect now?
 
Old 08-28-2003, 09:25 PM   #8
LooseCanon
Member
 
Registered: Aug 2003
Location: Canada
Distribution: RH, Fedora, Debian
Posts: 128

Original Poster
Rep: Reputation: 15
I keep getting an error at K3b setup - must be run as root.

I'm looking at the boot.msg now to see if there's anything in there.

Somethin weird goin on.
just to retrace my steps:

1) added "hdc=ide-scsi" (no quotes) to Grub
2) md /mnt/cdrw
3) added /dev/scd0 /mnt/cdrw auto ro,noauto,user,exec 0 0 to /etc/fstab
4) removed /dev/cdrom /mount/cdrom auto ro,nauto,user,exec 0 0 from /etc/fstab
5) made symlink ln -s scd0 cdrom in /dev

re-booted ... I get a couple of icons on my desktop (CDROM and CD Recorder (scd0 not mounted)) and I now I can't get at either.

something FUBAR-ed here.
 
Old 08-28-2003, 09:25 PM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 21,948

Rep: Reputation: 4315Reputation: 4315Reputation: 4315Reputation: 4315Reputation: 4315Reputation: 4315Reputation: 4315Reputation: 4315Reputation: 4315Reputation: 4315Reputation: 4315
To see the modules that are loaded:
/sbin/lsmod

You should have
ide-scsi
scsi_mod
 
Old 08-28-2003, 09:28 PM   #10
BenV
LQ Newbie
 
Registered: Jun 2002
Location: Netherlands
Distribution: Slackware 8
Posts: 21

Rep: Reputation: 15
Have you considered running k3b setup as root?
 
Old 08-28-2003, 09:37 PM   #11
LooseCanon
Member
 
Registered: Aug 2003
Location: Canada
Distribution: RH, Fedora, Debian
Posts: 128

Original Poster
Rep: Reputation: 15
ok, checked through the boot.msg and I didn't find any reference to anything like you mentioned.

Found:
ide_setup: hdc=ide-scsi

and waaaaay down in the file there's this:
"doneSetting up IDE DMA mode
/dev/hdc: Input/output error"

^^^^
that's because I forced DMA33 on it. If I take DMA33 setting off then this error goes away. but nothing else changes.

that's about it.. unless I'm looking in the wrong file. ?
 
Old 08-28-2003, 09:46 PM   #12
LooseCanon
Member
 
Registered: Aug 2003
Location: Canada
Distribution: RH, Fedora, Debian
Posts: 128

Original Poster
Rep: Reputation: 15
OK I'm in root now and started the K3b setup and I don't even see the drive at all. When I try to "add device" and specify /dev/scd0 I get an error "Could not find attached device at /dev/scd0".
 
Old 08-28-2003, 09:51 PM   #13
LooseCanon
Member
 
Registered: Aug 2003
Location: Canada
Distribution: RH, Fedora, Debian
Posts: 128

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by michaelk
To see the modules that are loaded:
/sbin/lsmod

You should have
ide-scsi
scsi_mod
hmmm.. don't have that... I do have this:
ide-cd
cdrom [sr_mod ide-cd]

scsi emulation doesn't seem to be loading at all here...

like I said.. something's FUBAR-ed...

Last edited by LooseCanon; 08-28-2003 at 10:06 PM.
 
Old 08-28-2003, 10:41 PM   #14
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 60
does anything happen when you do:
modprobe ide-scsi
if no errors occur, then type:
lsmod | grep ide-scsi
and see if it loaded...
 
Old 08-29-2003, 06:57 AM   #15
BenV
LQ Newbie
 
Registered: Jun 2002
Location: Netherlands
Distribution: Slackware 8
Posts: 21

Rep: Reputation: 15
Seems to me your kernel doesn't have scsi support...
So you might have to recompile your kernel with the options "scsi" [CONFIG_SCSI], "scsi-cdrom support" [CONFIG_BLK_DEV_SR] and "generic scsi" support [CONFIG_CHR_DEV_SG] enabled.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no K3B setup? so it doesn't recog. the CDRW Trinity22 Linux - Software 1 03-27-2005 11:25 PM
k3b and cdrw debora Fedora 8 10-15-2004 06:32 AM
k3b stops burning after about 1MB with aopen CDRW Ebel Linux - Hardware 5 07-18-2004 04:20 PM
CDRW Help shaun_bakker Linux - Hardware 13 04-29-2003 09:54 PM
Burn CD with k3b on Liteon 48x24x48 pixelV Linux - Hardware 5 03-21-2003 08:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration