LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Linux/WinXP Dualboot and Raid (https://www.linuxquestions.org/questions/linux-hardware-18/linux-winxp-dualboot-and-raid-199141/)

bluebox 06-29-2004 12:57 PM

Linux/WinXP Dualboot and Raid
 
Hi everybody,

I'm not sure whether this is the right board for my question - depending on the answer, it is either "hardware" or "software" or even "Microsoft".

As the topic states, I'm dualbooting with WinXP Pro and Linux (Suse9.1 Pro so far). Both OSes reside on a legacy IDE-harddisk attached to my Asus P4P800-Deluxe mainboard. This works flawless.

I have two additional harddisks attached to the onboard IDE Raid Controller of the P4P800 Deluxe. What I want to do is run these two harddisks in Raid1-mode with one partition for Linux an one partition for XP.

Using the Raid Controller to do this does not work, as there are no working Linux drivers to do Raid with the Via-Raid-Chip.

So I tried to use the Raid controller as regular IDE controller, put two partitions on each of the two disks and tried to use two partitons with Linux Multi Disk as Software Raid 1 and two partitons with WinXP "dynamic volumes" as Software Raid 1. This does not work either, as Linux MD does not recognise Windows Dynamic Volumes and Windows kills the Linux MD partitons when converting the harddisks to "dynamic".

So, is there a way to either teach Linux to handle "Microsoft dynamic Volumes" or to do a Software Raid with WindowsXP on legacy partitions? Or even any other way to do what I want?

tnx in advance,

bluebox

flysideways 06-29-2004 03:08 PM

Have you seen this http://www.viaarena.com/?PageID=297#raid ? The Asus website shows your mb as having a Via 6410 raid controller. If you can use the raid driver for each os and format they array in a format to which you can read and write from either os you should be in business. Suprisingly, Asus does not have a linux driver listed at their download page. Via has binaries and source, it looks like. They at least have instructions on compiling the driver. Maybe I should rethink my previous dislike of Via.

bluebox 06-29-2004 04:03 PM

Yes, you're right - the Raid controller is a Via VT6410,
but, no, the Via driver is not compilable. It's a ready compiled binary module with a source code wrapper and it's not usable for Kernel 2.6 and unstable for Kernel 2.4 (I tested it). Via will not give away neither their sourcecode nor a specification of the VT6410. There is a kernel patch of unknown origin that makes it possible to use the VT6410 as ordinary IDE controller, though.

This situation lasts since about one year, so there it no hope of a change. See this thread for further information:
http://forums.viaarena.com/messagevi...E=&STARTPAGE=1

As the Windows driver is not very stable either, I'm away from using the controller as hardware raid controller. I'm looking for a solution without Via made drivers.

Keep your dislike of Via - there are plenty of reasons for it. I supposed, there would be Asus support, but there is none.

flysideways 06-30-2004 11:49 PM

bluebox,

Bummer. I looked at your link. Doesn't look good. I did notice that someone mentioned getting a Promise Fastrack card for the raid. I've never used one as a raid controller in Linux though so I can't speak to its compatability. I have temporarily used one in ide mode until I got an ide card, also Promise. The Fasttrack TX2000 worked fine in FC2 in ide only mode, but I didn't need it as the install was only FC1 (no dual boot) and was a software raid.

My bad Via experience was an Asus a7v133 rev 1.04. I was only using windows on it when I first got it and the chipset drivers were so bad that it even corrupted floppies at about an 85% rate. Many 4in1 and bios updates later all was well but it sure was painfull getting there. I never was able to get any help from Asus' tech support. I don't know if they provide any better help today. Ironically, it now lives on as a FC1 raid 5 headless file server.


All times are GMT -5. The time now is 04:49 PM.