LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-13-2021, 01:11 AM   #1
Bepi
LQ Newbie
 
Registered: Sep 2021
Posts: 2

Rep: Reputation: Disabled
Linux Mint 19.1 internal microphone stopped working


Hello,

My internal mic worked up to 2 weeks ago and then it stopped working completely.
I have tested the mic under Windows 10 and it works.

I am using linux mint 19.1

See below some info I have gathered.

Screenshot from alsamixer:
https://ibb.co/zs3GqyF


Screenshots from pulseAudio Volume Control

https://ibb.co/QQPtVP1
https://ibb.co/2YtVh7W
https://ibb.co/Ydp4fvD



Screen Shot 2021-09-12 at 9.40.37 PM
Code:
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
Subsystem: Hewlett-Packard Company Sunrise Point-LP HD Audio

Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus ID: 00:1f.3
Sound Server: ALSA v: k4.15.0-20-generic
Code:
dmesg | grep snd
[ 42.548778] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 42.608378] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC236: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[ 42.608381] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 42.608382] snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[ 42.608384] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
[ 42.608385] snd_hda_codec_realtek hdaudioC0D0: inputs:
[ 42.608387] snd_hda_codec_realtek hdaudioC0D0: Mic=0x18
[ 42.608388] snd_hda_codec_realtek hdaudioC0D0: Internal Mic=0x19
[ 42.608389] snd_hda_codec_realtek hdaudioC0D0: Internal Mic=0x12
[ 43.133339] Modules linked in: rtl8821ce(OE+) 8821ce(OE) snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic snd_soc_skl snd_soc_skl_ipc snd_hda_ext_core snd_soc_sst_dsp snd_soc_sst_ipc snd_soc_acpi snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine intel_rapl snd_hda_intel x86_pkg_temp_thermal intel_powerclamp snd_hda_codec coretemp kvm_intel snd_hda_core snd_hwdep kvm irqbypass crct10dif_pclmul btusb btrtl btbcm btintel crc32_pclmul ghash_clmulni_intel bluetooth snd_pcm snd_seq_midi pcbc snd_seq_midi_event ecdh_generic snd_rawmidi aesni_intel aes_x86_64 crypto_simd glue_helper cryptd intel_cstate snd_seq intel_rapl_perf hp_wmi(+) wmi_bmof snd_seq_device snd_timer joydev input_leds intel_wmi_thunderbolt serio_raw snd cfg80211 soundcore shpchp mei_me mei intel_pch_thermal processor_thermal_device
[ 43.133547] Modules linked in: rtl8821ce(OE+) 8821ce(OE) snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic snd_soc_skl snd_soc_skl_ipc snd_hda_ext_core snd_soc_sst_dsp snd_soc_sst_ipc snd_soc_acpi snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine intel_rapl snd_hda_intel x86_pkg_temp_thermal intel_powerclamp snd_hda_codec coretemp kvm_intel snd_hda_core snd_hwdep kvm irqbypass crct10dif_pclmul btusb btrtl btbcm btintel crc32_pclmul ghash_clmulni_intel bluetooth snd_pcm snd_seq_midi pcbc snd_seq_midi_event ecdh_generic snd_rawmidi aesni_intel aes_x86_64 crypto_simd glue_helper cryptd intel_cstate snd_seq intel_rapl_perf hp_wmi(+) wmi_bmof snd_seq_device snd_timer joydev input_leds intel_wmi_thunderbolt serio_raw snd cfg80211 soundcore shpchp mei_me mei intel_pch_thermal processor_thermal_device
[ 3520.774530] snd_hda_intel 0000:00:1f.3: Unstable LPIB (65536 >= 32768); disabling LPIB delay counting
Code:
pacmd list-sources
2 source(s) available.
* index: 0
name: <alsa_output.pci-0000_00_1f.3.analog-stereo.monitor>
driver: <module-alsa-card.c>
flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: RUNNING
suspend cause:
priority: 1030
volume: front-left: 98304 / 150% / 10.57 dB, front-right: 98304 / 150% / 10.57 dB
balance 0.00
base volume: 65536 / 100% / 0.00 dB
volume steps: 65537
muted: no
current latency: 0.00 ms
max rewind: 64 KiB
sample spec: s16le 2ch 44100Hz
channel map: front-left,front-right
Stereo
used by: 11
linked by: 11
configured latency: 26.00 ms; range is 26.00 .. 371.52 ms
monitor_of: 0
card: 0 <alsa_card.pci-0000_00_1f.3>
module: 7
properties:
device.description = "Monitor of Built-in Audio Analogue Stereo"
device.class = "monitor"
alsa.card = "0"
alsa.card_name = "HDA Intel PCH"
alsa.long_card_name = "HDA Intel PCH at 0xb1228000 irq 129"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:00:1f.3"
sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
device.bus = "pci"
device.vendor.id = "8086"
device.vendor.name = "Intel Corporation"
device.product.id = "9d71"
device.product.name = "Sunrise Point-LP HD Audio"
device.form_factor = "internal"
device.string = "0"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
index: 1
name: <alsa_input.pci-0000_00_1f.3.analog-stereo>
driver: <module-alsa-card.c>
flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: RUNNING
suspend cause:
priority: 9039
volume: front-left: 65540 / 100% / 0.00 dB, front-right: 65540 / 100% / 0.00 dB
balance 0.00
base volume: 6554 / 10% / -60.00 dB
volume steps: 65537
muted: no
current latency: 0.37 ms
max rewind: 0 KiB
sample spec: s16le 2ch 44100Hz
channel map: front-left,front-right
Stereo
used by: 2
linked by: 2
configured latency: 40.00 ms; range is 0.50 .. 371.52 ms
card: 0 <alsa_card.pci-0000_00_1f.3>
module: 7
properties:
alsa.resolution_bits = "16"
device.api = "alsa"
device.class = "sound"
alsa.class = "generic"
alsa.subclass = "generic-mix"
alsa.name = "ALC236 Analog"
alsa.id = "ALC236 Analog"
alsa.subdevice = "0"
alsa.subdevice_name = "subdevice #0"
alsa.device = "0"
alsa.card = "0"
alsa.card_name = "HDA Intel PCH"
alsa.long_card_name = "HDA Intel PCH at 0xb1228000 irq 129"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:00:1f.3"
sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
device.bus = "pci"
device.vendor.id = "8086"
device.vendor.name = "Intel Corporation"
device.product.id = "9d71"
device.product.name = "Sunrise Point-LP HD Audio"
device.form_factor = "internal"
device.string = "front:0"
device.buffering.buffer_size = "65536"
device.buffering.fragment_size = "32768"
device.access_mode = "mmap+timer"
device.profile.name = "analog-stereo"
device.profile.description = "Analogue Stereo"
device.description = "Built-in Audio Analogue Stereo"
alsa.mixer_name = "Realtek ALC236"
alsa.components = "HDA:10ec0236,103c867c,00100002 HDA:8086280b,80860101,00100000"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
ports:
analog-input-internal-mic: Internal Microphone (priority 8900, latency offset 0 usec, available: unknown)
properties:
device.icon_name = "audio-input-microphone"
analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: no)
properties:
device.icon_name = "audio-input-microphone"
active port: <analog-input-internal-mic>
Code:
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC236 Analog [ALC236 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0
Code:
inxi -A
Audio:
Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
Sound Server: ALSA v: k4.15.0-20-generic
Code:
dmesg | grep Mic

[ 1.587409] microcode: Microcode Update Driver: v2.2.
[ 1.590986] Loaded UEFI:db cert 'Microsoft Windows Production PCA 2011: a92902398e16c49778cd90f99e4f9ae17c55af53' linked to secondary sys keyring
[ 1.591004] Loaded UEFI:db cert 'Microsoft Corporation UEFI CA 2011: 13adbf4309bd82709c8cd54f316ed522988a1bd4' linked to secondary sys keyring
[ 45.438049] snd_hda_codec_realtek hdaudioC0D0: Mic=0x18
[ 45.438050] snd_hda_codec_realtek hdaudioC0D0: Internal Mic=0x19
[ 45.438052] snd_hda_codec_realtek hdaudioC0D0: Internal Mic=0x12
[ 45.490185] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input8

I would be grateful if someone can help me.

1
Reply
 
Old 09-13-2021, 07:20 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 17,664
Blog Entries: 28

Rep: Reputation: 5499Reputation: 5499Reputation: 5499Reputation: 5499Reputation: 5499Reputation: 5499Reputation: 5499Reputation: 5499Reputation: 5499Reputation: 5499Reputation: 5499
For testing purposes, if this machine has an external mic jack, does the external work with Mint?

Also for testing purposes, you might try booting to a Live CD/USB of something not *buntu and seeing whether the mic works.

Last edited by frankbell; 09-13-2021 at 07:23 PM.
 
Old 09-14-2021, 01:19 AM   #3
Bepi
LQ Newbie
 
Registered: Sep 2021
Posts: 2

Original Poster
Rep: Reputation: Disabled
I have tested it under Windows 10 and it works
I have tested it with a Live USB (Linux mint 19.3) and it works
I have used and external mic and I can see the volume moving

https://ibb.co/C5BDG7d

although I do not know what it is doing as I am not speaking and when I speak it does not make any difference.

When I unplug the external mic it is dead

https://ibb.co/QNpFRzZ


Thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[CLOSED] Using Alsamixer on Dell E5450 Laptop in Linux Mint 19.1 to Select Internal Microphone julianvb Linux - Software 10 01-21-2019 07:40 AM
Internal microphone stopped working (Lenovo T400) kwangel Linux - Newbie 4 04-29-2018 03:26 AM
[SOLVED] Neither internal nor external microphone functioning. Not even USB Microphone (Debian Jessie) achim_59 Linux - Hardware 3 08-14-2016 10:48 AM
mono sound and no microphone stopped working matters Slackware 7 03-21-2008 05:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration