LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 05-29-2008, 05:49 PM   #1
abecedarian
LQ Newbie
 
Registered: Mar 2008
Posts: 6

Rep: Reputation: 0
Laptop with "ImExPS/2 Generic Explorer Mouse" touchpad


I bought a nice laptop a few months ago, worth about $650, barely 8 months old, and in mint condition, but sold at half price because the last user had installed Linux of it and rid it of any Windows product key, license, install, or CD.

Problem is, it doesn't use a synaptics touchpad. Observe:
Code:
$ cat /proc/bus/input/devices 
I: Bus=0017 Vendor=0001 Product=0001 Version=0100
N: Name="Macintosh mouse button emulation"
P: Phys=
S: Sysfs=/devices/virtual/input/input0
U: Uniq=
H: Handlers=mouse0 event0 
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/devices/platform/i8042/serio0/input/input1
U: Uniq=
H: Handlers=kbd event1 
B: EV=120013
B: KEY=4 2000000 3803078 f800fc11 feffffdf ffefffff ffffffff ffffffff
B: MSC=10
B: LED=7

I: Bus=0011 Vendor=0002 Product=0006 Version=0000
N: Name="ImExPS/2 Generic Explorer Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input2
U: Uniq=
H: Handlers=mouse1 event2 
B: EV=7
B: KEY=1f0000 0 0 0 0 0 0 0 0
B: REL=143

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=LNXVIDEO/video/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input3
U: Uniq=
H: Handlers=kbd event3 
B: EV=3
B: KEY=3f000b 0 0 0 0 0 0 0

I: Bus=0019 Vendor=0000 Product=0002 Version=0000
N: Name="Power Button (FF)"
P: Phys=LNXPWRBN/button/input0
S: Sysfs=/devices/virtual/input/input4
U: Uniq=
H: Handlers=kbd event4 
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0019 Vendor=0000 Product=0005 Version=0000
N: Name="Lid Switch"
P: Phys=PNP0C0D/button/input0
S: Sysfs=/devices/virtual/input/input5
U: Uniq=
H: Handlers=event5 
B: EV=21
B: SW=1

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button (CM)"
P: Phys=PNP0C0C/button/input0
S: Sysfs=/devices/virtual/input/input6
U: Uniq=
H: Handlers=kbd event6 
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0019 Vendor=0000 Product=0003 Version=0000
N: Name="Sleep Button (CM)"
P: Phys=PNP0C0E/button/input0
S: Sysfs=/devices/virtual/input/input7
U: Uniq=
H: Handlers=kbd event7 
B: EV=3
B: KEY=4000 0 0 0 0
I've googled around and it seems like the synaptics driver is the only driver out there. My Xorg.conf is just using the "mouse" driver at the moment, and while it works, movement is erratic and not at a constant speed, and I can't get a scrollbar down the side of the pad.

If it helps, I have no idea what model my laptop is. It's a Lenovo, but that's all I know. I've tried to identify using the Lenovo site, but I can't find any identification or valid serial numbers anywhere on it.

Any help would be appreciated.
 
Old 05-30-2008, 03:00 PM   #2
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 552Reputation: 552Reputation: 552Reputation: 552Reputation: 552Reputation: 552
As for getting some identity info from the machine, try the lshw command. If you do not have it, get it from sourceforge.

For the mouse, not sure if it will help, but try the "imps/2" driver, or just the "ps/2" driver in your xorg.conf.
"man xorg.conf" may have other options that way or may not work.

Good luck!
Sasha
 
Old 01-04-2010, 02:44 PM   #3
m.pike1
LQ Newbie
 
Registered: Jan 2010
Posts: 5

Rep: Reputation: 0
Hey,

I have exactly the same problem, the mouse is all but unusable in exactly the same manner. I noticed this thread seems kinda dead but i really need help, I have tried both suggestions here and got no change. I have a little bit more information that the previous post though. I am using a Zoostorm Freedom laptop (same mouse type listed in /proc/bus/devices/input) using the distro Vector Linux. I have tried changing the xorg.conf with no avail, i have tried almost everything, please help.


Cheers

Martin
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Installing the "linux-headers-2.6.22-14-generic" update. solitaire Linux - Newbie 1 02-15-2008 08:09 PM
Chinese laptop "Founder"," unichrome Pro" graph card drivers? Sirr Linux - Laptop and Netbook 3 07-14-2007 01:31 AM
Touchpad recognized as "Logitech Wheel Mouse" j2f Linux - Hardware 0 01-14-2007 09:54 PM
"Back" and "Forward" side-buttons of my mouse Unforgiven79 Linux - Hardware 1 10-31-2006 12:10 AM
laptop mouse and "eraser" problems jsfour Slackware 3 03-14-2004 04:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 08:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration