-   Linux - Hardware (
-   -   LAN drivers on Slack 11 not working (Sony VAIO) (

whitesnake190684 07-16-2007 10:41 PM

LAN drivers on Slack 11 not working (Sony VAIO)

I installed Slackware 11 like three months ago and I just can't get my network to work, I tried a lot of things, I even changed my kernel around 3 times, I'm using a Sony VAIO laptop, I've been looking around to find the appropriate drivers and a guide about how to install them but I'm going INSANE!!! can you please point me in the right direction?? I would love to stop using Windows but I'll do it until I can get the network to work.

Thanks for your time.

Bruce Hill 07-17-2007 03:49 AM

Welcome to LQ!

Please post the output of /sbin/lspci from a terminal/konsole/xterm.

Use [_code] without the underscore (_) before your output, and [_/code] without the underscore after your output.

P.S. Your post should be in the Slackware forum, or Hardware, but not Software.

b0uncer 07-17-2007 03:57 AM

The drivers would probably work if there was correct kind of hardware around. VAIOs are troublematic, in my experience, but not impossible to work with :) post the lspci output, like asked, and it might not hurt to

too; with these you can find out what kind of hardware you have (the ethernet card type/model/chip), and then go on to thinking what kind of software you need for that hardware.

reddazz 07-17-2007 08:55 PM

Moved: This thread is more suitable in Linux Hardware and has been moved accordingly to help your thread/question get the exposure it deserves.

whitesnake190684 07-19-2007 01:42 AM


Sorry for the delay, I ran those commands today but now I have another one :( I can't share information between my linux partitions and Windows, I can see the files in Windows from Linux but not the other way around, do you know if editing the fstab file would do?? if should the line look like??

thanks again for your help

Bruce Hill 07-19-2007 01:51 AM

Windows is blind to Linux file systems. Microsoft does not want it's users to have anything to do with *nix, therefore, they are not going to code it to see Linux file systems.

You can use Samba to see those file systems from Windows -- I think that's it.

If I'm understanding you, the object is to write to a Windows partition from Linux so that you can post this information. (You could put the files on an USB flash disk or something.)

This is my /etc/fstab file for this Slackware computer (one of many):

mingdao@silas:~$ cat /etc/fstab
/dev/sda5        swap            swap        defaults        0  0
/dev/sda6        /                reiserfs    defaults        1  1
/dev/sda7        /usr            reiserfs    defaults        1  2
/dev/sda8        /home            reiserfs    defaults        1  2
#/dev/sda1        /WinXP          ntfs        ro              1  0
/dev/sda1        /WinXP          ntfs        users,umask=1000,ro,auto  1  0
/dev/sda2        /Shared          vfat        users,umask=1000,rw,auto  1  0
/dev/sda4        /Ghost          vfat        users,umask=1000,rw,auto  1  0
/dev/cdrom      /mnt/cdrom      auto        noauto,users,ro  0  0
/dev/fd0        /mnt/floppy      auto        noauto,users    0  0
devpts          /dev/pts        devpts      gid=5,mode=620  0  0
proc            /proc            proc        defaults        0  0
# Added 05Nov06 for DVD burners and USB sticks
/dev/hda        /dvd1            auto        noauto,users,ro  0  0
/dev/hdc        /dvd2            auto        noauto,users,ro  0  0
/dev/sdb1        /usb1            vfat        noauto,users,rw,umask=1000  0  0
/dev/sdc1        /usb2            vfat        noauto,users,rw,umask=1000  0  0
# Mount point for NFS # /serverhome nfs auto,rsize=8192,wsize=8192,hard,intr 0 0 /server1 nfs auto,rsize=8192,wsize=8192,hard,intr 0 0 /server2 nfs auto,rsize=8192,wsize=8192,hard,intr 0 0
# Next line added for kqemu - it will not harm your system
none                    /dev/shm                tmpfs  size=1040M        0 0
# For viewing NTFS drives in USB enclosure #
/dev/sdb1        /mnt/hd          ntfs        noauto,users,ro  0  0

Normal users can read and write to /Shared and /Ghost, but only read /WinXP. All three of those Windows file systems are mounted automatically. Writing to a NTFS file system is still considered experimental by most, and requires a lot of care to keep from trashing the NTFS partition.

All times are GMT -5. The time now is 09:44 AM.