LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 01-29-2019, 02:53 PM   #1
BillMess
LQ Newbie
 
Registered: Jan 2019
Posts: 8

Rep: Reputation: Disabled
Lag with the open source AMDGPU graphics drivers


I'm having issues with graphics on my system. The operating system itself is fine, but while running applications like Blender, Godot and Inkscape, there is a noticeable lag between moving the mouse and the content in the viewport moving. In Windows, it feels instantaneous.

I've tried installing both the stable and unstable drivers from the Padoka PPA. I've also tried many different distros like Manjaro, Linux Mint, Ubuntu, Ubuntu Studio, and Fedora, but it still behaves the same.

The only thing that seems to fix it is using Ubuntu 18.04 and installing the proprietary amdgpu-pro graphics drivers. However, I would prefer to use Manjaro and to not have to use the proprietary drivers.

My system is running an Intel Core i7-4790k cpu, 8GB DDR3 ram, ASUS AMD R9 285 graphics card, and an ASUS Z97-A motherboard.
 
Old 01-29-2019, 05:35 PM   #2
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,195

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
If running Ubuntu or Debian or a Debian derivative, do this and provide the link it provides here:
Code:
pastebinit /var/log/Xorg.0.log
You might need to install pastebinit first. Other distros have similar commands, such as openSUSE's susepaste. Manjaro's could be named pastebinit as well. Or just go to any of the pastebin sites and upload /var/log/Xorg.0.log for us to look at. Pasting in here output from:
Code:
inxi -Gxx
in code tags ([#] above the input window) should give us the PCI ID and driver situation of your R9. Look for error messages in
Code:
dmesg | less
Whatever you might see there relating to mouse problems you can grep from dmesg and paste here. If you feel the need to share all of dmesg, use pastebinit. Clues to mouse trouble might also be spotted doing
Code:
journalctl -b
in similar fashion to dmesg.
 
Old 01-30-2019, 04:01 PM   #3
BillMess
LQ Newbie
 
Registered: Jan 2019
Posts: 8

Original Poster
Rep: Reputation: Disabled
Here is the link from "pastebinit /var/log/Xorg.0.log"

http://paste.ubuntu.com/p/hCvq8vP3DQ/

Output from
Graphics: Card: Advanced Micro Devices [AMD/ATI] Tonga PRO [Radeon R9 285/380]
bus-ID: 01:00.0 chip-ID: 1002:6939
Display Server: x11 (X.Org 1.19.6 )
drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa,radeon)
Resolution: 1920x1200@59.95hz
OpenGL: renderer: AMD Radeon R9 200 Series (TONGA / DRM 3.23.0 / 4.15.0-44-lowlatency, LLVM 6.0.0)
version: 4.5 Mesa 18.0.5 (compat-v: 3.0) Direct Render: Yes
 
Old 01-30-2019, 04:31 PM   #4
BillMess
LQ Newbie
 
Registered: Jan 2019
Posts: 8

Original Poster
Rep: Reputation: Disabled
I'm using Ubuntu Studio 18.04 with the default amdgpu graphics drivers. Also, the USB devices I'm using is a Cooler Master keyboard, a Razer Deathadder mouse (the original one), an Audient iD14 audio interface, and an Alesis Midi keyboard.

Here is the link from pastebinit /var/log/Xorg.0.log:

http://paste.ubuntu.com/p/hCvq8vP3DQ/

Output from inxi -Gxx:

Code:
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Tonga PRO [Radeon R9 285/380]
           bus-ID: 01:00.0 chip-ID: 1002:6939
           Display Server: x11 (X.Org 1.19.6 )
           drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa,radeon)
           Resolution: 1920x1200@59.95hz
           OpenGL: renderer: AMD Radeon R9 200 Series (TONGA / DRM 3.23.0 / 4.15.0-44-lowlatency, LLVM 6.0.0)
           version: 4.5 Mesa 18.0.5 (compat-v: 3.0) Direct Render: Yes
Here is the link for dmesg output:

http://paste.ubuntu.com/p/CsMqQfgDHG/


I did find this amdgpu error:

Code:
amdgpu 0000:01:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff
I also found several ACPI errors, whatever that means.
 
Old 01-31-2019, 12:30 AM   #5
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,195

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
(If you've never fully updated since installing, that's the place to start. #2: Tried a different pointing device?)

Quote:
Originally Posted by BillMess View Post
Code:
Graphics: Card: Advanced Micro Devices [AMD/ATI] Tonga PRO [Radeon R9 285/380] bus-ID: 01:00.0 chip-ID: 1002:6939
	Display Server: x11 (X.Org 1.19.6 )
	drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa,radeon)
	Resolution: 1920x1200@59.95hz
	OpenGL: renderer: AMD Radeon R9 200 Series (TONGA / DRM 3.23.0 / 4.15.0-44-lowlatency, LLVM 6.0.0)
	version: 4.5 Mesa 18.0.5 (compat-v: 3.0) Direct Render: Yes
There is one difference between yours, and mine
Code:
Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Oland [Radeon HD 8570 / R7 240/340 OEM] vendor: Dell driver: amdgpu
	v: kernel bus ID: 01:00.0 chip ID: 1002:6611
	Display: tty server: X.Org 1.20.3 driver: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
	resolution: 1920x1200~60Hz
	OpenGL: renderer: AMD Radeon HD 8500 Series (OLAND DRM 3.27.0 4.19.0-1-amd64 LLVM 7.0.1) v: 4.5 Mesa 18.2.8
	compat-v: 4.4 direct render: Yes
that bothers me. I expect to see only one name between "driver:" and "(unloaded:". Both yours and mine have two. In yours, ati comes first. I expect not to see it at all for either of ours, but especially your newer GCN3 Tonga Pro. As an educated guess, either or both of two things might change it to amdgpu only, and might constitute a fix:
1-purge xserver-xorg-video-ati, making sure xserver-xorg-video-amdgpu remains; or
2-create /etc/X11/xorg.conf.d/20-amdgpu.conf containing the following:
Code:
Section "Device"
    Identifier "DefaultDevice"
	Driver	"amdgpu"
EndSection
Try first whichever you find easier.

Quote:
I did find this amdgpu error:
Code:
amdgpu 0000:01:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff
I also found several ACPI errors, whatever that means.
I'm not informed enough to know, but the 0xffff instead of 0xaa55 seems like a possible clue. ACPI errors seem to be no more than noise most of the time with hardware as new as yours. BIOS updates sometimes make them go away.

One possibility that I expect to be less than ideal but might constitute a clue if the above does not work, is to additionally purge xserver-xorg-video-amdgpu. Having neither the ati nor the amdgpu should cause the modesetting driver to load instead of either ati and/or amdgpu. Alternatively, just put it in place of amdgpu in the above 20-amdgpu.conf file, and change the name to 20-modeset.conf.

Less likely still, but worth a try if no joy, is if your display's setup menu has a setting to select between v1.1x and v1.2 and/or newer version of DisplayPort, try switching it.

Another low likelihood possibility: upgrade or downgrade firmware-amd-graphics. This I say due to Google hits I saw for "ib test on ring", which your dmesg has en masse.

If you get desperate, wiki.archlinux.org often leads to solutions.

https://lists.x.org/mailman/listinfo/xorg-driver-ati is how to reach the ATI driver writers. If no solution from my suggestions, someone else will have to figure it out. I'm out of ideas.

Last edited by mrmazda; 01-31-2019 at 12:40 AM.
 
Old 02-01-2019, 06:07 PM   #6
BillMess
LQ Newbie
 
Registered: Jan 2019
Posts: 8

Original Poster
Rep: Reputation: Disabled
None of your suggestions seemed to help, but I discovered that unchecking "Enable display compositing" in the XFCE Window Manager Tweaks settings seems to make Blender feel more responsive. But then everything has screen tearing, and it still doesn't feel quite as responsive as it does in Windows. I've tried installing the compton display manager, but it still behaved the same. I'll try contacting the ATI driver authors.

Even with the proprietary AMDGPU-PRO drivers, I'm running into issues with games, and with using LinVst and Wine to run Windows VST audio plugins for music production. I have discovered that using an older version of Linux (like Ubuntu 14) and the old Catalyst fglrx drivers makes everything feel just as smooth as Windows with no screen tearing. Maybe I could just use that as my OS in the meantime while I find a solution or just get a new computer.

Last edited by BillMess; 02-01-2019 at 06:10 PM.
 
Old 02-01-2019, 07:01 PM   #7
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,682
Blog Entries: 1

Rep: Reputation: 796Reputation: 796Reputation: 796Reputation: 796Reputation: 796Reputation: 796Reputation: 796
I have amdgpu on my laptop. I need to run debian TESTING (buster) or higher or it fails for gaming or other graphically intense things. But it works fine for me.

$ lspci -nnk
Code:
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Carrizo [1002:9874] (rev ca)
	Subsystem: Hewlett-Packard Company Wani [Radeon R5/R6/R7 Graphics] [103c:81f9]
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu
$ cat /proc/cpuinfo
Code:
model name	: AMD A10-9600P RADEON R5, 10 COMPUTE CORES 4C+6G
Granted a bit older of a system. A dual core 2.4GHz AMD CPU with 8GB of RAM.

Have you considered using ARCH? Isn't that what manjaro is based on these days? Normally when I get "NEW" hardware arch is the quick answer until it's 6+ months old and other distros catch up on versioning-s. I don't normally like arch though. Having to use things like sxiv instead of mirage for browsing images. Or slumming it in a web browser for file:/// browsing. Plus personal preferences like dhclient over dhcpcd. And other annoyances.
 
Old 02-01-2019, 07:35 PM   #8
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,195

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Quote:
Originally Posted by BillMess View Post
Maybe I could just use that as my OS in the meantime while I find a solution
No reason I can think of not to in the very short term, but 14.04 goes out of support in April. Does 16.04 have the same problem?

Quote:
or just get a new computer.
This can backfire. IMO yours is far from so old that it shouldn't just work like it did before, especially since Windows has no similar problem. Most of mine aren't as new as yours. New PC users OTOH, commonly take months to find out what will work as expected, after doing too little homework and buying hardware that's too new for FOSS support.

Various cmdline options for radeon and amdgpu exist for working around problems. Hopefully contact with AMD/ATI specialists will result in one that works for whatever distro, DE and version you prefer. I think there is a way to find out from cmdline what options are available for your hardware or kernel modules appropriate to it, if only I could remember enough to even search for it, modinfo maybe?

When and how did you discover the problem?
 
Old 02-01-2019, 11:36 PM   #9
BillMess
LQ Newbie
 
Registered: Jan 2019
Posts: 8

Original Poster
Rep: Reputation: Disabled
Aha! I found out that using Linux Mint 18.3 (which is based on Ubuntu 16.04) and using the default open-source amdgpu drivers seems to fix the issues with Blender, Inkscape, and Godot. I haven't tried seeing if it fixes the issue with LinVst yet, though.
 
Old 02-02-2019, 04:13 PM   #10
BillMess
LQ Newbie
 
Registered: Jan 2019
Posts: 8

Original Poster
Rep: Reputation: Disabled
Although Linux Mint 18.3 still doesn't fix the issue with LinVst, and I'm still having performance issues with games like Minecraft.
 
Old 02-04-2019, 05:28 PM   #11
BillMess
LQ Newbie
 
Registered: Jan 2019
Posts: 8

Original Poster
Rep: Reputation: Disabled
I found out how to fix it. I was trying all the different fixes found in https://wiki.archlinux.org/index.php/AMDGPU, and what fixed it inside Manjaro it was creating the file:

Code:
/etc/X11/xorg.conf.d/20-amdgpu.conf
and filling it with these contents:

Code:
Section "Device"
     Identifier "AMD"
     Driver "amdgpu"
     Option "DRI" "2"
EndSection
The wiki said the default value for DRI is 3, and setting it to 2 fixed it for some reason. What does that option mean, and is it a bug?

I haven't tested the fix in Ubuntu or Linux Mint yet, but Manjaro is the OS I want to use anyway. Blender and Godot feel just as responsive as it does in Windows now!
 
Old 02-04-2019, 05:52 PM   #12
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,195

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Quote:
Originally Posted by BillMess View Post
The wiki said the default value for DRI is 3, and setting it to 2 fixed it for some reason. What does that option mean, and is it a bug?
Like most software, major versions change from time to time. The previous version for DRI was 2, while the current is 3. Both are typically installed. Generally the calling software can figure out which is supported or required, but the hardware manufacturers make it hard by reusing references and names. For your R9 285 apparently v3 is called but is not supported properly, or at all, and needs the override you specified. It might be a bug that could be fixed if you would report your experience on gitlab.freedesktop.org.
 
Old 02-06-2019, 02:51 PM   #13
BillMess
LQ Newbie
 
Registered: Jan 2019
Posts: 8

Original Poster
Rep: Reputation: Disabled
I found the easiest solution. DRI3 can be disabled for a single program by running
Code:
env LIBGL_DRI3_DISABLE=1 <program name>
such as
Code:
env LIBGL_DRI3_DISABLE=1 blender

Last edited by BillMess; 02-06-2019 at 02:55 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Open-Source AMDGPU and ATI Linux Graphics Drivers Updated with New Features LXer Syndicated Linux News 0 09-20-2018 10:30 AM
LXer: Open-Source AMDGPU and ATI Linux Video Drivers Updated for AMD Radeon GPUs LXer Syndicated Linux News 0 09-14-2017 02:28 AM
LXer: Open Source AMDGPU and Radeon Linux Drivers Bring TearFree, DRI3 by Default LXer Syndicated Linux News 0 11-17-2016 01:00 PM
LXer: AMD Going Open Source with AMDGPU Linux Driver and GPUOpen Tools LXer Syndicated Linux News 0 12-15-2015 09:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration