LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   LaCie 500 usb external hard drive (https://www.linuxquestions.org/questions/linux-hardware-18/lacie-500-usb-external-hard-drive-620811/)

sheine 02-13-2008 07:36 AM

LaCie 500 usb external hard drive
 
I just bought a LaCie usb hard drive to use with a neuros osd. After getting nowhere with a linux format, I fell back to the required Windows format using WindowsXP. At first, I used the regular NTFS format and it did not work with neuros although it did work in Windows as a hard drive. When I called neuros technical support I was told to use a program called SwissKnife to format it as FAT32. With this format, I can put things on the hard drive using WindowsXP that neuros can use.

It seems to me that linux should be able to transfer information to a FAT32 drive. However, using three linux distributions, pclinuxos, ubuntu, and simply mepis, all see the drive but none give me simple access to it. As an example pclinuxos says that I do not have permission even though I have logged in as root. The other two let me in but when I try to view the pictures that I have put on the drive they cannot open them.

The interesting thing is that neuros itself uses linux as its operating system, but advertises itself as for Windows and Mac, no mention of linux. Is there same program available that will enable me to use this drive in linux?

b0uncer 02-13-2008 08:03 AM

FAT filesystem (FAT16 or FAT32) is generally used in external storage media such as USB-connected external harddisks, USB flash keys, memory cards and so on, because most systems nowadays can read and write to it without problems. Linux is no difference, I take it Mac neither, and Windows used it back in the Windows98/ME times; the move to NTFS was made after that on Windows side. Linux (ok, "Linux" is the kernel name, but I'll refer to the whole operating system with a Linux kernel with that name, because most people know it by that name) can nowadays access NTFS filesystems in read-only mode with ntfs driver, which it has been able to do for some time, or in read-write mode with another, newer, driver - Fuse I recall. That's not the case with all Linux systems, however, only some. Therefore for easy read/write access FAT is the desired filesystem, altough it has some major drawbacks compared to newer filesystems: it doesn't allow large single files, and it doesn't know of permissions (such as user/group). The largest single file you can create on a FAT32 filesystem is about 4 gigabytes in size (actually 4G minus one byte, or something like that - I'm not sure, but you get the idea); try to make it any larger, and an error pops up telling you it can't be done. Therefore if you have large files you either have to slice them down to <= 4G pieces, or use a filesystem that allows bigger file sizes (namely newer filesystems).

I have no experience about Neuros OSD, so I can't go further in detail; it seems to be some sort of a "media center" from the first view of their website, but I couldn't tell without more reading. Anyway - can you log on to it (or how do you know it runs Linux?), to see what drivers it's using?

I take it the manufacturer gave you a manual or something that describes what sort of storage media you can use with it. Then just use that media. You can format harddisks to different filesystems (like FAT for example) under Windows and Linux, and the number of tools is big. For example a graphical GParted program is easy to use on Linux, or you could just use (c)fdisk, or Windows system tools or PartitionMagic or whatever.. Windows and Linux should be able to access NTFS (on Linux if you use Fuse or something else to allow NTFS writing) and FAT, and with extra software installed to Windows, ext2 and ext3 filesystems which are native for Linux (naturally Windows doesn't know what they are). But like I said, what you need to use is up to what the Neuros thing "supports" - if it's FAT32-only, you have no other choice but to make the disk FAT32-formatted, even if it meant max. 4G file sizes.

Mounting harddisks under Linux is another matter then. Usually only root is allowed to mount new disks, by default. That can be changed. In the past disk mounting was done either manually, or automatically during boot procedure; hotplugging of devices worked in the sense that you plugged the device in and then typed your hands hot the commands to mount the media. Nowadays Udev (+ some system tools to pass the information) handles the automatic detection, informing of and mounting of new media on-the-fly; with Udev rules set right non-root users can access the media too, with the preferred permissions. On usual desktop operating systems such as Ubuntu the Udev rules are set so that when you (as a normal user) plug a device in, it gets mounted read-write for you automatically, unless somebody decided other way (an admin). If you have less "automatical" system, either ask the administrator to configure it or if you are the administrator, start reading manuals :)

sheine 02-13-2008 08:23 AM

From New York Times review:

The OSD has not only open hardware, but also open software: it is based on the Linux operating system. Neuros Technology encourages hacking of the device; it has contests with cash rewards for new applications for the OSD. One winner, for instance, designed a program that lets people use it to watch YouTube on their televisions.

b0uncer 02-13-2008 08:37 AM

Well, try hacking it to make it understand ext or NTFS filesystems :)

unSpawn 02-13-2008 08:47 AM

Quote:

Originally Posted by sheine (Post 3055603)
all see the drive but none give me simple access to it. (..) when I try to view the pictures that I have put on the drive they cannot open them.

If it's not a permission thing then maybe posting output of 'fdisk -l /dev/devicename' and exact errors when opening files could help.

sheine 02-13-2008 09:04 AM

[root@localhost ~]# fdisk -l /dev/sdb

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 1 60801 488384001 b W95 FAT32

sheine 02-13-2008 10:23 AM

Progress. I added the following line to /etc/fstab:

/dev/sdb1 /mnt vfat users,noauto,rw,exec,umask=033 0 0

Using pclinuxos, I can now view the pictures that I placed on the external hard drive using WindowsXP. However, it will not permit me to write to the hard drive. It denies me permission but I do not know where to change the permission.

sheine 02-13-2008 11:04 AM

Now that I have both pclinuxos and Simply Mepis allowing me to read the hard drive, I tried to change permissions to allow me to write. Every place that I can find, I have changed the permissions. But in Simply Mepis, when I tried mkdir, I got the following: mkdir: cannot create directory `/mnt/sdb1/Movies': Read-only file system.
Somewhere there is a ro but I cannot find it. I can write to the hard drive using WindowsXP.

JoeBorn 02-13-2008 01:23 PM

fat32 should work
 
Quote:

Originally Posted by sheine (Post 3055603)
The interesting thing is that neuros itself uses linux as its operating system, but advertises itself as for Windows and Mac, no mention of linux. Is there same program available that will enable me to use this drive in linux?

Well, I'm not an engineer for the project, but AFAIK, the device supports ext3 over USB well. It's just not normally suggested due to the compatibility issues with windows and mac.

I'm not sure why your Linux machines are having trouble with the FAT32 partition, it's beyond my ability to troubleshoot, but I can tell you that a FAT32 drive shuttling between the OSD and a Linux box is a setup used by a number of folks.

nerochiaro 02-13-2008 01:42 PM

Quote:

Originally Posted by sheine (Post 3055603)
Is there same program available that will enable me to use this drive in linux?

You should be able to use the standard linux command mkfs.vfat to format your disk.
Then your Linux machines, Windows and the OSD will be able to see it and access it just fine.

It works here, just tried it.

sheine 02-13-2008 01:46 PM

Quote:

Originally Posted by nerochiaro (Post 3055980)
You should be able to use the standard linux command mkfs.vfat to format your disk.
Then your Linux machines, Windows and the OSD will be able to see it and access it just fine.

It works here, just tried it.

Thanks I just discovered mkfs.vfat about an hour ago and it seems to be working. I have transferred pictures and music to the hard drive and they played through neuros. Now I am trying a movie.

nerochiaro 02-13-2008 01:49 PM

Quote:

Originally Posted by sheine (Post 3055777)
Progress. I added the following line to /etc/fstab:

/dev/sdb1 /mnt vfat users,noauto,rw,exec,umask=033 0 0

Using pclinuxos, I can now view the pictures that I placed on the external hard drive using WindowsXP. However, it will not permit me to write to the hard drive. It denies me permission but I do not know where to change the permission.

Maybe umask 000 will do the trick.
For more information on umask & company, check this guide here:
https://help.ubuntu.com/community/VolumePermissions

It's for ubuntu but i'm sure you will be able to translate to any distro.

rlhartmann 03-06-2008 12:53 PM

I am not familiar with PClinuxOS, but almost every one of the linux liveCD's create a generic username that the graphic environment runs as. Since FAT does not support multiple users you must mount the filesystem for the user you want to have write access to the drive.

The first step is to figure out who that user is. Each user has a name and a number. The number is refered to as the UID or user ID. To figure out the UID of your user, open up a terminal (or Konsole) window and type id this will report something like
uid=501(pclinux) plus some other information.

Now that you have this information, add the uid=501 line to your
fstab entry as:
/dev/sdb1 /mnt vfat users,noauto,rw,exec,umask=033,uid=501 0 0

This should allow you to both read and write to the FAT filesystem. Note, you will have to type
sudo mount -o remount /mnt (or restart pclinuxos) for this to take effect.

sheine 03-06-2008 01:45 PM

I tried Vista since I was getting nowhere with linux. It repaired whatever was wrong immediately. Since then I have been reading and writing to the disk with linux. I do not know what went wrong or whether I will have the trouble again.


All times are GMT -5. The time now is 10:24 PM.