-   Linux - Hardware (
-   -   KVM mouse glitch (

VxJasonxV 09-13-2003 01:00 AM

KVM mouse glitch
I have no idea why this is happening, but I'm wondering if anyone has any ideas.

I have a 2-port KVM (Belkin, if that helps).
Port 1 to Windoze, Port 2 to RH (7.3).

Basically, whenever I switch to windoze, 1 second 'catch-up' for the mouse and keyboard, and it works fine, however, when I switch to Linux, the pointer spazzes out...horribly.

For example, I can switch off of Linux while the mouse is in the middle of the screen.
I'll switch off and then when I come back to Linux, the mouse moves normally for a few seconds, then (as long as I keep using the mouse) it will fly all over the screen quickly, but usually hit the corners and randomly left and right click.

When I have the 'desktop milage' applet on the desktop, it repeatedly gets reset because of the mouses erratic ness.

And, if I don't use the mouse, it will fly as soon as I do.


david_ross 09-21-2003 04:11 PM

I'm affraid that I had the same problem and couldn't find a fix. I just run woth 2 mice on the desk. I would love to hear if you ever get a solution.

Brian1 09-21-2003 05:30 PM

If you switch back to the Windose box does the mouse work fine there.

If it does what kind of mouse do you have?

I ran into a similiar problem with a kvm (Cybex 8port) and the keyboard. I have a Logitech wireless keyboard and rechargable optical mouse. Never had any problems from the keyboard because the kvm just just makes Winblows to think it is a plain keyboard and mouse. I decided to install the driver for the keyboard one day for Windose and make use of the extra keys. Driver loaded and installed fine. I switch back to one of my Linux boxes and whenever I hit the backspace key it would backspace and then the letter ' q ' would come back a second later. Backspaced again and the q came back. Or if the caps was one it would be a capital Q. I powered off and back on the kvm and the problem stopped but if I switch backed to Window$, and back to Linux the problem reoccurred. I went back to the Windose box and used a basic keyboard 102 key driver. Reset the kvm and no longer have a problem.

I would try to use basic keyboard and mouse drivers if you can on the Windo$e box and see what you get.

Good luck. Let me know how it goes.

VxJasonxV 09-22-2003 01:32 AM

No it never did it when I switched back to windows.
Although now I KNOW it's a setting issue.

I upgraded to RH9, and it doesn't do it anymore...

geoff_f 09-23-2003 05:32 AM

I have a different KVM switch (Serverlink SL-221) but have seen the same symptoms as VxJasonxV described, so will post here in case it helps someone.

The Serverlink SL-221 has a configuration screen where you can specify what sort of mouse is connected. The selection options are: None/2-Button/Wheel 2-Button/Wheel 4-Button/Auto. In Linux, there is also a section where you specify which mouse is connected. I have found that whenever these two settings become unsynchronised, the mouse behaves erratically as VxJasonxV described.

In my case I have to set the KVM to 'Wheel 2-Button' and set Mandrake 9.1 to 'Generic PS2 Wheel Mouse'. I found these settings to be compatible by trial and error. If either is changed, then it goes erratic. For example, after a town power failure, the KVM re-started with 'Auto' as the default setting, and the erratic behaviour returned. As a result, I couldn't control Mandrake (in KDE) using the mouse - couldn't shutdown, or anything. Once I remembered the KVM connection, I went into its config screen, changed the setting back to 'Wheel 2-Button' and mouse stability returned there and then (ie, without re-booting).

These settings change with Linux version and computer hardware. The other computer has a different motherboard, but with Mandrake 9.0 installed. The settings for it are '2-Button' for the KVM and 'Standard' for Mdk 9.0.

If your KVM has the means to specify what sort of mouse is connected to it, this may apply to you. (BTW, my mouse is a Microsoft Intellimouse 1.2A PS/2 Compatible, made by Gateway, in case it matters. The computer with Mandrake 9.1 has an ASUS A7S333 motherboard, and the Mandrake 9.0 computer has a Gateway motherboard (G6-266M))

n2vsb 09-26-2003 08:41 PM

I seem to be having the same problem that VxJasonxV was having although I am using RH9 and my Microsoft Intellimouse Explorer. It is connected to my KVM switch (Belkin 4-port w/audio) with the USB-PS2 adapter that they provide when you buy the mouse. When it happens the only way to resolve it is to CTRL+ALT+BACKSPACE. If anyone else has this problem and knows how to fix it, it would be greatly appreciated.



plisken 10-01-2003 08:26 AM

Running RH7 2.2.16-22, just using a basic switch, could switch between two boxes without as issue, but I receintly built a new kernel 2.4.22 and now when switching, the only way to get the mouse to respond again, is to restart X, CTRL/BCK_SPC etc.

plisken 10-10-2003 01:28 PM

Just compiled 2.6.0 and the problem has gone, but remains with 2.4.22 and also SuSE which runs 2.4.20 (I think)

VxJasonxV 10-10-2003 01:45 PM

It shouldn't be a Kernel issue with the 2.4.x series.

RH7.3 has the issue, and that's 2.4.18
RH9 does not have the issue, and that's 2.4.20-2.

...I would be willing to say it's a setting (XFree?) and not a Kernel issue.
Unless something hidden worked itself out then broke itself again, and was found and finalized in 2.6.

plisken 10-10-2003 05:06 PM

Seems strange that all was well with my RH7 2.2.16-22 and it was only after upgrading to 2.4.22 that I noticed the problem.

I am pretty happy with 2.6.0 though...

niederj2001 11-02-2003 11:09 AM

Using Suse 9.0 Pro, Belkin 4 port KVM, PS/2 intellimouse trackball.

When switching from Suse to Windows=Mouse works fine.
When switching from Windows to Suse=Mouse out of control.

Searching boards to find a resolution.

Any help is greatly appreciated.

recklessv 11-12-2003 10:53 AM

Using Dell wheel mouse and Fedora
I'm experiencing this too with Fedora Core Release 1 and a Belkin 4 port KVM switch. Switching from Linux to Windows works (mouse always works in windows regardless of how many switches). When I switch back the mouse flutters all over the screen when moved, menus popup everywhere, etc.

Did anyone here, save upgrading the Kernal find what settings may fix this? The mouse is listed in Fedora as a generic 2-button mouse. . .

Electro 11-12-2003 06:33 PM

I don't have server grade KVM but I have an Iogear Miniview 4-port KVM switch. It doesn't have any problems switching to Windows or LINUX computer systems. Sometimes my mouse glitches upon LINUX boot up, but when I shut down the system and power it up it works properly. I think there is a setting you can add to your XF86Config or XF86Config-4 configuration file. Below is what I have in my XF86Config file.

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/psaux"
    Option "ZAxisMapping" "4 5"

What I notice, certain mouse devices have their own way of sending their own data.

Sebboh 11-12-2003 09:58 PM

Belkin 4 port...

2 windows puters are fine. When I switched one to linux I see that same problem. Mouse is mad jittery, and the only fix is a X-restart as well...

J.W. 11-13-2003 12:50 AM

Belkin Omni-Cube 2-Port KVM, Linux on box A and Windows on box B, same [bleeping] problem with the mouse, but for me going from Win to Lin was fine, but Lin back to Win = mouse mayhem.

Solution: Linux on both boxes. Problem solved. -- J.W.

All times are GMT -5. The time now is 12:50 PM.