LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-19-2003, 07:48 AM   #1
cubeman
Member
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 35

Rep: Reputation: 15
KsCD doesn't work.


Problem:

Normal CDs worked fine after I included user mount in addition to the supermount option.

Audio CDs however, do not. Opening KsCD, the CD is not recognised. It is looks at /dev/cdrom, but this directory doesn't exist.

After a cat /etc/fstab I get the following:

/dev/hda5 / ext3 noatime 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda7 /home ext3 noatime 1 2
none /mnt/cdrom supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-15,code
page=850,unmask=0 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-15,sync,codepage=850,unmask=0 0 0
/dev/hda1 /mnt/windows vfat iocharset=iso8859-15,codepage=850,unmask=0 0 0
none /proc proc defaults 0 0
/dev/hda6 swap swap defaults 0 0

So I assumed the link would be /dev/scd0. That doesn't work either.

How do I get Mandy to play audio CDs!!!
 
Old 10-19-2003, 09:02 AM   #2
nirvanix
Member
 
Registered: May 2003
Location: Calgary, Canada
Distribution: Arch Linux
Posts: 194

Rep: Reputation: 30
You should probably create a symbolic link to /dev/cdrom as many programs will be looking for this device. Open up a console as root as do the follwing 3 commands:

cd /dev
rm cdrom
ln -sf scd0 cdrom
 
Old 10-19-2003, 09:15 AM   #3
cubeman
Member
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 35

Original Poster
Rep: Reputation: 15
Someone suggested that to me previously. Doesn't work =/

Although he used

ln -s /dev/scd0 /dev/cdrom

Would that make any difference?
 
Old 10-19-2003, 11:58 AM   #4
nirvanix
Member
 
Registered: May 2003
Location: Calgary, Canada
Distribution: Arch Linux
Posts: 194

Rep: Reputation: 30
It's the same action more or less, but using ln -s /dev/scd0 /dev/cdrom means you don't have to cd /dev first.
The -f option on the link command is 'force' which will override existing links.
My fstab table entry for my cd-rw is:

/dev/cdrom /mnt/cdrom iso9660 noauto,user,rw 0 0

With this and the symbolic link KsCD works fine. The audio CD doesn't need to be mounted before you play it - KsCD recognizes it as an audio cd right away. In fact, for me the audio cd doesn't 'mount' using the mount command like a data cd does.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MDV2006: kscd volume slide doesn't work? registering Mandriva 0 11-09-2005 09:44 AM
cd-rom won't work in kscd rip Slackware 3 12-08-2003 08:06 PM
Kscd bibilit Linux - Software 0 12-07-2003 11:38 AM
Kscd jdphjp Linux - Hardware 3 05-02-2003 10:04 AM
kscd won't work!! :( falcon56215 Linux - Newbie 0 01-26-2002 12:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration