-   Linux - Hardware (
-   -   Keyboard strange behavior (

trebek 09-16-2007 03:06 AM

Keyboard strange behavior
Hey there guys.

i write to you because something strange happened to my keyboard. The thing is that i can no longer press and hold a key so that i can get as many characters as i want until i drop the key. For instance, if i mistype something, i cannot press and hold backspace until i erase everything i typed wrong; or, i cannot press any of the arrow keys so that i can move around freely until i get to where i want to be.

I have my thoughts about it and i can only guess that something changed it the xorg.conf file, i don't know where else i should be looking for the problem.

If you can throw a little light or the fix for that matter, i would greatly appreciate it.

Thanks in advance for the aid.

raskin 09-16-2007 09:30 AM

Probably something like

Option "AutoRepeat" "500 30"

in Keyboard section should give reasonable behavior.

trebek 09-16-2007 02:32 PM

I just added that part to the keyboard section and nothing happened. I restarted X of course to make sure the changes took effect. But nothing happened.

I don't remember exactly how my initial xorg.conf file looked specifically for the keyboard sections, since it has always worked with the default settings. I just usually have to tweak the part for mouse, touchpad and video card part.

Any other suggestions would be greatly appreciated.

raskin 09-16-2007 04:01 PM

What does 'xset q' say about repeat? Are you sure your xorg.conf has only one keyboard section?

trebek 09-16-2007 05:43 PM

Output of xset q
Here's the output of the command you provided over there. Hope it helps you out.


Keyboard Control:
  auto repeat:  off    key click percent:  42    LED mask:  00000000
  auto repeat delay:  500    repeat rate:  30
  auto repeating keys:  00ffffffdffffbbf
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  51/10    threshold:  20
Screen Saver:
  prefer blanking:  yes    allow exposures:  no
  timeout:  0    cycle:  600
  default colormap:  0x20    BlackPixel:  0    WhitePixel:  16777215
Font Path:
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Standby: 1200    Suspend: 1800    Off: 2400
  DPMS is Enabled
  Monitor is On
File paths:
  Config file:  /etc/X11/xorg.conf
  Modules path: /usr/lib/xorg/modules
  Log file:    /var/log/Xorg.0.log

The part for 'auto repeat: off' maybe wrong, i am guessing here.

raskin 09-16-2007 10:05 PM

So, 'xset r on' switches autorepeat on? Maybe some program (window manager?) executes its own analog of 'xset r off'.. Is the problem the same in IceWM?

trebek 09-17-2007 02:00 AM

I tried that xset r on and it got fixed, i hope that it stays this way after a reboot.

Thanks too much for the help, i'll shout out if something else comes up.

raskin 09-17-2007 01:31 PM

Such things usually do not stay OK after reboot... So the question about IceWM is not discarded.

trebek 09-19-2007 02:26 AM

Hey, thanks for the help. I just downloaded kubuntu 7.04 and installed it, so i guess i will be ok for a while.

Either way, i learned a lot, LQ rules.

Thanks man.

All times are GMT -5. The time now is 07:45 PM.