LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-07-2014, 10:53 PM   #1
aihaike
Member
 
Registered: Feb 2006
Location: Shanghai, China
Distribution: Slackware
Posts: 214

Rep: Reputation: 15
Question keyboard issue SONY VAIO


Dear all,

I'm running Slackware on a Sony Vaio ultrabook and after the installation I had to add
Code:
append=" vt.default_utf8=0 kbd-reset"
in lilo.conf in order to have the keyboard working.
It was working perfectly until some days ago when for some reason I have lost access to most of the key from boot stage. I can't even type "single".
The result is I can't login since just few key actually work.
I've just found however that hitting the Fn key allow me to get fully access to the keyboard.
The point is what is the cause of this and how to fix it.
Did someone have a similar experience?
Thanks,

Éric.
 
Old 03-10-2014, 08:47 PM   #2
insamniac
LQ Newbie
 
Registered: Aug 2007
Location: Evans, GA
Distribution: Slackware 12
Posts: 5

Rep: Reputation: 0
I'll have to confirm when I get home from work, but I put Debian on an old Vaio recently, and I thought there was a BIOS setting regarding the Fn key.

Of course that doesn't explain why the sudden change, unless your CMOS battery died and reverted to different settings or something..
 
Old 03-11-2014, 01:23 AM   #3
aihaike
Member
 
Registered: Feb 2006
Location: Shanghai, China
Distribution: Slackware
Posts: 214

Original Poster
Rep: Reputation: 15
Thumbs up

Hey Insamniac,

Thank you so much.
I checked the BIOS but did not find anything regarding the Fn key.
However, that fact to just get into the BIOS actually fixed the issue.
I have absolutely no idea about what was going wrong but it's solved.
Of course I'd happy to understand.
Thanks again,

Éric.
 
Old 03-11-2014, 11:31 PM   #4
insamniac
LQ Newbie
 
Registered: Aug 2007
Location: Evans, GA
Distribution: Slackware 12
Posts: 5

Rep: Reputation: 0
Haha, I'm glad I randomly popped on here for the first time in quite a while to provide an accidental solution. Glad to hear you got it sorted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Resolution issue with Sony Vaio laptop using Ubunta edgraham1 Linux - Newbie 1 04-25-2009 07:33 AM
Sony Vaio laptop VGN-TX2XRP keyboard issue dr_sad Linux - Hardware 2 01-12-2007 04:35 AM
Sony Vaio SZ140 ALSA issue Mizutsuki Linux - Hardware 3 08-01-2006 05:17 PM
keyboard does nor respond @installation (debian 3.1r1 @ sony vaio pcgk25 ) trelos Linux - Laptop and Netbook 1 04-02-2006 04:19 PM


All times are GMT -5. The time now is 05:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration